Jump to content

Recommended Posts

23 minutes ago, Church the Cat said:

Sorry, I'm not understanding. I play Skyrim SE v.1.5.97. I downloaded the new female version file you linked, but I don't see any UUNP Bodyslide files included.

Is a general message to make know the new version for SE since few users are being asking for a update.    Just as alert

 

I still have to finish the SE BodySlide for the Female Mod but the meshes included are good enough for today.

Link to comment
20 minutes ago, OsmelMC said:

Is a general message to make know the new version for SE since few users are being asking for a update.    Just as alert

 

I still have to finish the SE BodySlide for the Female Mod but the meshes included are good enough for today.

Ah, okay thanks. I will continue to wait for the UUNP Bodyslide update, with bated breath. ?

Link to comment

I'm having problems getting SLSO and your utility mod to work well together (LE). I think the enjoyment calculation is getting messed up somehow because the aggressor in aggressive anims always orgasms right after the start.

 

I just saw you recommend using the new SSE version of SLSO. What do I need to do to convert it, resave the esp?

 

Ok I still have the same problem with the latest SLSO and utility versions.

Edited by bnub345
update
Link to comment
2 hours ago, bnub345 said:

I'm having problems getting SLSO and your utility mod to work well together (LE). I think the enjoyment calculation is getting messed up somehow because the aggressor in aggressive anims always orgasms right after the start.

 

I just saw you recommend using the new SSE version of SLSO. What do I need to do to convert it, resave the esp?

 

Ok I still have the same problem with the latest SLSO and utility versions.

I get this too
I fixed it by doing a clean install of both
remove the esps of both and do a save clean (using a save clean util)

load clean save

make new save then install mods

 

Link to comment
6 hours ago, bnub345 said:

I'm having problems getting SLSO and your utility mod to work well together (LE). I think the enjoyment calculation is getting messed up somehow because the aggressor in aggressive anims always orgasms right after the start.

 

I just saw you recommend using the new SSE version of SLSO. What do I need to do to convert it, resave the esp?

 

Ok I still have the same problem with the latest SLSO and utility versions.

The enjoyment maths ar done on my Scripts and right now seems to be right. 

 

But you better disable on the SLSO the use of the Arousal value on the enjoyment function because if you start the scene with the actor arousal close to 100, obviously you will cum just starting.

 

Always make sure of overwrite the SLSO files with my SLU+. And with my Mod you don't need to convert the SE version of the SLSO because the only files that need some conversion are precisely the scripts already modified by my SLU+ 

Link to comment

Reinstalling from a clean save seems to have fixed it, as -alpha- suggested. And the furniture system works with slso now too, nice. Thanks for the help. 

 

@OsmelMC Since you're here, I know you have said the SSE version of SlaveTats is better then the LE version. What do you do to make it work on LE? I can select the tat categories, but the dropdown for the actual tats is empty.

Link to comment
1 hour ago, bnub345 said:

 

@OsmelMC Since you're here, I know you have said the SSE version of SlaveTats is better then the LE version. What do you do to make it work on LE? I can select the tat categories, but the dropdown for the actual tats is empty.

Is better and faster but you have to manually Refresh the Tattoo list each time you install a new tattoo pack because he not search for new tattoos like the LE version do.

 

To make it work on LE you need my Patch or the version released for both sky versions.

 

SlaveTats v1.3.5.2 (SE to LE Patch).7z

Edited by OsmelMC
Link to comment
6 hours ago, OsmelMC said:

But you better disable on the SLSO the use of the Arousal value on the enjoyment function because if you start the scene with the actor arousal close to 100, obviously you will cum just starting.

Seems pretty realistic to me ?.

Work a girl up enough and sometimes the first penetration is all it takes to make her start cumming lol.

Link to comment
On 11/30/2021 at 10:01 PM, greenmango12 said:

Thanks I will test again,, at current I do not try creature animation.. so maybe I can find it.. at same time,, so how I can confirm I save changes = made new animation then register?

 

actually I still not clear,,, how registered animation data will be saved... (or when saved it as permanent data)

 

I clear see,, my custom made test animation registered i n sexlab,  so I can choose the animation in game,,, just to confirm I usually when I add or remove my custom made animaiton (made by sexlab tools),, I export sexlab animation configure,, then save.. (though I do not know I really need this step..) or tose new json will be generated, when I simply click "register animation" from sexlab tool MCM menu?  

 

I think it is most easy understand,, how I generate new animation json... (if I can)

I can not find any new json, which seems related with the new animation..in MO2... the 2 animation file in pic,

one is tempalte,, (Arrok remvese cowgirl) and I do not know the other troll when I generate.. (it seems not my custom made one..)   

 

exjson.JPG.1948a397eb6ef2f7cc7fc109bffeedce.JPG

 

so I suppose I still not export  my custom-made animation..

 

 

 

Seems like that was not my last version. I check the one I'm using and the last edition to the scripts was the 2020-12-26 and the 2020-11-03 was my first modification with just the creature support.

 

This is the one I am using and still need the translation of the menus but have the Export to JSON option:

 

 

SexLab Tools v3.1 (20201226).7z

Link to comment
19 minutes ago, OsmelMC said:

 

Seems like that was not my last version. I check the one I'm using and the last edition to the scripts was the 2020-12-26 and the 2020-11-03 was my first modification with just the creature support.

 

This is the one I am using and still need the translation of the menus but have the Export to JSON option:

 

 

SexLab Tools v3.1 (20201226).7z 124.82 kB · 2 downloads

I thought actually if you happend to up-load old version with check your offered log txt (which added in default read me ^^;)

I have 2 or 3 other issue about animation creator and the tags..

, (but I think it is bug of default version), then I might hope you may check my report,, if you can find time,, try to make it more stable..

 

Untill you make this patch as official one (up-load on top page,, as same as other patch) I report in Sexlab tools SE topic, (but I use LE archived + your patch with SUP , so when you can find time,  hope if you can solve some issue about sexlab tools  anyway download and play again thanks!. ?)

Edited by greenmango12
Link to comment

@OsmelMC Looking further at the SLSO scripts, I think I know what the problem is. Both SLSO and SLU+ use sslActorAlias to modify the base Sexlab scenes. In the original SLSO script at lines 2153-4 have 

 

        if slaActorArousal < 0
            slaActorArousal = 0
        endIf

 

In your SLU+ script this is changed to (lines 2838-9)

 

        if slaActorArousal < 1
            slaActorArousal = 1
        endIf

 

This is forcing the enjoyment of both actors to 100% if they are less than 100%. That is why I was having problems with NPC's cumming immediately, because they should only be at 100% enjoyment at very high arousal values. I compiled the SLU+ sslActorAlias changing the values back to 0 and everything functioned normally. 

Link to comment
3 hours ago, bnub345 said:

@OsmelMC Looking further at the SLSO scripts, I think I know what the problem is. Both SLSO and SLU+ use sslActorAlias to modify the base Sexlab scenes. In the original SLSO script at lines 2153-4 have 

 

        if slaActorArousal < 0
            slaActorArousal = 0
        endIf

 

In your SLU+ script this is changed to (lines 2838-9)

 

        if slaActorArousal < 1
            slaActorArousal = 1
        endIf

 

This is forcing the enjoyment of both actors to 100% if they are less than 100%. That is why I was having problems with NPC's cumming immediately, because they should only be at 100% enjoyment at very high arousal values. I compiled the SLU+ sslActorAlias changing the values back to 0 and everything functioned normally. 

 

I will check but that just fix a 0 division error that make the enjoyment 0 when the arousal is less than 1. Remember that the arousal is not the same as the enjoyment. The arousal come from "SexLab Aroused" and for my point of view is irrelevant on the enjoyment but SLSO use it to calculate the enjoyment.

Link to comment
23 hours ago, OsmelMC said:

 

Seems like that was not my last version. I check the one I'm using and the last edition to the scripts was the 2020-12-26 and the 2020-11-03 was my first modification with just the creature support.

 

This is the one I am using and still need the translation of the menus but have the Export to JSON option:

 

 

SexLab Tools v3.1 (20201226).7z 124.82 kB · 15 downloads

Hi OsmeIMC thanks now I can find the new option to export json, in MCM Sexlab tool Animation  creator. then you said, you need to translation,

but if I use english only, (I usually not translate MCM menu etc,, because it may cause issue sometimes...

I could not export animation, which I created and registered.. it return this error

 

$animation not valid or need to be registered.

 

I just pick agressive type with race human, then choose 2 animation and mix up. with change stage.. do you think it is caused by MCM translation file?  (eg your saved tx file code as utf-8 etc).. what I did was.

1.  make animation name as ZZZTEST,

2. register animation.  

3. I confirm it was registered in Sexlab (SUP) MCM animation toggle.. (agressive),, I can find the animation as last page list.

4.  I clean cash, to confirm. (do not know it need or not though)

5.  then try to export.  with the $Export JSON,, (the labell already change I notice,,, with $ )

 

exportmiss.JPG.597952b39846f4827b8c67600d236780.JPG

 

I notice so you simply do not add those new funciton String Variable, then I added them (though I do not think we need it to script work,, just for visuall clean..) in translation file (English)...  but it may not relate with funciton error I suppose..

 

So there seems case,, script return error .. I will attach papyrus log,,,if you can check them.. I confirm animation work without problem though... (not test stage etc, at current,,I found stage sometimes not change as I made,,when I mix 2 or 3 animations, and set different stage.. (eg for stage 2. I use animationA stage4 etc)

btw,, are you OK,, if I ask or report about  your offered sexlab tools patch, in this topic?  ?

Edited by greenmango12
Link to comment
3 hours ago, Deutsche_Cookie said:

I can't equip tongues on my character, I added them in my inventory, but nothing happens while I click them. Expressions works fine tho (SE)

If your character is type Beast (Argonian or Kahit) you have to enable the Expressions for Beast and make sure that each one have the BeastOnly option enabled.

 

 

If is not Beast, make sure that the first 8 Ahegao Expressions be enabled and with the BeastOnly option disabled

 

Never enable the BeastOnly and the No Beast options on the same Animation

 

 

The test option allow you test the Animation on any actor Race so if the test is working then the only reason should be the the Beast options.

 

By the way the Tongues don't get equipped on the OpenMouth event or when you have a Gag equipped.

Link to comment
6 hours ago, OsmelMC said:

If your character is type Beast (Argonian or Kahit) you have to enable the Expressions for Beast and make sure that each one have the BeastOnly option enabled.

 

 

If is not Beast, make sure that the first 8 Ahegao Expressions be enabled and with the BeastOnly option disabled

 

Never enable the BeastOnly and the No Beast options on the same Animation

 

 

The test option allow you test the Animation on any actor Race so if the test is working then the only reason should be the the Beast options.

 

By the way the Tongues don't get equipped on the OpenMouth event or when you have a Gag equipped.

 

My character is a nord, so it's not seems to be the case.
I've installed Conditional Expressions + patch and clicked "Reset Expression Registry", then enabled all ahegao (except beast) in expression editor. So, after I disable all beast related checks tongue seems to be applied correctly, but it got stuck on my character's face (44 slot). The problem become quite the opposite. 

 

Edited by Deutsche_Cookie
Link to comment

OsmeIMC could you test your offered sexlab tool version (and customized scripts) work to create and show animation with sexlab tools, with your recent sup and sexlab frame work?  I feel new cash sysatem seems cause strange issue, when make the list of animation. (when I add new animation with sexlab tools)

 

When I test your attached one (which add new export function as json), I can not see my custom animation.  with sexlab tools/

 

as I reported, 

1. I can not export animation as json (everytime I made new animation, with set name, then register sexlab>> Export JSON,  it return same error info.

 

2.  I can confirm, animation are registered in sexlab frame work MCM menu. (toggole on and off, or set agressive or not) . but after I register new animation for sexlab frame work,, Sexlab tools can not pick the new "custom" animaiton..  

 

I tried all options which can list up and pick animation (isexlab tool match-maker funcitons to set animaiton) but once I add new animaton, I only see error.. 

 

(eg select agressive/normal animation from  the list never be shown... eg I make animaton as non agressive.. then register it,, after that, when I try to get list of non agressive animation, from sexlab tools ,, it can not show list (almost freeze) then from log, it usually show  error message.

 

  or if I  use tag "custom",, it simply not run any  animation. (but my new animation auto tag as custom, I confrim it)   I did not see this issue for your old patch(which could not export animation as json)

 

if I remove my custom made animation (sexlab tools menu),, then I can use all options to set animation and run with sexlab tools.  (but it means I can not see my hand-made animation at last with sexlab tools)

 

I could success to see new animation. with old version (to make creature animation without CTD)  though it was not stable. I felt..  but with recent version, I actually can not see any new animation which I registered...

 

Edited by greenmango12
Link to comment

I re-test with papyrus log. (clean up first)

my test steps.

 

0. remove all custom animation use tag "custom" from sexlab registry. it seems failed then I set animation name (currently registered my custom one), and can confirm it is removed.
1. set new animation as AAAtest1. with 5 normal animation stage 1 to stage 5,  I set each stage number as same as original. (stage1 use stage1, stage 3 use stage 3)
2  I set time for each , (0 may use defualt setting, but I set seconds 20.0 or 30.0 for 1 to 5 stage, then 6 stage have no animation)
3. regsiter animation. >> suceed
4.  export json >> error.  (error window = invalid animation or you need to register sexlab)
5.  set Actor as PC with sexlab tools. then select animation with use "select animation tag/name", I set tag as "custom",
6. start scene >> I got this info, "Queue scene has ended " then no animation start.  (as if the animation have no frame length)
7.  I try change animation "choose a normal animation" >> it could show list this time, but I can not find my new "aaatest1" in the list.

 

then this is papylus log0 (step 0 to step 7). (I attach full, though I can suspect related error message, but it seems better to apply all..to you confirm where is problem)

 

Papyrus.0.log.7z

Link to comment

Since one of the recent updates of Sexlab Utility Plus, females no longer use strap-ons when they are taking a male role in an animation, they just hump air, so to speak. I wonder if this has something to do with the "enhanced futa compatiblity", like sexlab now thinking all women are futa? Is there a particular setting I need to choose to get strap-ons back?

Link to comment
9 hours ago, Brommer said:

Since one of the recent updates of Sexlab Utility Plus, females no longer use strap-ons when they are taking a male role in an animation, they just hump air, so to speak. I wonder if this has something to do with the "enhanced futa compatiblity", like sexlab now thinking all women are futa? Is there a particular setting I need to choose to get strap-ons back?

The Futa Actors are those that come with one sex on Skyrim and a different gender assigned on SexLab.

 

The condition for the strap-on is very specific about that.

 

1. the Allow strap-on for Females need to be Enabled on the SexLab "Animations settings" page

2. the Animation position should be male type or female with strap-on.

3. If you are using some Mod to force a specific Gender when some specific SOS is equipped, make sure of use it just for Futa penises because some of those Mods can confused the SexLab making it think the actor is Futa.

 

I will check but seems to be fine.

Link to comment
14 hours ago, OsmelMC said:

The Futa Actors are those that come with one sex on Skyrim and a different gender assigned on SexLab.

 

The condition for the strap-on is very specific about that.

 

1. the Allow strap-on for Females need to be Enabled on the SexLab "Animations settings" page

2. the Animation position should be male type or female with strap-on.

3. If you are using some Mod to force a specific Gender when some specific SOS is equipped, make sure of use it just for Futa penises because some of those Mods can confused the SexLab making it think the actor is Futa.

 

I will check but seems to be fine.

My current setup is:

1. Allow strap-ons: enabled

2. Restrict strap-on use: disabled

3. SOS: Females with schlong get their Sexlab gender set to "male", except those with the "No Schlong" addon, who are set to female.

4. All females have some sort of schlong, most have the "no schlong" addon

 

In the past it worked as intended: Futas would be recognized and not equip strap-ons, other females would get a strap-on. I found out that if I remove schlongs (even the "no schlong" one), they still equip strap-ons, it's just that what worked for me in the past no longer works the same.

Edited by Brommer
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...