Jump to content
IGNORED

The Still Prevalent Lip Sync Issue


Recommended Posts

Now, I've posted this exact issue in SexLab Framework SSE's forums page, but it was mostly drowned out from all other comments on the forums, so I thought it would be a good idea to post it separately here. I'll just give the rundown of what happened on the forums, with an update to the post here, and if anyone knows how the issue can be solved, that would be amazing! 

 

-----------------------------------------------------

 

Alright, I asked for the load order since I would expect that this error might occur due to script heavy mods, but you barely have much mods to really say that was causing the issue, so I then made a completely new load order to see if the issue lied in a mod. Then I found out with this (and recommended for an issue like this) mod, and saw during sex scenes after enabling the lip sync feature, every single character defaulted to phoneme BigAah at 100 with zero's all across the board. Now I'm not sure what script does that, but I'll check to see if ANY mods that overwrite SexLab files actually effect how the lip sync works. (All mods shown that still cause this issue during the time of older post on SexLab Framework SE forums, got rid of all of the excess info that was me rambling on in those forums.)

 

 

Other Picture.PNG

 

-----------------------------------------------------

 

Now with that info dump done, I've done an update on the mods that were active when this glitch still occurred, and it's even more confusing than normal:

wow.PNG.c48cd628d12af1edc9ced8b30e1e2f41.PNG

Yep, only ten mods (most mods being required by SexLab Framework), and the issue is still there. Others have gotten this issue fixed before, but I can't seem to find out how. After activating Lip Sync and using MatchMaker to activate any sort of sex, the mouth of the character and the npc (male/female) stays open, not being able to close unless another Moan occurs, and after the sex happens, the npc's mouth AND player's mouth stay open, and when the npc talks, the mouth jitters like hell while it's open. A majority of the mods here have been re-installed, and I made sure to use the FNIS tool. I'm not sure what the problem is, and would like to hear any sort of fix from anyone in the community, since this issue might have fixes that date back to Oldrim. Thank you if you read through this hell of a post, or even if you click on this thread.

Link to comment
  • 2 weeks later...
  • 2 weeks later...

Also, an update on this topic: the developer of the mod saw these issues and is going to improve the scripts that utilize the Mfg Function, so i'll most likely delete this once the new version comes out. I'll also include the other fix I did for sslBaseExpressions, maybe fixing issues for that too: 

sslBaseExpression.pex

Link to comment
1 hour ago, janbui said:

Also, an update on this topic: the developer of the mod saw these issues and is going to improve the scripts that utilize the Mfg Function, so i'll most likely delete this once the new version comes out. I'll also include the other fix I did for sslBaseExpressions, maybe fixing issues for that too: 

sslBaseExpression.pex 16.92 kB · 1 download

Now days I saw your discribed "every single character defaulted to phoneme BigAah at 100 with zero's all across the board"

I have thought my installed mods may cause issue, but could not detect, which one did so. 

I really apreciate you offer fix.  

 

Then can you offer source files?. I  hope to know where  you changed..or added. 

Link to comment
1 hour ago, janbui said:

so i'll most likely delete this once the new version comes out.

I would actually recommend leaving them for people who don't jive with forced CC updates. For instance, I'm still on .80...and I shudder to think about trawling my .dll's to update to the latest.

Link to comment

Even though your patch seems correct "BigAah " full face, for NPC,,  

If I set lip sync active,, I show green face flickeling (sometimes it change color, with your scene light etc), in all animation for PC and NPC.

but if I disalbe lip sync, the green tint for face never happen..

 

I suppose,, these 2 problems, (big Ahr face) and green flikker are different problems, but Is there way to stop it, with lipsync on in sexlab? 

 

I have installed MfgFix, with opparco MFG command,, (it need to set expression with hot key, by poser hot key plus)

but it seems not matter about this green flicker effect (with lip sync ON in sexlab MCM animation setting) (I set both disable, or only one active etc,,

it seems should happen for my PC male, and NPC females, with sexlab animation)

Link to comment
22 hours ago, greenmango12 said:

Even though your patch seems correct "BigAah " full face, for NPC,,  

If I set lip sync active,, I show green face flickeling (sometimes it change color, with your scene light etc), in all animation for PC and NPC.

but if I disalbe lip sync, the green tint for face never happen..

 

I suppose,, these 2 problems, (big Ahr face) and green flikker are different problems, but Is there way to stop it, with lipsync on in sexlab? 

 

I have installed MfgFix, with opparco MFG command,, (it need to set expression with hot key, by poser hot key plus)

but it seems not matter about this green flicker effect (with lip sync ON in sexlab MCM animation setting) (I set both disable, or only one active etc,,

it seems should happen for my PC male, and NPC females, with sexlab animation)

I've never had this issue before with just lip sync enabled so I don't think it was a problem with the script since this issue would probably bee seen in also Oldrim, but I know for sure you should only have Mfg Fix installed, since there is a conflict between both opparco MFG and MfgFix, which might be causing the issue you have now. With this fix, you have to only have Mfg Fix since they both accomplish the same task but in different ways.

On 3/21/2020 at 10:07 PM, WandererZero said:

I would actually recommend leaving them for people who don't jive with forced CC updates. For instance, I'm still on .80...and I shudder to think about trawling my .dll's to update to the latest.

These scripts could be sourced from the new SexLab Framework that will come out, so you could just remember to install these scripts once Ashal uploads the new SexLab Framework, also, he might be making new code to do the same thing this modification accomplishes, so you should rather get it from the person who made SexLab Framework instead of some random dude on the Internet.

Link to comment
31 minutes ago, janbui said:

These scripts could be sourced from the new SexLab Framework that will come out, so you could just remember to install these scripts once Ashal uploads the new SexLab Framework, also, he might be making new code to do the same thing this modification accomplishes, so you should rather get it from the person who made SexLab Framework instead of some random dude on the Internet.

It's been over a year or so since SL was updated...I am unaware of any new version coming anytime soon. But that wasn't really my main point...

 

I mean, certainly you're free to delete them if you want, but I can tell you from experience...there's been a number of times, especially just looking at SSE conversion, where a long lost scrap of script saved the day for me. It's on that premise I mentioned keeping them here instead of just deleting them. They may come up with a search someday, and fix someone's rainy day.

 

This stuff is even more relevant now that I see how much stuff has been lost or pissed away with FO:NV and Fallout 3. More resources are always good. Random dudes on the internet probably save more hassle than they cause in cases like these. But, whatevs. I got em archived. If I need em, I can use em.

 

You do you.

Link to comment
1 hour ago, janbui said:

I've never had this issue before with just lip sync enabled so I don't think it was a problem with the script since this issue would probably bee seen in also Oldrim, but I know for sure you should only have Mfg Fix installed, since there is a conflict between both opparco MFG and MfgFix, which might be causing the issue you have now. With this fix, you have to only have Mfg Fix since they both accomplish the same task but in different ways.

These scripts could be sourced from the new SexLab Framework that will come out, so you could just remember to install these scripts once Ashal uploads the new SexLab Framework, also, he might be making new code to do the same thing this modification accomplishes, so you should rather get it from the person who made SexLab Framework instead of some random dude on the Internet.

Yes,, actually the green face issue seems only happen once, but I can not re-produce anymore..sorry reported without confirm carefully.

(I have seen same issue sometimes, so it may be related my sexlab setting)  and maybe it occured  opparco MFG and MFG fix combination,,

 

I currently see another problem,, with lip sync "on",, once run sexlab animation,, it not show strange expression, but  show their lip sync broken. as if broken doll.

( move lips with flicker ,, (but not texture problem , animation break,) 

 

Anyway I may check,, if it work well, de-activatet Opparcro MFG but only activate MFG fix,, .with your scripts. thanks

 

 

Link to comment
12 hours ago, WandererZero said:

It's been over a year or so since SL was updated...I am unaware of any new version coming anytime soon. But that wasn't really my main point...

 

I mean, certainly you're free to delete them if you want, but I can tell you from experience...there's been a number of times, especially just looking at SSE conversion, where a long lost scrap of script saved the day for me. It's on that premise I mentioned keeping them here instead of just deleting them. They may come up with a search someday, and fix someone's rainy day.

 

This stuff is even more relevant now that I see how much stuff has been lost or pissed away with FO:NV and Fallout 3. More resources are always good. Random dudes on the internet probably save more hassle than they cause in cases like these. But, whatevs. I got em archived. If I need em, I can use em.

 

You do you.

Oh sorry, you do make a point though. I'll keep this up then but just delete the redundant ones on the SL Framework SE forums and keep the ones here. Also, here's a link to the message Ashal said in the forums to make sure the word spreads around, just scroll to the bottom of the page to see the message

12 hours ago, greenmango12 said:

Yes,, actually the green face issue seems only happen once, but I can not re-produce anymore..sorry reported without confirm carefully.

(I have seen same issue sometimes, so it may be related my sexlab setting)  and maybe it occured  opparco MFG and MFG fix combination,,

 

I currently see another problem,, with lip sync "on",, once run sexlab animation,, it not show strange expression, but  show their lip sync broken. as if broken doll.

( move lips with flicker ,, (but not texture problem , animation break,) 

 

Anyway I may check,, if it work well, de-activatet Opparcro MFG but only activate MFG fix,, .with your scripts. thanks

 

 

I haven't seen this issue yet but I'll go check with just the lip sync enabled for now, I'm one of the plebs who have both on since there is only a slight issue for me by having both on.

Link to comment
18 minutes ago, janbui said:

Oh sorry, you do make a point though. I'll keep this up then but just delete the redundant ones on the SL Framework SE forums and keep the ones here.

That's cool. After I posted a reply yesterday, I thought of a better analogy:

 

Imagine if people started deleting answers on stack overflow every time someone updated some software, or a new windows update hit? It would be a 10th of the resource it is...

 

(The above link isn't really relevant to my analogy, but it is a bit of fun. ;)  )

 

Cheers, and thanks.

Link to comment

I understand actually your script remove some annoying issue,, then hope to stable with my gaming, thanks.

 

Then  could you advice me,, what setting you currently recommend for sexlab  about Expression, and lipsync?

you kindly offer 2 scripts for lip sync, and expression,, so I suppose I could active lip sync, and expression at same time,

(though sexlab menu clear discribe, it may cause issue,,,,)

 

I understand the lipsync patch, (you offered first) are used ,with sexlab mcm menu lipsync = active,, right?

and the expression patch ( you offered later), are used with sexlab mcm menu expresison = active,, I suppose so,,

but which setting you currently used? and if you only use lip sync active,, the expression pach work still ? 

 

I found strange lip sync happen when I equip some zaz items, which add animation with face expression, and show lip sync somehow broken.

then I hope to check it with most reliable setting .?

 

As you discribed I understand to check what cause problem, I need to remove some mods, which may effect sexlab animation,,

(I have installed  SLAA,, and it need to use sexlab utility plus, (it offer some good new option related with zaz and DD filter etc,, so bascially I hope to keep it,,)

 but  maybe I need to remove them once. ^^;  do you use those mod too?  I just hope to know,if it related about these issue,,)

 

 

 

 

 

 

Link to comment
  • 2 months later...

I realize this thread is now a bit older, I’m experiencing a strange bug after using your script (even though I'm pretty much just happy with finally getting lip sync to work with expressions again!). My understanding is that once an animation begins, sexlab will pick a semi random expression from the list of presets (pleasure, happy, joy, etc) and then from there it’s a combo of enjoyment and animation stage to cycle through the phases of that expression. The bug I’m getting is that the character will only ever use one of those presets if I attempt to edit any of them. For example, to test I did Pleasure: Mood Surprised 100, Happy: Mood: Anger 100, Joy: Mood Fear 100 (I picked these because it's easy to tell if they're playing), but no matter what, the npc only used "Joy." I ended and restarted the animation about 2 dozen times, but while all three were enabled in Sexlab, they only used Joy. I'm baffled. Any idea the cause of this?

Link to comment
On 3/23/2020 at 1:04 AM, greenmango12 said:

I currently see another problem,, with lip sync "on",, once run sexlab animation,, it not show strange expression, but  show their lip sync broken. as if broken doll.

( move lips with flicker ,, (but not texture problem , animation break,) 

 

I'm also seeing a jitter/flicker with the jaw moving up and down maybe like 3-4 times in a 1/4 second. It is on a new save with the latest mfg fix and no Opparcro.

 

Edit: I messed around some more and it's working now. It may have been a load order thing as I was modifying my list and possibly forgot to run loot. Thanks for the fix!!

Link to comment
  • 3 weeks later...
On 7/5/2020 at 10:06 AM, Dide05 said:

Hello, i have after installing this script the same problem as before, but if i set expressions on, the mouth is not staying open he is flickering, can anybody help maybe?

If you have random emotions, that tends to be the issue. There is a patch somewhere for it.

Link to comment
On 6/7/2020 at 8:55 PM, Gro_Lak said:

I realize this thread is now a bit older, I’m experiencing a strange bug after using your script (even though I'm pretty much just happy with finally getting lip sync to work with expressions again!). My understanding is that once an animation begins, sexlab will pick a semi random expression from the list of presets (pleasure, happy, joy, etc) and then from there it’s a combo of enjoyment and animation stage to cycle through the phases of that expression. The bug I’m getting is that the character will only ever use one of those presets if I attempt to edit any of them. For example, to test I did Pleasure: Mood Surprised 100, Happy: Mood: Anger 100, Joy: Mood Fear 100 (I picked these because it's easy to tell if they're playing), but no matter what, the npc only used "Joy." I ended and restarted the animation about 2 dozen times, but while all three were enabled in Sexlab, they only used Joy. I'm baffled. Any idea the cause of this?

Sorry about responding so late, but SexLab does work a bit differently then picking a random animation. Each animation has a set facial experssion attached to the individual, and if not provided with one (I presume) it defaults to happy or something of the sort. That being said, I'm not entirely sure if my fix could cause this issue: I actually got the scripts from the original SexLab for LE and looked through them to see which lines of code were disabled for SE since the script MfgConsoleFunc was not available when SE came out. I've checked nearly every line of code to ensure that any extra code that was added in since LE was disabled by just turning the code into a comment, so I'm not entirely sure about how that bug happens. I would reccomend to just uninstall and reinstall SexLab and try again when the scripts, but I'm not sure what else.

 

On 7/5/2020 at 10:06 AM, Dide05 said:

Hello, i have after installing this script the same problem as before, but if i set expressions on, the mouth is not staying open he is flickering, can anybody help maybe?

On 6/15/2020 at 2:55 AM, fooman said:

I'm also seeing a jitter/flicker with the jaw moving up and down maybe like 3-4 times in a 1/4 second. It is on a new save with the latest mfg fix and no Opparcro.

 

Edit: I messed around some more and it's working now. It may have been a load order thing as I was modifying my list and possibly forgot to run loot. Thanks for the fix!!

Click on the person and type in the console "mfg reset". There is no good fix for it yet as it happens even without the scripts here, this usually happens after having sex with the facial expressions turned on.

 

I should have checked this forum a bit more vigilantly, sorry about that

Link to comment
On 3/24/2020 at 3:44 AM, greenmango12 said:

I understand actually your script remove some annoying issue,, then hope to stable with my gaming, thanks.

 

Then  could you advice me,, what setting you currently recommend for sexlab  about Expression, and lipsync?

you kindly offer 2 scripts for lip sync, and expression,, so I suppose I could active lip sync, and expression at same time,

(though sexlab menu clear discribe, it may cause issue,,,,)

 

I understand the lipsync patch, (you offered first) are used ,with sexlab mcm menu lipsync = active,, right?

and the expression patch ( you offered later), are used with sexlab mcm menu expresison = active,, I suppose so,,

but which setting you currently used? and if you only use lip sync active,, the expression pach work still ? 

 

I found strange lip sync happen when I equip some zaz items, which add animation with face expression, and show lip sync somehow broken.

then I hope to check it with most reliable setting .?

 

As you discribed I understand to check what cause problem, I need to remove some mods, which may effect sexlab animation,,

(I have installed  SLAA,, and it need to use sexlab utility plus, (it offer some good new option related with zaz and DD filter etc,, so bascially I hope to keep it,,)

 but  maybe I need to remove them once. ^^;  do you use those mod too?  I just hope to know,if it related about these issue,,)

 

 

 

 

 

 

Also again, sorry for the lateness, but I do use both with only a slightly weird issue in-between the change from the moan to the expression, where the player/npc has their original base facial expression followed by the edit of expression done by SexLab Framework. I've actually seen people use this in a real clever way like izzyguy, who uses the mod random emotions to change the base facial expression and goes back to SexLab Framework's facial expression to get more "diverse" facial expressions that are really just one stagnant and one changing facial expressions. Love his shit to pieces.

Link to comment
On 7/12/2020 at 2:35 PM, janbui said:

Sorry about responding so late, but SexLab does work a bit differently then picking a random animation. Each animation has a set facial experssion attached to the individual, and if not provided with one (I presume) it defaults to happy or something of the sort. That being said, I'm not entirely sure if my fix could cause this issue: I actually got the scripts from the original SexLab for LE and looked through them to see which lines of code were disabled for SE since the script MfgConsoleFunc was not available when SE came out. I've checked nearly every line of code to ensure that any extra code that was added in since LE was disabled by just turning the code into a comment, so I'm not entirely sure about how that bug happens. I would reccomend to just uninstall and reinstall SexLab and try again when the scripts, but I'm not sure what else.

 

Click on the person and type in the console "mfg reset". There is no good fix for it yet as it happens even without the scripts here, this usually happens after having sex with the facial expressions turned on.

 

I should have checked this forum a bit more vigilantly, sorry about that

Thanks for the help! I actually figured out what was going on. Basically I was using default expression sets for SexLab and just wasn't getting the results I wanted. Turns out, a few custom expressions, plus Random Emotions (LE version), plus your script to allow us to use both expressions and lip sync works amazingly well together. Cheers!

Link to comment
On 7/12/2020 at 2:41 PM, janbui said:

Also again, sorry for the lateness, but I do use both with only a slightly weird issue in-between the change from the moan to the expression, where the player/npc has their original base facial expression followed by the edit of expression done by SexLab Framework. I've actually seen people use this in a real clever way like izzyguy, who uses the mod random emotions to change the base facial expression and goes back to SexLab Framework's facial expression to get more "diverse" facial expressions that are really just one stagnant and one changing facial expressions. Love his shit to pieces.

Huh, so he "stacks" facial expressions? How does that work without getting jitter? Or is that something your change fixes as iirc izzyguy uses LE.

 

On 7/13/2020 at 8:59 PM, Gro_Lak said:

Thanks for the help! I actually figured out what was going on. Basically I was using default expression sets for SexLab and just wasn't getting the results I wanted. Turns out, a few custom expressions, plus Random Emotions (LE version), plus your script to allow us to use both expressions and lip sync works amazingly well together. Cheers!

 

I assume the LE version so there is follower support? Did you have to use a patch so it doesn't conflict with SL expressions?

Link to comment
  • 3 weeks later...

Iv tried you're fix and my characters jaw still gets stuck open i went and updated to the experimental version of sex lab on github and that fixed it then it broke again and i cant fix it for the lip sync do you think it might be vortex's fault if so should i just switch over to mod organizer 2 ( Its reallying just getting ridiculous to fix it at this point ngl)

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...