Jump to content
Ashal

SexLab Framework SE 1.63 - BETA 6 - March 19th, 2019

Recommended Posts

How do I add the animations? I still have the Lite version of Sexlab, do I just have this one overwrite it? Do I need more mods to add the animations from the Lite Version or will having it overwrite be enough?

Share this post


Link to post

can't get any animations to work using matchmaker light. remade all my patches, cleaned/rebuilt sexlab ingame after installation, but no scene animations play.

Share this post


Link to post
26 minutes ago, squirrellydood said:

How do I add the animations? I still have the Lite version of Sexlab, do I just have this one overwrite it? Do I need more mods to add the animations from the Lite Version or will having it overwrite be enough?

Sexlabs lite is not sexlabs 1.63, you will have to deinstall the former and install the full mod 1.63

Share this post


Link to post
17 minutes ago, tuxagent7 said:

Sexlabs lite is not sexlabs 1.63, you will have to deinstall the former and install the full mod 1.63

I know that but this one doesn't have any animations and there are no animation packs for it on SE. So the options are an empty framework or overwrite Sexlab Lite.

Share this post


Link to post
8 minutes ago, squirrellydood said:

I know that but this one doesn't have any animations and there are no animation packs for it on SE. So the options are an empty framework or overwrite Sexlab Lite.

 

Well i think the original animations are supposed to be in sexlabs 1.63 sure you wont have the nibbles or the billyy or the others because they have to be converted and there has to be a slal AnimLoaded converted

 

But Sexlabs normally come with somes animations

Share this post


Link to post
1 hour ago, tuxagent7 said:

 

Well i think the original animations are supposed to be in sexlabs 1.63 sure you wont have the nibbles or the billyy or the others because they have to be converted and there has to be a slal AnimLoaded converted

 

But Sexlabs normally come with somes animations

There are literally over 8 thousand files that this does not conflict with in Sexlab Lite, its more than just a few animations. There are over 800 separate animations in the other Lite version, including all the creature animations.

Share this post


Link to post

Animation packs that work with SexLab Lite should work with this as far as I know.

Share this post


Link to post
46 minutes ago, Ashal said:

Animation packs that work with SexLab Lite should work with this as far as I know.

There are no animation packs for Lite, all the animations were already included because the program that was needed to include animations en mass doesn't work in 64 bit requiring them to individually be added to sexlab itself by the modder, in this case Vinfamy.

 

or at least tht's how it was explained in the development thread.

Share this post


Link to post
3 hours ago, squirrellydood said:

There are no animation packs for Lite, all the animations were already included because the program that was needed to include animations en mass doesn't work in 64 bit requiring them to individually be added to sexlab itself by the modder, in this case Vinfamy.

 

or at least tht's how it was explained in the development thread.

Would it be possible to add the animations from Lite, as well as the script that registers those animations to this Beta, without blowing up the universe?  I believe it's one script, sslAnimationDefaults.pex.  Just wondering.

Share this post


Link to post

Seems like upgrading to sexlabs 1.63 broke the sex animations for my custom race (Succubus). It worked fine with sexlabs lite 0.1.1 (after I used sexlab register custom race spell) but 1.63 doesn't seem to have that function. At least not yet

Share this post


Link to post
4 hours ago, perrymwt said:

Would it be possible to add the animations from Lite, as well as the script that registers those animations to this Beta, without blowing up the universe?  I believe it's one script, sslAnimationDefaults.pex.  Just wondering.

I haven't looked at how modified lite's version of the relevant scripts is, but that should work fine as far as I know. You may need to recompile the copied sslAnimationDefaults from lite under the full version though.

 

1 hour ago, Revanswe said:

Seems like upgrading to sexlabs 1.63 broke the sex animations for my custom race (Succubus). It worked fine with sexlabs lite 0.1.1 (after I used sexlab register custom race spell) but 1.63 doesn't seem to have that function. At least not yet

Make sure the custom race has the ActorTypeNPC keyword. Other than that, I'd have to see a debug log from an animation attempt using the race to know more.

Share this post


Link to post
14 hours ago, Ashal said:

 

 


  • A new scaling fix that finally solves the issue with some actors/creatures randomly changing sizes when animating (enabled by default) (Wasnt that fixed already by madmangun?)
  • (partially implemented) a new hook system for developers that don't work on events, allowing them to fully complete their hook function before the thread continues. Solves some sync issues with more complicated or timing sensitive hooks. (Will that fix desychronization between actors, especially if more then 2 actors animation is playing?)

 

Share this post


Link to post
3 hours ago, Ashal said:

I haven't looked at how modified lite's version of the relevant scripts is, but that should work fine as far as I know. You may need to recompile the copied sslAnimationDefaults from lite under the full version though.

 

Make sure the custom race has the ActorTypeNPC keyword. Other than that, I'd have to see a debug log from an animation attempt using the race to know more.

I'm not sure how this is done, is there a guide telling how to do these things manually?

Share this post


Link to post
7 hours ago, Ashal said:

I haven't looked at how modified lite's version of the relevant scripts is, but that should work fine as far as I know. You may need to recompile the copied sslAnimationDefaults from lite under the full version though.

 

Make sure the custom race has the ActorTypeNPC keyword. Other than that, I'd have to see a debug log from an animation attempt using the race to know more.

 

Well, I gave it a try and it does work.  All you need to do is copy the actors directory from the lite version to the Beta version. THen copy sslAnimationDefaults.pex and sslCreatureAnimationDefaults.pex from the Lite version to the Beta version.  Install.  Rerun FNIS.  Run the game and reset the animation registry.  I've tried a dozen or so human animations and they all work.  So no real need to wait for JContainers to be converted to use with SLAL.

 

A big thanks to vinfamy for all the work putting together the animations.

 

Edit: Be patient.  It takes a while for 800+ animations to register.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...