Jump to content
IGNORED

Massive FPS drop caused by HDT-SMP


Recommended Posts

FPS goes down from 144 to between 5 and 15 and stays there when either there are multiple actors with SMP-enabled clothing that are in a SexLab scene or randomly after a period of time. Restarting the game fixes the issue until one of the causing factors happens again. Opening any kind of menu or the console temporarily fixes the issue until I close that menu or the console.


I've tried locking the game to 60 FPS, thinking that the problem may be caused by the high FPS but I ran into the same problem.
I've tried both (not at the same time) the ini edit fMaxTime=0.0069 and the Havok Fix mod for the FPS, thinking that maybe one would be better over the other but I get the lag with either one.


I've also noticed that if I encounter multiple naked actors (dead or alive), after spending some time in-game, certain body parts start stretching all over the place at very high speeds. Again, I was able to reproduce this at both 144 and 60 FPS so that is not the cause.

 

Mod list and loadorder:

modlist.txt

loadorder.txt

 

On another note, but maybe somewhat related, I am using Mannequins Revamped AB and whenever I go into a cell with a lot of mannequins I get the same FPS drop.

Link to comment

That's just your system not being able to handle several NPCs with HDT-SMP stuff enabled. There are bug reports about it (on the nexus page for hdt-smp), recommendations from other mod authors to disable hdt in NPCs and use it only for the player/a couple of followers and so on. Trying to cap FPS at 60 won't help you, because the issue is your FPS will be way below 60. Some people even get a CTD after a while.

Link to comment
10 minutes ago, dontknowdontcaredontask said:

That's just your system not being able to handle several NPCs with HDT-SMP stuff enabled. There are bug reports about it (on the nexus page for hdt-smp), recommendations from other mod authors to disable hdt in NPCs and use it only for the player/a couple of followers and so on. Trying to cap FPS at 60 won't help you, because the issue is your FPS will be way below 60. Some people even get a CTD after a while.

Hmm, that's weird, I would've thought that my system (i5-9600KF, rtx 2070, 16GB ram) can handle it. Well, that's a bummer, thanks for the reply though!

Link to comment

It's purely based on CPU, and if you check comments/bug reports there are people with CPUs similar to yours that even get freezes. It's more like the code isn't optimized to work in several NPCs/items at the same time, than your system specs being too low.

 

I think there is a command to reset smp ("smp reset" or "reset smp", not sure) and go back to your highest FPS, but as you keep playing your FPS will go lower and lower again.

Link to comment

Reinstall all your mods, with your specs it's really strange that you get that fps.

I have an i7 4790, r9 290x and 16 ram. And i dont have any problems with BHUNP with hdt smp support. Maybe someting is installed wrong, or in a bad order.

Or just reinstall the skeleton and all the smp mods including the bodie (Sorry for my english)

Link to comment

I came across this thread with similar issues, very bad FPS on just a lightly modded game and after deactivating HDT-Smp the problem was gone. I have an 8700K a rtx2070, 32gb of ram and the game is running from an exclusive ssd raid everything overclocked, so I was quite baffled by this. I doubt its a cpu issue, I had pretty much the same rig Rodvoight has like 5 years ago and that was running skyrim with 200 mods including hdt stuff on everything.

 

 

Link to comment
3 hours ago, Zaflis said:

HDT-PE for Skyrim LE is much more optimal than HDT-SMP, it isn't news to anyone i guess.

Not even kind of, nor in any universe.

 

PE has a memory leak and HObjects will, not can, bake themselves into your save permanently. Properly configured SMP gets about 50% better framerate than PE and no amount of wishful thinking or fetish fapping will change that, nevermind realism or level of granularity.

Link to comment
  • 3 months later...

type "smp reset" into console to get your fps back to max. smp hdt has this known bug that causes it to push your cpu to 99% because some npc's physics get stuck in an infinite collision loop. I have the same issue and this fix works until i find a more permanent solution. Disabling physics for npcs should also work but i like having it. For scientific reasons.

Link to comment
On 1/26/2020 at 5:24 PM, sfdrake said:

how do I stop smp of follower?

Afaik, assign the follower(s) a non-SMP body. Both 3BBB Advanced and BHUNP have body models that don't use SMP.

 

BHUNP 3BBB Advanced , BHUNP 3BBB Advanced Ygnord, for any BHUNP enabled followers, and afaik, for 3BBB Advanced, the choices would include any of the Body Physics or Body Special types, which I believe will then only run off CBP

 

PS> for your own character, (in case you weren't aware)  if you use the CBBE route, the CBBB Advanced MCM menu offers a hotkey to switch from SMP to CBP and back. (also doubles as an  easy way to reset SMP for the player when its engine's residuals build up and SMP begins to show signs of imminent catastrophe (when the breasts start vibrating a bit on their own... which gets progressively worse until they're flying around like an angry bee on a leash.)

 

--- edited for spelling and content

Link to comment
20 minutes ago, anjenthedog said:

 

 

PS> for your own character, (in case you weren't aware)  if you use the CBBE route, the CBBB Advanced MCM menu offers a hotkey to switch from SMP to CBP and back. (also doubles as an  easy way to reset SMP for the player when its engine's residuals build up and SMP begins to show signs of imminent catastrophe (when the breasts start vibrating a bit on their own... which gets progressively worse until they're flying around like an angry bee on a leash.)

This has been bugging me for ages, I thought I was the only one. Do you know of a way to limit these vibrations?

Link to comment
12 hours ago, Player80 said:

This has been bugging me for ages, I thought I was the only one. Do you know of a way to limit these vibrations?

the only way I know right now is to perform a periodic SMP reset, by whichever means you have on your system. Perhaps someone who knew how could script it as a periodic call, idk. I don't. So I just manually do it when I start to detect things are going off the edge.

Link to comment
6 hours ago, anjenthedog said:

the only way I know right now is to perform a periodic SMP reset, by whichever means you have on your system. Perhaps someone who knew how could script it as a periodic call, idk. I don't. So I just manually do it when I start to detect things are going off the edge.

Yeah I just unequip and re-requip the SMP armor using the hotkey.

Link to comment

One minor note: you often cannot perform this reset during an animation sequence. So you may have to endure it until the sequence has completed and you regain direct control over the actor, although if you catch it at the very beginning you can usually do a reset, if you're quick about it.

Link to comment
  • 1 year later...
On 1/26/2020 at 2:45 PM, Just Don't said:

It's purely based on CPU, and if you check comments/bug reports there are people with CPUs similar to yours that even get freezes. It's more like the code isn't optimized to work in several NPCs/items at the same time, than your system specs being too low.

 

I think there is a command to reset smp ("smp reset" or "reset smp", not sure) and go back to your highest FPS, but as you keep playing your FPS will go lower and lower again.

 

HDT has very little to do with your CPU or your GPU. It's a very intensive process and even on my rig with a 14 core i9 overclock to 4.8 GHz, I drop from 60 all the way down to 20 or even 15 FPS. Standing in the middle of white on the market gives me like 25 FPS only at 1080p. I was pulling my hair out trying to figure out why my frame rate was so bad but it turns out HDT physics is really just bad.

 

It never got mainstream optimization, it never got code simplification, and the multithreading feature is buggy as shit.

 

If you have trouble in a specific area you're better off just disabling HDT for that portion.

Edited by Etrius vanRandr
Link to comment
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...