Jump to content
IGNORED

[mod] Sexbound


Locuturus

Recommended Posts

26 minutes ago, red3dred said:


... Yep, same pregnancy issue i've shared the fix for here. It has not been fixed yet indeed.

Little pointer:

 

thanks, i did remember such a fix, but somehow didnt have a backup of that fixed file, so thanks!

Link to comment
2 minutes ago, Onenighthero said:

Does impregnating work? If I have a female character I can get impregnated, but I cant impregnate anyone as a male character.

 

Did you remember to click the white bars that fill up during the animations?

Link to comment
Quote

5.8.10 - change sexbound to include lustbound_base.

Does that mean we don't need the lustbound base anymore?

 

EDIT: just checked, it's still needed, if you use lustbound.

Edited by ptmc2112
Link to comment
10 minutes ago, ptmc2112 said:

Does that mean we don't need the lustbound base anymore?

 

EDIT: just checked, it's still needed, if you use lustbound.

 

Ah. I worded it wrong. Includes means Sexbound loads after Lustbound loads.

Link to comment

So Ive been having issues where beaming down to certain worlds will immediately teleport me back up to my ship. I've done just about everything I can think of to fix it, including deleting the universe folder entirely and only playing with the sexbound mod installed. Im not sure why this is happening, especially since I have used these mods on other computers in the past and the game worked perfectly fine. Any chance someone here could help?

Here is a list of the mods I have installedstarbound mods.txt

Link to comment
3 hours ago, OutlyingAvian said:

So Ive been having issues where beaming down to certain worlds will immediately teleport me back up to my ship. I've done just about everything I can think of to fix it, including deleting the universe folder entirely and only playing with the sexbound mod installed. Im not sure why this is happening, especially since I have used these mods on other computers in the past and the game worked perfectly fine. Any chance someone here could help?

Here is a list of the mods I have installedstarbound mods.txt

Logs would be handy to know what causes it. Mod list alone isn't gonna be enough I'm afraid.

Link to comment
4 hours ago, OutlyingAvian said:

So Ive been having issues where beaming down to certain worlds will immediately teleport me back up to my ship. I've done just about everything I can think of to fix it, including deleting the universe folder entirely and only playing with the sexbound mod installed. Im not sure why this is happening, especially since I have used these mods on other computers in the past and the game worked perfectly fine. Any chance someone here could help?

Here is a list of the mods I have installedstarbound mods.txt

 

Quote

So, to better report issues, try providing a description of the issue and recreating the issue in-game, then providing a log file.

To find the log file, it should be within your Starbound installation directory, then the storage folder. You should see a text file named starbound.log (Or simply starbound, a plain text file). Paste it into your response as a attached file, or use PasteBin, whichever you prefer. Then users can look into your issues with the necessary information at hand.

 

<Just please don't post the whole thing as text here>

Link to comment
4 hours ago, OutlyingAvian said:

So Ive been having issues where beaming down to certain worlds will immediately teleport me back up to my ship. I've done just about everything I can think of to fix it, including deleting the universe folder entirely and only playing with the sexbound mod installed. Im not sure why this is happening, especially since I have used these mods on other computers in the past and the game worked perfectly fine. Any chance someone here could help?

Here is a list of the mods I have installedstarbound mods.txt

Like RenaTheAvali and red3dred said, the starbound log would be more helpful, also, the log also has the list of mods as well.

Unlike games like skyrim, the log is extremely useful, as starbound logs every error, and relies on a "no error" environment, so if something were to error during game loading in (before the main menu), it won't exist in the game, and if it errors during gameplay, it stops working, at worst crashes the game, or like in your error, it teleports you back to the ship (which is generally the safest place to teleport).

Sorry if im blunt.

Edited by ptmc2112
Link to comment
1 hour ago, ptmc2112 said:

Like RenaTheAvali and red3dred said, the starbound log would be more helpful, also, the log also has the list of mods as well.

Unlike games like skyrim, the log is extremely useful, as starbound logs every error, and relies on a "no error" environment, so if something were to error during game loading in (before the main menu), it won't exist in the game, and if it errors during gameplay, it stops working, at worst crashes the game, or like in your error, it teleports you back to the ship (which is generally the safest place to teleport).

Sorry if im blunt.

starbound.log

Sorry, I was under the impression the log would only be useful in case of actual crashes, good to know it logs everything. So I think the error is that the world wants to spawn something called bigbrococo, but that doesnt exist for whatever reason. After checking that I deleted Terramon and Terramen from my mods folder and deleted the universe folder, and it worked fine.

Damn, I tried everything except looking at the log because I thought it would be shit like other game logs Ive seen, sorry for the trouble

Link to comment
44 minutes ago, OutlyingAvian said:

starbound.log 25.11 kB · 0 downloads

Sorry, I was under the impression the log would only be useful in case of actual crashes, good to know it logs everything. So I think the error is that the world wants to spawn something called bigbrococo, but that doesnt exist for whatever reason. After checking that I deleted Terramon and Terramen from my mods folder and deleted the universe folder, and it worked fine.

Damn, I tried everything except looking at the log because I thought it would be shit like other game logs Ive seen, sorry for the trouble

 

Hmm... "BigBroCoco"... Somehow you have Cass's Terramen, but without the mod being installed. If your planet generated with that mod before you removed it, now you can't play on it because it tries to spawn a monster that does not exist.

Edited by red3dred
(Fixing grammatical derps)
Link to comment
27 minutes ago, red3dred said:

 

Hmm... "BigBroCoco"... Somehow you have Cass's Terramen, but without the mod being installed. If your planet generated with that mod before you removed it, now you can't play on it because it tries to spawn a monster that does not exist.

Yeah, it was just weird since in the past I uninstalled all mods aside from sexbound and deleted the planets I was having trouble with and it still crashed when I went back onto them. I guess I had to delete the entire universe folder for it to work

Link to comment

Latest version isn't compatible with Teratophilia, unless I'm doing something wrong
 

Spoiler

[Warn] Could not create placable object of kind 'sexbound_main_node', exception caught: (MapException) Key 'actor1Groinwear1' not found in OrderedMap::get()

 

Edited by silphium_potion
Changed code sections to spoiler because it makes more sense
Link to comment

I found the cause!
I located two files containing "Actor1Groinwear1" (/artwork/humanoid/twoactors.animation and /artwork/humanoid/twoactors-centered.animation)
I searched through the code for errors and found that both files had a case where ActorXGroinwear1 was misspelled as ActorXGroinwear, specifically string 11031 in the first one and string 66 in the second one
I patched those up, and voila! :)


 

Edited by silphium_potion
grammar
Link to comment
36 minutes ago, silphium_potion said:

Here's the patch if anyone needs it. Just extract the archives, drop the files in the sexbound folder and overwrite
groinwearfix.zip


I mean, you refused to send the log, and only grazed upon the error, so i was waiting until you scrolled up a bit and actually did the thing, but judging by how you only mentioned Sexbound thus far, i assume you found an actual typo/bug in the API. Which version, i don't know. Thanks for the info i guess? At any rate, that'll be noted for Locuturus...

Link to comment

Sorry, I couldn't really find anything about that problem specifically. It's in the 5.10 version of sexbound
I only sent one line of the log because I thought it was the only part necessary, the error popped up specifically every time I tried to create a node. I'm going to send the full logs next time I encounter an error, I promise >.<
I'm not really sure how or why, but everything started to work after I made the tweaks mentioned above, I just assumed that I fixed something ?

Edited by silphium_potion
Link to comment

Sex scene don't work anymore after version 2.8.10 for me...

Edit: I reinstalled 5.8.9, welp, now it's broken and I still can't see sex scene. Idk how the bug started since it was working fine 2 days ago for me, I didn't install anything between 2 days ago and today.

starbound.log

Edited by Shynasha
Link to comment
1 hour ago, Shynasha said:

Sex scene don't work anymore after version 2.8.10 for me...

Edit: I reinstalled 5.8.9, welp, now it's broken and I still can't see sex scene. Idk how the bug started since it was working fine 2 days ago for me, I didn't install anything between 2 days ago and today.

starbound.log 76.15 kB · 0 downloads

[22:14:59.111] [Error] [string "/scripts/sexbound/override/common/pregnant.lu..."]:100: bad argument #2 to 'insert' (position out of bounds)

 

yeah, im guessing it's the same error that red3ded had noticed and fixed where the pregnant.lua file stops learning to count, not kidding.

 

fortunately, @red3dred already made a version that fixes that issue

 

Edited by ptmc2112
Link to comment
20 minutes ago, ptmc2112 said:

[22:14:59.111] [Error] [string "/scripts/sexbound/override/common/pregnant.lu..."]:100: bad argument #2 to 'insert' (position out of bounds)

 

yeah, im guessing it's the same error that red3ded had noticed and fixed where the pregnant.lua file stops learning to count, not kidding.

 

fortunately, @red3dred already made a version that fixes that issue

 

Well now my character does appear, same for other during sex, but they just duplicate and stand here whitout doing anything.

starbound.log

Link to comment
1 hour ago, Shynasha said:

Well now my character does appear, same for other during sex, but they just duplicate and stand here whitout doing anything.

starbound.log 107.55 kB · 1 download


Hmm... You can try updating your Lustbound base to the one i've posted in the Lustbound thread, but looking at the error i get a feeling there maybe new changes to the pregnancy script, that is making it incompatible with the patch i've made, and @ptmc2112 shared, this may require a new patch soon, but without knowing when or if the API is updated it's really hard to say when or if i'll get it made... Or Locuturus can also fix that up real quick in the near future.

I'm afraid i can't help you much there without taking a while to read old and new code.

 

Edit: Took a while to compared the codes, and it's not different, the patch should still work fine... May i ask you how you used the patch?/ How you applied it?
If the issue is persistent even after the patch this is either a new issue or something else.

Edited by red3dred
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...