Jump to content

Recommended Posts

3 hours ago, garth033 said:

Hey, thanks for that, I noticed that the Venus body does not look like the screen caps from the custom race patches. I've also found that my custom races don't work, nor is pregnancy visual outside of animations.

 

Any idea what I may have done wrong?

1) Custom races require a patch/support made by users, if yours is not available, check the starbound club, there is a request thread there, run by Alastor. Not all races were allowed to have support by their creators/owners.

2) The pregnancy lacking visuals outside of animations is known, and we're still coming up with ways to visually warn the player of such things. For now however, it is normal.

Share this post


Link to post
7 hours ago, red3dred said:

How so...? Dialogue tech didn't change, all that changed was that Dialogue from your version didn't carry over to 2.8.1-- though, me and the Discord folks have been trying to expand dialogues for all positions and races for a while, might get on releasing that as a separate thing in the near future.

 

I'm still on 2.8.0 because when I put on 2.8.1, I couldn't use sexbound beds, sex toys co, fuschia, or the bow. It made npcs disappear when they used a sexbound bed or get shot by the bow.

 

It's just that when I went and add, or even changed some dialogue in the defaults of the positions: some carried over but it overrode other positon dialogues. For example, I input dialogue for missionary and it only used about half the dialogue and dialogue for cowgirl/cowboy vanished.

Share this post


Link to post

I don't think I've ever actually seen any of my tenants across any of my bases use any of the sex-enabled loungeables on their own without resorting to the use of the Dibella statue. The correct version of admin-spawned furniture is in place around the bases, but goes completely ignored, and if I interact with it and hang out there, nothing happens there either. Is there some other thing I need to do to activate these things?

 

Note: I'm not using the special loungeables mod, but rather the ones packaged within the new Sexbound API. Is that other mod necessary to make even the ones in the main mod work?

Share this post


Link to post
2 hours ago, Ethereal13 said:

I don't think I've ever actually seen any of my tenants across any of my bases use any of the sex-enabled loungeables on their own without resorting to the use of the Dibella statue. The correct version of admin-spawned furniture is in place around the bases, but goes completely ignored, and if I interact with it and hang out there, nothing happens there either. Is there some other thing I need to do to activate these things?

 

Note: I'm not using the special loungeables mod, but rather the ones packaged within the new Sexbound API. Is that other mod necessary to make even the ones in the main mod work?

Nope, that's intended behaviour. There is no default natural use of sex-enabled beds from NPC's.

 

That's why the "Naturally Horny" mod exists.

Share this post


Link to post
21 hours ago, red3dred said:

1) Custom races require a patch/support made by users, if yours is not available, check the starbound club, there is a request thread there, run by Alastor. Not all races were allowed to have support by their creators/owners.

2) The pregnancy lacking visuals outside of animations is known, and we're still coming up with ways to visually warn the player of such things. For now however, it is normal.

1) right right, I read that and downloaded the proper patches. Still having issues with the head not lining up and either the body flashing in and out or just not showing up all together.

 

2) ah, ok. Nice to know. Hope ya'all figure that out.

Share this post


Link to post
On 1/14/2019 at 8:30 PM, red3dred said:

Lewdbound's Clean mattresses are up to date, dibella's statue should be aswell, among many others. Race supports don't have to be updated, only mods with additional objects needed to be updated.

 

Hey, feel free to post your issues. We're to help when possible.

I appreciate the support if everything is up to date then its just on my end, if i do get it to work i will probably inform you guys.

Share this post


Link to post
4 hours ago, garth033 said:

1) right right, I read that and downloaded the proper patches. Still having issues with the head not lining up and either the body flashing in and out or just not showing up all together.

That means you're using an outdated race support, made for pre-2.6 artwork. It will not work properpy nor look good until it is updated. Do take a gander though, not all races have been updated yet, but a lot of the popular ones have been updated.

 

15 minutes ago, SPECTER1887 said:

I appreciate the support if everything is up to date then its just on my end, if i do get it to work i will probably inform you guys.

No problem-- also, i've just read "craftable example sex"-- are you using the old legacy release that doesn't support any of the current mods...? Because i'm certain there is no example animation item in 2.5+

Share this post


Link to post

@DrakeWk same question i had a long Time i think its to complicated to make a mod for this?
 

Share this post


Link to post
On 12/28/2018 at 1:20 PM, FURRYHUSKY1000 said:

I'm having a strange problem where NPCs completely disappear if they're females.

 

and checking the logs, I get this:

 

[22:18:36.167] [Error] Exception caught loading asset: /scripts/sexbound/plugins/pregnant.config, (AssetException) Could not read JSON asset /scripts/sexbound/plugins/pregnant.config

 

(I have also attached the log file)

(Edit: I'm using the unpak version, I have modified nothing in there other than moans to false in config)

(Edit2: Problems persist even with the pak version)

starbound.log

I'm still having this problem even with this 2.8.1 Update.

Any interaction with a female just makes them disappear PERMANENTLY. (and game freezes a bit)
(Got no response about that particular issue either)

 

Both still happen with either the PAK file or the UNPAK files.

I have attached the log file.

starbound.log

Share this post


Link to post
45 minutes ago, FURRYHUSKY1000 said:

I'm still having this problem even with this 2.8.1 Update.

Any interaction with a female just makes them disappear PERMANENTLY. (and game freezes a bit)
(Got no response about that particular issue either)

 

Both still happen with either the PAK file or the UNPAK files.

I have attached the log file.

starbound.log

It looks like the pregnant.config file has a mistake within the file. Did you modify the config file?

Share this post


Link to post
3 hours ago, Locuturus said:

It looks like the pregnant.config file has a mistake within the file. Did you modify the config file?

I did not modify anything.

even the PAK version of the file gives this error.

 

 

1 hour ago, NekoLady said:

@FURRYHUSKY1000 Try removing SSS and test it again. That mod is old, even by vanilla Starbound's standard.

Nope, I have removed that mod but the same problem still persists, females still disappear permanently once interacted with.

 

[01:58:20.041] [Error] Exception caught loading asset: /scripts/sexbound/plugins/pregnant.config, (AssetException) Could not read JSON asset /scripts/sexbound/plugins/pregnant.config

 

I have attached the log again.

starbound.log

Share this post


Link to post
4 hours ago, FURRYHUSKY1000 said:

I'm still having this problem even with this 2.8.1 Update.

Any interaction with a female just makes them disappear PERMANENTLY. (and game freezes a bit)
(Got no response about that particular issue either)

 

Both still happen with either the PAK file or the UNPAK files.

I have attached the log file.

starbound.log

If you just downloaded the mod and its doing that, you should try cropping some NPC-related mods, i'd say the "NPC's aren't dumb" mod might be the culprit. Just remember, not all mods are written in such way that they are friendly to other mods altering the same thing (I know that a bit too well).

If the problem still persists, i'd recommend redownloading the mod, and trying without workshop mods to see if its still persists.

Share this post


Link to post
47 minutes ago, red3dred said:

If you just downloaded the mod and its doing that, you should try cropping some NPC-related mods, i'd say the "NPC's aren't dumb" mod might be the culprit. Just remember, not all mods are written in such way that they are friendly to other mods altering the same thing (I know that a bit too well).

If the problem still persists, i'd recommend redownloading the mod, and trying without workshop mods to see if its still persists.

After all this testing, I found out that SexboundAPI_Familiar.pak is causing the issue!
Uninstalling it made it work even with workshop mods!

strange...


EDIT: I grabbed the [2.1.1. Hotfix A] "Redefine pregnant.config.patch to fully functional on the current version Sexbound of Sexbound 2.6.x."

EDIT2: It's working fine now.

Share this post


Link to post

Hey i'm getting a warning message in the bottom of the first planet cave, with the poptop boss, saying "WARNING:  is not compatible with Sexbound API 2.8.1! Please download and install the latest version of the mod." Does anyone know which mod this could be? I reckon the space between "warning" and "is" should say the mod name, but alas its not. It's only happening in the cave with the poptop boss, not on my ship or the surface. Everything else is working perfectly. 

Share this post


Link to post
2 hours ago, sckntt said:

Hey i'm getting a warning message in the bottom of the first planet cave, with the poptop boss, saying "WARNING:  is not compatible with Sexbound API 2.8.1! Please download and install the latest version of the mod." Does anyone know which mod this could be? I reckon the space between "warning" and "is" should say the mod name, but alas its not. It's only happening in the cave with the poptop boss, not on my ship or the surface. Everything else is working perfectly. 

It's impossible to say which mod is the culprit when we don't know which mods you have. Are all of your other sexbound dependent mods updated? In the short time I've used this mod I've only ever seen this pop up when another sexbound mod wasn't up to date.

Share this post


Link to post
7 hours ago, sckntt said:

Hey i'm getting a warning message in the bottom of the first planet cave, with the poptop boss, saying "WARNING:  is not compatible with Sexbound API 2.8.1! Please download and install the latest version of the mod." Does anyone know which mod this could be? I reckon the space between "warning" and "is" should say the mod name, but alas its not. It's only happening in the cave with the poptop boss, not on my ship or the surface. Everything else is working perfectly. 

I think might be the Loungeable Patcher needs to be updated to version 1.1.0? The upcoming version of Sexbound API will be better able to output the object name of the incompatible object.

Share this post


Link to post

Hi, I just started using this mod recently -- very interesting and definitely adds some fun flavor to the game.  I had a quick question.  When using sex-enabled furniture (both the ones native to this mod and from Sexbound Loungeable Patcher), only 3 animations are available.  However, if I use the Artemis Bow on npcs, all 6 can be selected.  Is that supposed to be the case?

 

Thanks in advance!

Share this post


Link to post

Hello Guys is it normal to cant have sex with the cremembers?
after Patch 2.7 and newer its dosnt work anymore all waht it says is obstructet..
im the only one with that problem?

Share this post


Link to post
7 hours ago, Krovos said:

Hello Guys is it normal to cant have sex with the cremembers?
after Patch 2.7 and newer its dosnt work anymore all waht it says is obstructet..
im the only one with that problem?

@Krovos If you're using the Aphrodite's Bow, that is normal. The FAQ on that mod page says the following:  "Currently, crew members and other follower type companions will always display as 'obstructed' because the [SIC] cannot transform into a SexNode object."

 

See the last sentence under FAQ 1)  on that mod page:

 

 

If you want someone on your ship, one work around I found is to put up a Colony Deed and generate a tenant.  You can use Aphrodite's Bow on the tenants no problem.

Share this post


Link to post

I have a bit of a problem. My character got pregnant and i selected to give birth later twice. And now the option is not coming up at all. Don't know what to do about it. I'm playing as floran btw.

Share this post


Link to post
5 minutes ago, jouda852 said:

I have a bit of a problem. My character got pregnant and i selected to give birth later twice. And now the option is not coming up at all. Don't know what to do about it. I'm playing as floran btw.

Which version of the Sexbound API are you using? Latest?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...