Jump to content
Ark of Truth

[Guide/v5.3] How to install FNIS properly

Recommended Posts

I am still having a lot of trouble with FNIS can someone PLEASE help me........ i got it working then i went to install another mod that requires fnis then i clicked update fnis like im suppous to and its doing the same thing it was doing before... by saying  ">>Warning: Bad installation. Generator not run from a Skyrim installation directory.<<
FNIS Behavior V4.1.1   3/21/2014 12:11:02 AM
Skyrim: ??.?? - C:\Program Files (x86)\Steam\steamapps\common\Skyrim (Steam)
Generator: C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\FNIS Behavior 4.1.1\Data\tools\GenerateFNIS_for_Users
Skeleton female: Default (99 bones)   male: Default (99 bones)
Patch: "SKELETON Arm Fix"

Reading FNIS ...
Reading FNISBase ...

All Anim Lists scanned. Generating Behavior Files...
Converting Behavior Files (.xml to .hkx) ...

Create Creature Behaviors ...

Creature Pack not installed

 373 animations for 2 mods successfully included (characters)
 1 Warning(s)."

Link to post

It gives a warning if it isn't run from where it thinks it should be run. But it should still function even throwing up a warning.

 

i have it in the same place as i have my steam/skyrim downloaded in my c drive under program files (x86) i had taken a long 2 weeks from skyrim and modding it then i decided to give fnis another try and got it to work then found a mod i wanted to try that requires fnis so i installed it then went into fnis the same way i did to get it working and it started with it again saying that.

 

Link to post

the mod i had installed after i got fnis to work doesn't but i still have some animations even tho everytime i run/update fnis i get the warning that its a bad installation and that it says the creature pack isn't installed when it is, but the mod i had installed after i got fnis to work is this one http://www.loverslab.com/files/file/149-estrus-chaurus/ and i have all the required mods that is needed for it to work installed.

Link to post

Your problem is : install your games into the "Program Files (x86)" ou "Programs" (if 32bit OS). Thoses directory are specificely protected by the OS and causes grat problems for games (and Steam too) with auto update. And FNIS dosen't like it too. For me, i have installed all my games + Steam and Origin outside thoses directories (on another disk in fact) and don't have this problem. And (but it isn't recommanded i know) my user is administrator too. This can help.

 

Maybe you can move Steam and games on another disk and try out ?

Link to post

Your problem is : install your games into the "Program Files (x86)" ou "Programs" (if 32bit OS). Thoses directory are specificely protected by the OS and causes grat problems for games (and Steam too) with auto update. And FNIS dosen't like it too. For me, i have installed all my games + Steam and Origin outside thoses directories (on another disk in fact) and don't have this problem. And (but it isn't recommanded i know) my user is administrator too. This can help.

 

Maybe you can move Steam and games on another disk and try out ?

 

another disk as in another harddrive? cuz i only have the c drive, would it help or do anything if i made a new folder on my desktop and moved steam and skyrim things from program files to the folder and just create other folders in the folder for skyrim mods?

Link to post

 

Your problem is : install your games into the "Program Files (x86)" ou "Programs" (if 32bit OS). Thoses directory are specificely protected by the OS and causes grat problems for games (and Steam too) with auto update. And FNIS dosen't like it too. For me, i have installed all my games + Steam and Origin outside thoses directories (on another disk in fact) and don't have this problem. And (but it isn't recommanded i know) my user is administrator too. This can help.

 

Maybe you can move Steam and games on another disk and try out ?

 

another disk as in another harddrive? cuz i only have the c drive, would it help or do anything if i made a new folder on my desktop and moved steam and skyrim things from program files to the folder and just create other folders in the folder for skyrim mods?

 

 

You can do that. The important thing is : move out Steam and the games of "Programs"/"Program Files (x86)".

Link to post

 

 

Your problem is : install your games into the "Program Files (x86)" ou "Programs" (if 32bit OS). Thoses directory are specificely protected by the OS and causes grat problems for games (and Steam too) with auto update. And FNIS dosen't like it too. For me, i have installed all my games + Steam and Origin outside thoses directories (on another disk in fact) and don't have this problem. And (but it isn't recommanded i know) my user is administrator too. This can help.

 

Maybe you can move Steam and games on another disk and try out ?

 

another disk as in another harddrive? cuz i only have the c drive, would it help or do anything if i made a new folder on my desktop and moved steam and skyrim things from program files to the folder and just create other folders in the folder for skyrim mods?

 

 

You can do that. The important thing is : move out Steam and the games of "Programs"/"Program Files (x86)".

 

 

ah kk ill try it and post of it works.

 

Link to post

yay it worked! and upon ferther moving my steam/skyrim files i noticed there was 2 fnis.exe's and the one i was trying to use that said bad install was out of date and the one i clicked befor that worked was up to date and is working just rite, thank u for ur help Gvman and Benmc :)

Link to post

This keeps popping up on my FNIS

 

>>Warning: Generator not run from a legal (Steam) Skyrim installation directory.<<

FNIS Behavior V4.1.1   3/22/2014 8:00:11 PM
Skyrim: 1.9.32.0 - 
Generator: C:\Users\Name\Desktop\Skyrim\Data\tools\GenerateFNIS_for_Users
Skeleton female: XPMS (242 bones)   male: XPMS (242 bones)
 
As you can see i did move it but it keeps coming up with the warning  :@
Link to post

Nope still doesn't work, still get warning  :-/

 

>>Warning: Generator not run from a legal (Steam) Skyrim installation directory.<<
FNIS Behavior V4.1.1   3/22/2014 10:12:56 PM
Skyrim: 1.9.32.0 - 
Generator: C:\Steam\steamapps\common\Skyrim\Data\tools\GenerateFNIS_for_Users
Skeleton female: XPMS (242 bones)   male: XPMS (242 bones)
 
Do i have to put it on desktop ?
Link to post

 

Nope still doesn't work, still get warning  :-/

 

>>Warning: Generator not run from a legal (Steam) Skyrim installation directory.<<
FNIS Behavior V4.1.1   3/22/2014 10:12:56 PM
Skyrim: 1.9.32.0 - 
Generator: C:\Steam\steamapps\common\Skyrim\Data\tools\GenerateFNIS_for_Users
Skeleton female: XPMS (242 bones)   male: XPMS (242 bones)
 
Do i have to put it on desktop ?

 

 

You must launch Skyrim once through Steam.  When you do this, is adds a windows registry that FNIS is looking for to verify validity.  You only need to launch it once - just launch and quit.  The try running the Generator again and that warning will disappear.  As nutluck told you in another post.

Link to post

Ah...it's most likely going to be something obvious but i'm just to stupid to realize it...I've tried starting skyrim from steam itself and then i tried running it from the skyrim folder in the steam folder. Still same old error, I am bad at doing things sometimes  :P

Link to post

Ok Guys I got some major issues I Just did a Fresh Install of Skyrim & I installed the Pinup Poser mod Installed SKSE, Installed FNIS 4.1.1 & Idle Spells 4.0.2 & then I loaded GenerateFNISforUsers.exe & I started my game & when I would go to use the Rings I can Select what p[ose I want but when  I put on the Play rings all I get is the armor equip sound but no animations what so ever & I also get a saying in the top left corner of my screen saying FNIS Coin has been added WTF does that mean??  LOL  so I ran a consistency check & this is what I found--->

FNIS_Errors.jpg

it's saying I am missing Certain Animations, But the original didn't even have those files it says I am missing so again WTF is up with FNIS??? LOL does anyone have any solid fix for this? I have uninstalled FNIS over 6 times & I keep getting the same thing... No animations.

 

PLEASE HEEEEELLLLLP!!! :blush:

Link to post

Not a problem with FNIS.  PP has a lot of slots setup, with no animations/poses.  Basically the author setup the text file that FNIS uses with future poses in mind but never implemented them.  If you do a search for this on the FNIS page on Nexus you'll see this discussed.  It shouldn't hurt anything other than having a shit-ton of useless animation/pose slots assigned that go nowhere (if they're never called, no issue).  The author of PP should fix this, or you can take a stab at it and remove them from the text file yourself.

Link to post

Ok I finally figured it out why I wasn't getting animations I fell victim to corrupt saves  so All I had to do was make a Clean save & that solved my issue, Damn that sucks when you spend soo musch time trying to figure something out only to find it was something extremely simple....Oie.

Link to post

I always get this:

 
 ( 6 furniture, 10 offset, 0 alternate animations) - mt_behavior usage: 2.7 %
 ( 9 paired, 0 kill animations) - 0_master usage: 3.0 %
 1574 animations for 8 mods successfully included (character)
 1 Warning(s).
 
"1Warning(s)." This bothers me but so far the game works fine except my save bloats a little (14mb)
Link to post

I have a minor issue with FNIS/Sexy moves...

 

The animations and everything works fine... but sometimes my character and some npc will walk in a T shape for a few seconds before starting the normal animation. Not sure how to fix this, or if it is fixable or maybe just lag between changing animations or what not.

 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...