Jump to content
Ark of Truth

[Guide/v5.3] How to install FNIS properly

Recommended Posts

I have a minor issue with FNIS/Sexy moves...

 

The animations and everything works fine... but sometimes my character and some npc will walk in a T shape for a few seconds before starting the normal animation. Not sure how to fix this, or if it is fixable or maybe just lag between changing animations or what not.

 

Hi,

I don't think it's a problem on users end, I also have this issue either in particular cells or randomly, usually it goes back to normal after a few seconds like you or when I jump/run. I guess it's just engine's fault.

Link to post
Guest vShadowAU

When I try to run GenerateFNISforUsers I get the little loading mouse cursor and then nothing happens. No error message at all, just nothing opens. I've tried reinstalling it multiple times as well as disabling all mods. I've also disabled anti-virus while re-installing and running so it is likely not an issue with AVG. I have also tried running both GenerateFNISforUsers and hkxcmd as administrator. Any help is greatly appreciated

Link to post

Hi.whenever i try to open my skyrim from the skse launche,i get an error message saying that FNIS has not been installed properly,that sexlab needs FNIS to run properly etc.

My FNIS output is:

 

FNIS Behavior V5.2   2/21/2015 3:11:30 PM
Skyrim: 1.9.32.0 - D:\SteamLibrary\steamapps\common\Skyrim\ (Steam)
 
Skeleton female: Default (99 bones)   male: Default (99 bones)
 
Reading FNIS V5.2 ...
Reading FNISBase V5.2 ...
Reading SexLab V1.59c ...
Reading SexLabCreature V1.59c ...
Reading SexLabDefeat V?.? ...
 
All Anim Lists scanned. Generating Behavior Files ...
 
Creature Pack not installed
 
 1046 animations for 5 mods successfully included (character)
 

 

I have also tried a new game but it still didnt work

Link to post

So here is a problem I have, I installed all the skse, fnis, and sexlab frameworks and everything else required to get there. Everything is working flawlessly. Everything is in check. When I download a mod using the sexlab framework it is simply absent, the generate for users doesnt detect it and it doesnt show in game, yet the game is running smooth, just without those other sexlab mods. Help please

Link to post

Seems like you have managed to install FNIS twice. You will need to remove it all and start again.

Oh are you not on this thread anymore? Is there anyone else that can help me pls

Link to post

Here is the instructions for installing FNIS for Skyrim, for those of you who are wanting to install FNIS for SexLab please look here.

 

This guide requires that you have some common knowledge of modding Skyrim.

This guide assumes you are using a account with administrator privileges. 

 

 

 

1. Download SKSE from here

2. Go to the FNIS download page on the Nexus. 

3. Download the file called FNIS Behavior V4_0_2 -- ALWAYS necessary

4. Download the file called FNIS Idle Spells V4_0_2 -- ADD-ON for the spells

5. Unpack both FNIS files to the desktop.

6. Unpack SKSE to the Desktop.

7. Copy the contents for the SKSE folder to the main Skyrim folder (The one which contains the Data folder)

8. Copy the entire contents of FNIS Behavior V4_0_2 -- ALWAYS necessary to the Skyrim Data folder.

9. Copy the entire contents of FNIS Idle Spells V4_0_2 -- ADD-ON for the spells to the Skyrim Data folder.

10. In the Skyrim Data folder go open the folder called "Tools". (If it's not there you have not followed the instructions, start again from the beginning)

11. In there you should see two folders, one called GenerateFNIS_for_Modders and another called GenerateFNIS_for_Users

12. Open the folder called GenerateFNIS_for_Users

13. Run GenerateFNIS_for_Users.exe

14. You should now see the FNIS window open up.

15. If you are using xp32 skeleton then make sure you select "SKELETON Arm Fix" from the menu at the bottom of the window.

16. Select "Update FNIS Behaviours"

17. You should see something like the following appear in the window, this is FNIS reading and configuring mods. Note: My screen will look slightly different as I have FNIS Zoo installed

 

attachicon.gifFNIS.jpg attachicon.gifFNISDone.jpg

 

18. Go to the Skyrim root folder and create a new shortcut for Skyrim by right clicking on SKSE_Loader.exe and select "Send to" and then "Desktop"

19. Launch Skyrim using the shortcut you just created.

20. If you followed everything exactly your game should now have FNIS and SexLab installed and in working order.

 

 

If all the NPCs and your character are walking around completely still with their arms out then you have done something wrong. Go back and start again from step 1.

 

 

how about nexus mod manager user ?

Link to post

 

how about nexus mod manager user ?

 

 

Install FNIS behavior and Creature and spell if wanted after adding each mod (say no if wants to upgrade so it installs as seperate version for each)

 

Then go C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\tools\GenerateFNIS_for_Users and click GenerateFNISforUsers.exe

 

 

Link to post

When I rum FNIS this is the result:

mt_behavior usage: 18.2 %   ( 26 furniture, 29 offset, 0 alternate animations)
0_master usage: 3.7 %   ( 9 paired, 0 kill animations)
 4312 animations for 36 mods successfully included (character)
 82 Warning(s).
 
Its that bad???
Link to post

Instructions updated for FNIS v5.3, they should be correct.....ish

 

When I get the time I am going to do a full guide which will include how to install everything needed to get some loving working in Skyrim. However I won't be doing support for individual mods only the install process covered in the guide.

Link to post

i have done everything said but i load skyrim with the skse loader,itsopen up ,do the loading thing and then crashes...when i load it with nexus mod manager by launch skse button it does the same but when i load it up on nexus by lauch skyrim button when it loads perfectly and then it tells me that fnis has not sucessfully work or something like that......please help i really do not know what to do

Link to post

Please help, I can't even find the "tools" folder that the generator is supposed to be in. I followed the path correctly up to Data, and there is no tools folder for me in Data. Could it be somewhere else?

 

Link to post

Ok totally lost and Google is of no help. I am trying to migrate from NMM to MO and am following Gophers guides and the STEP manual as needed.

 

I have installed FNIS as per the guides, I have created an executable as per the instructions, I pick FNIS from the drop down menu and hit run". I immediately get a text window saying MO is locked which is not an issue as that is supposed to happen. Even shows it in Gophers vids.

 

BI do not get the FNIS box, no readout as I would if I ran it in windows mode no chance to say go or exit, nothing. The mouse pointer turns into a hey I'm busy icon for a bit, then it all goes back to before I hit run.

 

I check the overwrite file and there is nothing in ther about FNIS. It is as if MO tried to run FNIS and it failed.

 

I'm totally stuck and it must be a setting or something simple as I can find nothing on it by googling. Anyone else run into this?

 

I've already deleted reinstalled FNIS. Deleted the executable and recreated it.

 

Any new thoughts would be very helpful

Link to post

Can anyone offer any insight into running/installing FNIS through wineskin for Mac? I feel like I'm almost there... Until I click 'update FNIS behaviors' in GenerateFNISforUsers window and nothing happens. SexLab also tells me when I sign into Skyrim I need FNIS installed properly for it to work, and it doesn't look like FNIS is reading any of the mods i have installed either. Really clueless as to what to do, but I only have a Mac right now and really wanted to try the mods! Haven't found a solution anywhere. Willing to give more data if someone is familiar with this issue. Thank you! 

Link to post

I'm trying to get into Skyrim again now that I have a nice computer, by FNIS 3.1.1 is giving me issues. 

 

ERROR(2017): PatchID not found in PatchList, Template line: 1809 (templates\defaultfemale_Template.txt)

 

I have no idea what to do, and it isn't for want of trying. Any insights?

 

 

Edit: also, Sexlab freezes my game with a "you should be using FNIS" message when I try to play.

 

Edit: I was suffering from an incomplete install. If anyone find this post while looking for their own cure, try manually reinstalling via drag and drop. 

Link to post

Hey everyone,

 

I keep having this issues of 1 warning that stated that I install the fnis out of my steam directory.

 

(gah where is the spoiler button?)

 

 

>>Warning: Generator not run from a legal (Steam) Skyrim installation directory. If you use SKSE, this can be fixed by starting Skyrim once through Steam.<<
FNIS Behavior V5.5 fix1   2015/10/28 18:36:37
Skyrim: 1.9.32.0 -
Generator: E:\SteamLibrary2\steamapps\common\Skyrim\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

Skeleton(hkx) female: XPMS2HDT (115 bones)   male: XPMS2HDT (115 bones)
Patch: "SKELETON Arm Fix"
Patch: * groovtama's Alternate Anim. for XPMSE/RaceMenu

Reading DeviousDevices V2.9.2 ...
Reading FNISBase V5.5 ...
Reading FNISSpells V5.0.1  ( 0 furniture, 0 offset, 9 paired, 0 kill, 0 chair, 0 alternate animations) ...
Reading SexLab V1.60 ...
Reading ZaZAnimationPack V6.07  ( 26 furniture, 29 offset, 0 paired, 0 kill, 0 chair, 0 alternate animations) ...

All Anim Lists scanned. Generating Behavior Files....
Generating animationsetdatasinglefile.txt ...

Creature Pack not installed
mt_behavior usage: 19.9 %   ( 26 furniture, 29 offset, 0 chair, 0 alternate animations)
0_master usage: 3.5 %   ( 9 paired, 0 kill animations)

 1964 animations for 5 mods successfully included (character)
 1 Warning(s).


Okay I install steam on my drive c: and it is outside of the program files, and my game library is on my D drive. and I get this error.

 

and plus I tried to applied the memory patch thing using the SKSE ini trick, but yeah it makes it way much worse then when I am not using the skse ini.

 

and also what's the bb code for spoilers ? I can't find the spoilers code as I post this so my apologie for my post that appear to long.

 

 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...