Jump to content
IGNORED

Getting Devious Devices to work in SkyrimVR


Recommended Posts

So, as promised, here is the summarised mod list that came as a result of me aiming to get Devious Devices (and Cursed Loot) running on Skyrim VR. This is my first real pass at Skyrim modding, so this setup is undoubtedly flawed, and I already know it has issues, so will no doubt be revised. But coming to this relatively cold it's been an uphill struggle to try to collate all the different knowledge from Lovers Lab, Reddit, and Nexus, just to try to get this to a basic working state. The least I could do is share what I have working, in the hope that it will save other people some time and serve as a jumping off point where they can refine this list and get what they'd like out of it.

 

I must state that I can take no credit for any of this, all the real work has been done by others, so where possible I've linked to their posts rather than raw download links so you can understand the context of why the various patches are needed. I'm not going to cover any of "the basics" like running FNIS or Bodyslide building, those are covered well enough elsewhere. I'm also not in a real position to offer anyone support, pretty much everyone else will know better than I do why your particular setup does or doesn't work. All I can do is share what I have that seems to function. This has all been set up using Mod Organizer 2.
 

Useful reference links

 

SKSE VR

https://skse.silverlock.org/

Download the Current VR build 2.0.10 (runtime 1.4.15), and install the DLL as per instructions you can find elsewhere. Script content should go into its own mod, I have it later on in the build order.

 

Mod Order

+BodySlide and Outfit Studio - v4.8.0 - Main File

+Bodyslide Generated Content - Created from the overwrite produced by Batch Building in Bodyslide (stuff under Meshes)
+Caliente's Beautiful Bodies Enhancer -CBBE- - v1.5.4 - Main File. Think I mostly picked default options for this
+FNIS Behavior VR 7 5 XXL - Not the Main File, but scroll down to find FNIS Behavior VR 7_5 XXL instead on the same page

+FNIS_Output - Created from the overwrite produced by running FNIS (meshes and scripts)

+SKSE Script Content - Script content from the SKSE VR download mentioned as the first step

+SkyUI v1.0-beta.4 - Not on Nexus, but you can grab the .7z builds from the GitHub page
+XP32 Maximum Skeleton Special Extended - Main File. I picked default options for everything.
+SexLab Light SE 0 1 1 - View this File, Download this file, use the second link (view?usp=sharing) which is a Google Drive one, ignore the network problem and Download, 
+SLLightVRPatch - I used the first of the two files, though I may go back for the VRIK one.
+MfgFix-vr - Second of the two files (MfgFix VR)

+VRIK V0.7.0 - Main file

+VRIK Generated Files - Created from the overwrite VRIK produces (a log file)

+SexLabArousedSSELoose - Main file. This appears to be an add-on for SexLab, not sure if it works with SexLab Light but Devious Devices needs it so needs to be in to satisfy that dependency

+Devious Devices Integration - SE 4.1 - Both files from this link should be used, DDa provides the assets for the next mod, DD provides the integration
+Devious Devices Assets - SE 3.0

+Devious Devices Expansion - 4.0 - Main file. While not called out explicitly as an SE version, I think it doesn't matter as it's just assets

+DeviousDevices VR Release - Download the attached RAR. "hotfix for the Heretic stuff. or else those models will crash you"

+Deviously Cursed Loot - Main File

+DDHOTFIX - Download the attached DDHOTFIX.7z
+DD DCL New CBBE - Mega.nz download link, for "a new CBBE slider set for DD and DCL"

+ZAZ 7.0SE - Rev 1.7 - Main file
+DCL-DD-ZaZ HDT And other patches - Mega.nz download link, fixing various issues with DCL, DD, and ZAZ
 

So in summary:

  • CBBE to get a body
  • FNIS to get animation support
  • SKSE because it's a basis for a bunch of things
  • SkyUI because everything hooks onto it for UI stuff
  • XP32 for a decent Skeleton
  • VRIK for a VR-centric body

gets you to a definitely working, no real issues build. Then you have:

  • SexLab Light + patches (because regular SexLab doesn't work on VR yet)
  • Devious Devices (integration, assets, expansion) + various patches to fix for VR
  • Deviously Cursed Loot for content
  • ZAZ for animations DCL relies on.
  • No RaceMenu for VR, which means no NetImmerse override.

 

Some of these rely on RaceMenu, which doesn't currently work for VR, but its absence doesn't break the other things. IIn-game, you do get messages about NetImmerse override (which RaceMenu should provide) being missing, so that's annoying, and presumably means footwear animations / pose stuff is broken. 

Link to comment
  • 6 months later...
On 4/20/2020 at 6:18 PM, Fakefuta said:

Also I noticed you have VIRK. For me when the Player equips anything it make my VIRK body invisible im assuming this is because im male?

It should not.

Use this guide to install SL and use the SL patch and the VRIK version provided in the thread of the patch.

Then - after you see that it works OK install the additional mods mentioned here.

 

On 4/17/2020 at 1:31 AM, Fakefuta said:

When DD asks to install a DLL for skse should you hit none since the versions do not match?

Yep. "DeviousDevices VR Release" has the dll that works in VR.

Link to comment
9 hours ago, prinyo said:

It should not.

Use this guide to install SL and use the SL patch and the VRIK version provided in the thread of the patch.

Then - after you see that it works OK install the additional mods mentioned here.

 

Yep. "DeviousDevices VR Release" has the dll that works in VR.

  So when I install DDVR it does not have any prompts about dll it just includes the correct one.The issue is probably Im using the DDSE 4.3 file as well, this is when I get the Dll prompt and I hit None ( im assuming thats still correct as its included with the ddvr) The guide says to install Devious Devices Integration - SE 4.1 Devious Devices Assets - SE 3.0 Devious Devices Expansion - 4.0 The links all seem to be bundled into DDSE 4.3 now. I have everything installed according to your guide il go back and check. I already had SL and everything working well a year or more ago. I just recently saw your guide and updated to the virk version of SLVR and tried to add DD. All seem to work fine other then any DD loot item I put on myself makes that body part invisible and Sl virk scenes are just floating cam not pov Im assuming thats correct, I might need to reinstall in mcm for it to use pov EDIT: I checked and cleaned VRIK shows NA under requirements no idea why I get the message saying VRIK required. The DDarmor works on NPC and other items work fine on VIRK just the DDloot it was same for female I change it race menu to check.   

 

Side question iv been messing with trying to get sos collisions working, I saw you had a Link (at the bottom to ref) When you said you had it working was that with Virk/hand collisions? You can dm me so I dont mess up the thread.

 

Link to comment
13 hours ago, Fakefuta said:

VRIK shows NA under requirements no idea why I get the message saying VRIK required

Are you completely sure you use the VRIK file provided there together with the SL VR patch? Maybe it is a good idea to redownload t and install it.

 

13 hours ago, Fakefuta said:

All seem to work fine other then any DD loot item I put on myself makes that body part invisible and Sl virk scenes are just floating cam not pov Im assuming thats correct,

It is not clear from what you said if the floating cam in animations happens only when you have devices equipped or always. With the current version of VRIK the body disappears only in menus.

 

I don't know if somebody has done a complete test of the different DD devices. From my own testing I have noticed that the wearable devices do not work - cuffs, binders do not get equipped at all. It is possible different devices have different issues.

 

13 hours ago, Fakefuta said:

So when I install DDVR it does not have any prompts about dll

This means you did not follow the install order. But yes - the dll that you need is in the VR archive. You can check if you have the correct dll in the sksevr.log that is located in Documents\My Games\Skyrim VR\SKSE.

 

13 hours ago, Fakefuta said:

When you said you had it working was that with Virk/hand collisions? 

I never managed to achieve VRIK hand collisions with the schlong. The breast collisions worked (with the SOS body in the archive linked in that thread), but the schlong didn't. I have given up for now and started using only a CBPC file to make the balls floppy during sex scenes. Still following the physics threads to see if some new development comes along.

Link to comment

It was the wrong VRIK I had the newest official nexus v8. The one in your guide is 8.1 I didnt notice that when looking it over il still have to test but im sure thats going to fix some things. As far as DD sounds like we kinda have the same issue only mine work they are just make me invisible. You can interact with them and my walking animation changes.

 

"This means you did not follow the install order. But yes - the dll that you need is in the VR archive. You can check if you have the correct dll in the sksevr.log that is located in Documents\My Games\Skyrim VR\SKSE."

 

Well idk im using vortex and installs ether have ui or not. I would get it prompt after the fact if it was overwriting or conflicting but I dont get that ether. Im guessing because im using a version of dd that lets me not install that part DD might not know there is a dll to use at all. Il install the wrong dll and overwrite with vr version that might be better and just recheck install order I wasnt aware vortex even cared about install order just conflicts. Hope that makes sense with my poor grammar.

 

Il let you know if I get anything with collisions working. Iv had collisions with some balls working at one point. I think it broke on a update shizof did he might have removed some experimental thing idk could have been something else. Right now it seems my hands only collide with CBPC if I touch HDT items my controller will vibrate like it collided but it will not move. Now that both physics work in vr its only a mater of time Im not sure whats missing at this point or id mess with it. I know shizof was working on not sure if he still is.

Link to comment
  • 1 month later...

If anyone's been having problems with CTDs when struggling out of certain restraints, there's a likely fix for that!

In the Devious Devices SE thread, Boulo 92 posted a patch for one of the DD scripts that handles controller input during struggle events.

 

https://www.loverslab.com/topic/99700-devious-devices-se-43/page/75/?tab=comments#comment-2894066

 

Download: https://www.loverslab.com/applications/core/interface/file/attachment.php?id=854007

 

In my brief testing, this fixes all the issues I've had with CTDs when struggling or if a random trip animation plays!

Link to comment
  • 1 month later...
9 hours ago, AkiKay said:

The "SexLab Light SE 0 1 1" part is outdated right ? I didn´t bother to read the description and thought its the mod that casts a light on the actors. But its just Sexlab and thats it.

Instead of SLLight use the current version of the full SL for SSE. And instead of the VR patch for SLLight use the VR patch for the full SL.

Link to comment
  • 4 months later...

DeviousDevices VR Release.rar is packaged up incorrectly for my mod manager. I had to create a new zip with DeviousDevices.dll inside the following folder structure:

SKSE\Plugins\DeviousDevices.dll

That gets everything loaded into my MCM perfectly.

1Capture.PNG.b0e5a62c0e4ba279eb374e0a876cdf63.PNG

2Capture.PNG.61d8a7b325aaa0aac1656bea7d11a9bf.PNG

 

However I get T-poses for everyone. When I run FNIS it complains:

>>Warning: \character\behaviors\FNIS_DD_Behavior.hkx not Skyrim VR compatible<<
Reading DD V4.0.0 ... 	ChAnims:640(493)	 CTD:11.2%	 pOpt:1.0%
>>Warning: \character\behaviors\FNIS_DD2_Behavior.hkx not Skyrim VR compatible<<
Reading DD2 V4.0.0 ... 	ChAnims:330(330)	 CTD:9.3%	 pOpt:0.0%
>>Warning: \character\behaviors\FNIS_DD3_Behavior.hkx not Skyrim VR compatible<<
Reading DD3 V4.1.0 ... 	ChAnims:102(102)	 CTD:2.5%	 pOpt:0.0%
>>Warning: \character\behaviors\FNIS_DDSL_Behavior.hkx not Skyrim VR compatible<<
Reading DDSL V4.0.0 ... 	ChAnims:410	 CTD:2.8%	 pOpt:0.9%
Reading Deviously Cursed Loot V6.3 ... 	ChAnims:23	 CTD:0.2%	 pOpt:0.1%
Reading FlowerGirlsSE V3.0.2 ... 	ChAnims:1618	 CTD:7.9%	 pOpt:0.0%
Reading FNISBase V7.6 ... 	ChAnims:0	 CTD:0.0%	 pOpt:0.0%
Reading FNISSexyMove V7.2 ... 	ChAnims:21(18)	 CTD:3.3%	 pOpt:2.2%
        NOTE: FNISSexyMove has at least one AASet definition without any animation files provided
Reading SexLab V1.63 ... 	ChAnims:882	 CTD:5.6%	 pOpt:1.5%
Reading SexLabAP V1.63 ... 	ChAnims:142	 CTD:0.9%	 pOpt:0.2%
Reading SexLabAroused V2.9 ... 	ChAnims:5	 CTD:0.1%	 pOpt:0.0%
Reading SexLabCreature V1.63 ... 	ChAnims:177	 CTD:1.2%	 pOpt:0.3%
Reading XPMSE V7.2 ... 	ChAnims:164(164)	 CTD:2.2%	 pOpt:0.0%
Reading ZaZAnimationPack V7.00 ... 	ChAnims:829	 CTD:3.6%	 pOpt:0.0%

The files with errors appear to come from Devious Devices - Integration - Framework & Resources - LoversLab. I'm running 4.3a because 4.1 isn't available anymore. The instructions said to download "both files", but 4.3a appears to only have a single download option. None of the other mods installed appear to overwrite these files, so I don't think it's a load order problem.

 

Lastly, I can't figure out where to download MfgFix-vr , nor what it is. The link just takes me back to this topic.

 

Thanks for the writeup! I've been using SexLab for over 80 hours so I think my SexLab installation is setup properly.

Link to comment
10 hours ago, UASD98lk said:

The files with errors appear to come from Devious Devices - Integration - Framework & Resources - LoversLab.

This link doesn't appear in the tutorial. It is an Oldrim mod, so FNIS complaints about that the animations are not OK. You need the SSE versions.

If I follow the link Devious Devices Integration - SE 4.1  I get to Devious Devices SE 5.0 (2020-11-26) - the SSE mod that should be used.

 

 

MfgFix-vr is here:

https://www.nexusmods.com/skyrimspecialedition/mods/11669?tab=files

Link to comment
  • 2 weeks later...

I want to give everyone the latest list of mods you need for 2020:

 

Not required, but I also installed Laura's Bondage Shop. Because I didn't know where to find the devices in game:

Devious Devices - Laura's Bondage Shop (2-oct-2020) V3.21 - Other - LoversLab

Sadly Laura's shop only sells some outfits and plugs.

If you install Laura's Bondage shop the people in the shop aren't fully voiced. So when you talk to them you won't hear anything. You can install Fuz.Ro.D.oh.VR.-.Alpha.3.zip but I wouldn't bother. It will make people in Laura's Shop talk using subtitles. But it also turns on subtitles for EVERYONE in the game and is SUPER annoying. Maybe install it, check out the shop, then disable it and don't use it again until a v4 comes out with a fix.

 

 

Here's my entire Load order, in case it matters:

 

Spoiler

# Automatically generated by Vortex
Skyrim.esm
Update.esm
Dawnguard.esm
HearthFires.esm
Dragonborn.esm
SkyrimVR.esm
Unofficial Skyrim Special Edition Patch.esp
SexLab.esm
Devious Devices - Assets.esm
SexLabAroused.esm
MajesticMountains_Landscape.esm
3DNPC.esp
Devious Devices - Integration.esm
Devious Devices - Expansion.esm
Devious Devices - Contraptions.esm
High Poly Head.esm
Lanterns Of Skyrim II.esm
MajesticMountains_Moss.esp
BBLuxurySuite.esm
ZaZAnimationPack.esm
UndergroundBathhouse.esm
Schlongs of Skyrim - Core.esm
FlowerGirls SE.esm
LSFX-SSE-Audiosettings.esp
SkyUI_SE.esp
Prometheus_No_snow_Under_the_roof.esp
SMIM-SE-Merged-All.esp
sr_FillHerUp.esp
Devious Devices For Him.esp
Devious Devices SE patch.esp
ub_cell_darkarea.esp
ub_cell_armory.esp
ub_tapestry.esp
SLAnimLoader.esp
Botox SE.esp
Botox SE - Flower Girls.esp
FNISSexyMove.esp
FNIS.esp
3DNPC0.esp
Carry Weight x100.esp
Chesko_WearableLantern.esp
Enhanced Vanilla Trees SSE.esp
AmazingFollowerTweaks.esp
Remodeled Armor - Vanilla Replacer.esp
BeSeated_3.0.0.esp
LoS II - Tamriel Master Lights.esp
JKs Skyrim.esp
Onyx Weathers.esp
NoRoadPredators.esp
LoS II - JKs Skyrim patch.esp
Nordic Ruins of Skyrim.esp
Point The Way.esp
WayshrinesIFT.esp
CFTO.esp
Inigo.esp
MistySkye.esp
Laura's Bondage Shop.esp
Men of Winter.esp
eeekie's Enhanced NPCs All-in-One.esp
BelleFollowerHP.esp
MajesticMountains.esp
UnreadBooksGlow.esp
Bijin Warmaidens.esp
Bijin Wives.esp
RaggedFlagonSign.esp
SexLab-AmorousAdventures.esp
BetterDwemerExteriors.esp
notice board.esp
HottIldari.esp
Schlongs of Skyrim.esp
SOS - Shop.esp
SkyTrek.esp
ub_bbls_merge.esp
ub_invite_any_npc.esp
WiZkiD Signs - No Snow Under the Roof patch.esp
LoS II - SMIM patch.esp
WiZkiD Signs - Interesting NPC patch.esp
Better Dwemer Exteriors - NSUTR Patch.esp
MistysHairSalon.esp
SkyDreamMaidens.esp
BBLuxurySuiteENM.esp
BlendedRoads.esp
DragonbornUnlimited.esp
Spellsiphon.esp
CBBE.esp
TheEyesOfBeauty.esp
SOS - Smurf Average Addon.esp
SOS - VectorPlexus Muscular Addon.esp
SOS - VectorPlexus Regular Addon.esp
holycow.esp
NoStagger.esp
RaceMenu.esp
RaceMenuPlugin.esp
RaceMenuMorphsCBBE.esp
SOSRaceMenu.esp
XPMSE.esp
vrik.esp
Gold Spell.esp

 

Link to comment
  • 2 weeks later...

Warning, while  DDHotfix was designed to prevent CTD, that's exactly what it causes if you use it with UUNP bodies in VR.  (Although its fine for CBBE in VR).    Had to completely uninstall DD to get game to boot again. Can't blame Pfiffy, it was written well before VR was even a concept

 

But otherwise @UASD98lk, thanks so much for going to the trouble to update the list to 2020 ?

Link to comment
  • 3 weeks later...
  • 3 weeks later...
On 2/6/2021 at 9:11 PM, Buckandisdead said:

It is being triggered i think by pop or sometimes interactive bdsm if I try to interact with an npc on a device or when I am being controlled etc

This is not very specific.

I'm asking because other people that use DD and ZAZ have said they don't experience it.  So if I can reproduce your issue I might be able to fix it.

I'm having a diferent problem with DD at the moment - I can't load any save, just CTD.

Link to comment

Prinyo,

 

I had the spinning head in ZAZ as well.  It was whenever POP or SUM would put me in a ZAZ pose.  You can release yourself from the ZAZ pose and the spinning stops and player control returns.  This only happened after I upgraded to the new POP and SUM and ZAP 8+ on the conversion page.  I had all older versions of them and had no issue but several of the POP/SUM scripts would hang or not work right.  Now they work right but cause the ZAP pose spin.  I have not isolated which of the three updates was responsible.

 

I am also having problems with @UASD98lk new DD5 set up.  I have tried a few things and get CTD on most load saves (not always though). I won't be able to test more until Thursday.  Lot of new combinations to test to see what works.  Also have Devious Mimic Clothes and DD Escape Overhaul (which is why I wanted to upgrade in the first place.)

Link to comment
3 hours ago, prinyo said:

POP as in Prison Overhaul Patched? Last I tried it several months ago it always got stuck at getting me arrested. Will give it a try again.

 

Yeah there is a new POP conversion by Herowynne that in my limited testing (I try not to get arrested) fixes all the script hangs that were happening in Nomaz's earlier conversion.  The new SUM conversion has night vision activated, which was broken before.  The constant flashing and color changes had me freaked out until I disabled in in the SUM menu. However, as mentioned earlier, there is the ZAZ pose head spin now.  It will happen on arrest or when put in a ZAZ device.  You can pull yourself out of it in the SUM menu or hot key the release control function and the spin stops until the next ZAZ pose.  Prinyo, you seem to be a bit of a script wizard and might know how to patch the head spin camera issue with VIRK.

 

I also want to return and further trouble shoot the DD5 issue.  For the record I have not started it with a new game as I don't want to spend hours in MCM just to have it not work.  I had an old DD working fine on SkyrimVR fine with DCL, Captured Dreams, and Devious Followers Continued.  So far I have tried exactly as UASD98lk has posted except I am on ZAZ 8+ and Sexlab Beta 7.  My issue seems to be the same as you mentioned in post #19.  I can have everything running on my old save, (DD5 works, in can exit devices, Devious Memic Clothing is awesome) but I CTD 95% of the time on loading the a save with the updated list.

The following is what I have tried:

DD5.0 with/without DD5.1 update with my old DCL and the DCL 8.4 version. I have also tried disabling and moving around the Hotfix / other patches. 

 

I would be interested to know if @UASD98lk upgraded on an old save from post #1 to the list in post #13 or started a new game.  Is that what you did as well prinyo?

Link to comment

Okay so I bit the bullet and started a new game, sat through the initialization of over 350+ mods, installed some from the MCM and got the DD5 installed and the new saves to load.  So the list by UASD98lk is working on my side with a new game. As an aside, I have also found that I can scrub the old DD save with Fallrim Tools (Batch clean, removed unattached/undefined) and get the old DD save to load with DD5.  I understand that it might not work for the long haul but I am still tinkering with the playlist so... fingers crossed. So far it is working with no CTD.

Link to comment

Did some testing this weekend. Seems I'm crashing with the new DD - v5. The older versions - 4.1 seem to work fine. As in "decorative" devices are visibly equipped, cuffs and binders are not.

Installed POP and got arrested, but couln't make anything happen while in the cell. There were notifications shown that I'm fantasizing about been tied-up, but  no NPC payed any attention to me. Played with the MCM trying to make something trigger, but with no result.

However the mod adds pillories downtown Whiterun so I tested activating them. Could not get the world rotating issue. By the way I'm using ZAZ 7.

 

Link to comment

I have been having issues with XP32MSSE, after starting the game it crashes before it reaches the main menu. All other mods load and work. The issue is with XP32 and I cannot figure out how to fix it. I believe I deleted a file from it and it worked but after re-enabling the mods it does not work. I have tried redownloading it several times and reloading the other mods to no effect. Any suggestions?

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...