Jump to content
IGNORED

Need help on Sexlab Framework & Sexlab Defeat


Recommended Posts

So, I'm totally new to modding Skyrim with Sexlab. So I did my best to follow guides and tutorials, but nothing is really clicking with me. There's a lot of stuff I don't quite understand and despite looking it up directly on the download page and on the forum, I feel like I'm just downloading too much files and making it more complicated than it actually is. I'm hoping someone could walk me through the process of modding it properly, especially after I spent a lot of time trying and ending up getting nowhere.

 

Mod Organizer?
I'm using Mod Organizer 2. I only started using it because there was a tutorail that used it, so I used it as well to follow along. It helped me install FNIS, but it's not like I got much with it. I'm pretty okay with switching Mod Organizers if it means getting Sexlab Framework and Sexlab Defeat to work.

 

What did I download so far?

Geez, I honestly went on a wild goose chase doing this. I tried my best to get the right downloads, but I was a bit overwhelmed by SSE version, compatibility issues, and so on.

> Sexlab Framework v162 FULL

- SKSE for SSE Build (No Steam Version)

- FNIS Behavior SE

- FNIS Spells

- FNIS Creature Pack

- SkyUI (This one was very straightforward from the looks of it. Just changed the interface but made it more convenient.)

- XP32 Maximum Skeleton Extended

 

> Sexlab Defeat

- FunnyBizness Animation Pack (Recommended Animations to go with mod)

- Sexlab Animation Loader (Recommended Loader to help Sexlab operate as said in the description)

 

The Sexlab Animation Loader added more to the list of stuff I had to download.

> Sexlab Animation Loader

- JContainers

 

At one point, I even downloaded these and still have no idea how they work or what to do with them. I forgot what they were for by now.

- Net Immerse Override

- RaceMenu

It seems RaceMenu already has Net Immerse Override in it as it was mentioned in the description, but whatever I was reading that told me to get them said I needed to.

 

The Goal of all this is to just get it working.

I just want to use the Sexlab Defeat mod, which requires me to download Sexlab Framework. I thought that would be simple enough, but after going bit by bit, I realize I have no idea what I'm doing,

 

I don't know where to place the Animation Files for the mod to.

 

I don't know what I NEED to download and how to install them.

 

I don't know what Mod organizer can help me get through this the best.

 

I don't know if I really need Sexlab Animation Loader or just need Sexlab Framework.

 

I don't know if I need this Jcontainers thing.

 

I just want to get the bare minimum working. Just want to get the standard Sexlab Defeat mod working.

 

The Guides are somewhat helpful on installation, but reading them still perplexes me. It may be due to the fact that I haven't gotten to deep into modding Skyrim at this level. So whatever help you can give would be most appreciated!

I already watched some tutorials, but I still need help. I'm going to try and start from scratch and maybe I can get it working by that way.

Link to comment

Hey there, 

 

modding Skyrim isn't that hard anymore, but I can totally understand you. At the beginning it's complicated and I got my knowledge mostly by trial and error. I would recommend to begin from scratch. But it also should not be a problem if you just switch mod manager. Just uninstall everything on your other manager first. Do you mean installing the mods on Oldrim or Skyrim Special Edition ?

Anyway I'll help you as much as I can. I'll try to make it a detailed as I can.

 

So, before you mod anything you have to start Skyrim the old fashioned way without the script extender. You need to do this, so the original ini file is created. Launch the game one time this way, then you are done. Just don't forget after installing mods, ALWAYS launch your game with the script extender.

 

This is also a very long thing to do so everything works. Once you are done, it's totally worth it.

 

Before getting started, there are a few programs you might need:

 

1. Get NMM. I've always been using this. It works quite well and it is pretty easy to use. https://www.nexusmods.com/skyrim/mods/modmanager/

Always start this program with Adminrights, or there could appear an error.

The program should auto detect your games. If you got a nexus account you can connect it with the mod manager, it's easier to download mods from the nexus and automaticaly puts them in the right categorie.

 

Now how to get mods to work from other sites than nexus:

In the interface of the program, there should be in the top left corner 2 segments. One called plugins, the other mods. Click on mods. Now you see the mod categories. On the left side, there should be a green plus sign. Click on that and you can manually select a mod you want to add. Manually added mods are always in the "unassigned" categorie.

To activate the mod, click on it in the list and press the green checkmark on the left side, that should appear. To deactivate it, press the red x.

 

Okay, so what I always do after I install mods, I go to the tools section on the top. It's a wrench and screwdriver symbol. There is a small arrow on the right side of it. Click on that. On the list of tools, at the very end, there should be a option " Reset Archive Invalidation". Do that and click yes. Do that always when you install new mods.

 

2. Install skyrim script extender. You are bound to need it. https://skse.silverlock.org/

Install it where your skyrim.exe file is.

 

3. LOOT. This is a very nice program to organize your load order. It also tells you if you have a dirty plugin, if there is a masterfile missing, etc. It also should do everything automatic. https://loot.github.io/

On the top middle, there you can select your game you want to organize, select skyrim and on the right side there is a button that is called "Sort Plugins" It looks like 3 lines. Click on that and the program sorts your mods in the right load order. Totally neat.

 

NOW MODS:

 

I hope I understood this right and you are playing the normal Skyrim Version ? Not the Special Edition ? Either way this also should work for the special edition.

All mods I have from the nexus I download it through the nexus manager. NOT VORTEX, do not touch vortex, don't even look at it. It's unhealthy for you.

You can also download the files from the site manually, just add them through the NNM like I said above. Don't know if they are in the right categorie then though.

Also you are going to install the custom bodies with bouncy effects, because right now I have no idea what else you would need if not that. I'm sorry that I can't help you more, I just know how to install it like I have it on my pc. There may be more ways, but I don't know all of them either. 

 

First you need the unofficial skyrim legendary patch if you have all the DLC's. I think you got them all, right ? https://www.nexusmods.com/skyrim/mods/71214/?

SSE version -> https://www.nexusmods.com/skyrimspecialedition/mods/266

 

Ok, now you need SKYUI https://www.nexusmods.com/skyrim/mods/3863

 

You need a custom body for your characters as far as I can remember. There are so many to choose from and this gets kinda complex. So bear with me here, as I can't remember it that well. I have CBBE installed with the bodyslide and outfit studio. You can only install the CBBE if you want and select the premade bodies from the installation. To make your own customisable female bodies you need the outfit studio too. There are a lot of tutorial videos on how to make your own bodies. I can't write it all down, as it will take too long.

CBBE -> https://www.nexusmods.com/skyrim/mods/2666

Bodyslide -> https://www.nexusmods.com/skyrim/mods/49015/

 

This is for male characters: 

 

 

ok, after this you need a CUSTOM SKELETON and this gets a little confusing: You need a skeleton, racemenu, skse and fnis for the skeleton to work. You do not need netImmerse override, as it is already in the race menu mod. 

 

Race Menu: https://www.nexusmods.com/skyrim/mods/29624/?

You going to need this for so many things. I forgot for what though. Never bad to install it anyway.

 

You need a custom skeleton. I use XP32 Maximum Skeleton Extended https://www.nexusmods.com/skyrim/mods/68000 

 

After that this mod, hdt physics ->https://www.nexusmods.com/skyrim/mods/53996/?

 

All of this you just need for the bodies, it has nothing to do with the animations for sexlab. I know this sounds totally unnecessary, because you just want to install sexlab. I am giving you the whole package for the long run. But now you have BOUNCY effects, lol. See it on the bright side.

You may need to look up armor made for HDT though.

 

You need FNIS for all animations. So it is a must.  https://www.nexusmods.com/skyrim/mods/11811/

I use the FNIS Behavior 7_5 XXL mod, because there are a buttload of animations out there. Maybe you need it, maybe you don't. If not, then just install the normal version. Maybe you want the creature pack too if you want animations with animals and such. (OK nvm, you NEED the CREATURE PACK TOO!) Also just to be save, install the Spells Pack. Should be 3 mods now from FNIS. Install it and launch it with admin rights. 

 

Ok listen up: IF you have XPSME installed and FNIS. Launch FNIS and look at the bottom list with the patches the SKELETON Arm Fix should be ticked. IF NOT, say something.

 

Everything installed now ? Great ! First mod installation section over. Then run the Archive Invalidation and LOOT afterwards. Start the game with the script extender and see if the game runs and shit. Play till you can save. Then quit the game again. Now take a short break if you want, or your head might spin. 

If everything works till now, you are doing great.

 

Second mod section:

 

1. Install Sexlab https://www.loverslab.com/files/file/150-skyrim-sexlab-sex-animation-framework-v162-updated-jun-3rd-2016/

 

2. Install Sexlab Defeat https://www.loverslab.com/files/file/286-sexlab-defeat/

 

3. Install JContainers https://www.loverslab.com/files/file/563-jcontainers/ 

4. Install Sexlab Animation Loader: https://www.loverslab.com/files/file/2488-sexlab-animation-loader/

 

Now you need animations: 

https://www.loverslab.com/files/category/25-animation/

You can install any animations that have SLAL in the title. Or just read the descriptions of the animations mods. Normally it says somewhere in there if the animations work for SLAL.

 

After you install all the mods, always run FNIS if you uninstall or install new animations, or all your characters will freeze.

 

Ok now start skyrim with skse and start a new game or load your old one.

You need to go into the ingame menu and go to mods and activate sexlab. Go out of the menu and let sexlab install/update. In the right upper corner of your screen there should be a text, "Installing Sexlab, etc" After that is done go into the menu again and config sexlab the way you want to. You can save/export these settings too, so you don't have to do it everytime you begin a new game. You just have to import them again.

You can do the same with sexlab defeat. 

 

Now go into SLAL and you can pick the animations you installed and register them to sexlab. You can then go back to the sexlab menu and toggle the animations to see if they are installed. 

 

NOW you should be set I hope. Hopefully I could help you somehow.

If something comes up or you didn't understand something, just write back and I can see if I can help you with it. 

 

Have fun !

Link to comment

I really love how much details you put in! Thank you so much!

I've downloaded the NNM Mod Manager from the link you've provided and was about to re-download Skyrim Script Extender.

 

The game I'm modding is the "Skyrim Special Edition" (Sorry for not being clear about that!)

So since I'm using skyrim Special Edition, I download this link? (The link within the red square of the image I've provided)

1159814954_SkyrimScriptEditorWebsiteimage.png.ee92720c9fbefb861625da6b0ab0d6be.png

Link to comment

Yeah ok all the mods exist in the Special Edition too, so that doesn't change much.

 

You don't need HDT then anymore. You need these links then. Also install them in that order.

 

SkyUI: https://www.nexusmods.com/skyrimspecialedition/mods/12604

CBBE: https://www.nexusmods.com/skyrimspecialedition/mods/198

Bodyslide:https://www.nexusmods.com/skyrimspecialedition/mods/201

Schlongs: https://www.loverslab.com/files/file/5355-schlongs-of-skyrim-se/

Racemenu: https://www.nexusmods.com/skyrimspecialedition/mods/19080

 

XP32MS: https://www.nexusmods.com/skyrimspecialedition/mods/1988

FNIS: https://www.nexusmods.com/skyrimspecialedition/mods/3038

 

Ok then you need other sexlab mods for Skyrim Special Edition. There aren't that many, but I think the 2 you want are available

 

Sexlab SE: https://www.loverslab.com/topic/91861-sexlab-framework-se-163-beta-7-june-17th-2019/

Defeat SE: https://www.loverslab.com/files/file/9152-sexlab-defeat-sse/

 

JContainers SE: https://github.com/ryobg/jcontainers/releases

SLAL SE: https://www.loverslab.com/files/file/5328-sexlab-animation-loader-sse/

Animations: https://www.loverslab.com/files/category/163-skyrim-special-edition/

There are animations in that list, you would need to look around a little.

 

So just follow the same steps, that I posted. Just use these links instead.

Hope that helped :) 

 

Link to comment

It really helped! Everything seems to be going smoothly!

I only need to confirm something about the Jcontainers & a file conflict

 

For Jcontainers, this is the file I download? Or do I just choose any of them?

Which one do you think?

1938675742_Jcontainersdownloadimage.png.8b85a206226fa982ec6f34f2a8ff87db.png

 

And the file conflict has something to do with the SOS and XP32 Maximum Skeleton Extended.

 1824990036_FileConflictpart1.png.f91aa6524e3c50035139cb0a58b4a95f.png882853717_FileConflictpart2.png.db164faf65222b72c0b45cf5b4a3f8e1.png

 

How should I set this up?

Link to comment

Yeah version 4.1.11 sounds right. That should be the right file. The other ones are source files, you only need those if you are a modder.

 

Ah ok, yeah that's normal. 

Load Schlongs first und the XP32MS after that. It just overwrites the file, but it should still work. :) 

 

Also some animations may have other requirements, but it should mention that in their descriptions. 

 

Link to comment

Everything looks good to go!

All I need left are the animations, right?

 

Are some animation files aren't compatible with Skyrim Special Edition but compatible with Skyrim (Old version)?

I just need to look for the ones meant for Skyrim Special edition then?

 

And when I download the animations, do I just install them like I did with the other mods with Vortex?

Then I use FNIS for Users?

Link to comment

Yeah you need animations, otherwise nothing happens.

 

Na that second link I sent you, in the third post I made, directs you to the animation for SSE. 

this one -> https://www.loverslab.com/files/category/163-skyrim-special-edition/ all of those animations are for SSE.

 

Yeah you just download them, activate them, and run FNIS. Oh you did use Vortex ? Not NMM ? Thats alright too. 

Ingame you should get a message, that it found new animations I think. If not, just look in the SLAL options and they should be there. Register them in SLAL aaand that should be it :) 

Link to comment

I seem to have hit a slight bump on the road.

I launched Skyrim normally, but realized the SKSE wasn't active because the Bethesda logo started flickering all over the place when it showed up.

 

It's a symptom I noticed when I don't run Skyrim Script Editor.

So I tried to launch SKSE but it couldn't locate the Skyrim exe. (Executable file, right?)

How should I remedy this?

Link to comment

I'm kinda embarrassed how frequently I'm sending a new message today, but the good news is that the mods seem to be working quite well!

The problem I mentioned earlier stopped appearing too for some reason. Like, I can't pull up the thing that happened because now it shows something different. Sexlab options and stuff like that. Great news!

 

The bad news is, the sex animations aren't working. The first animation I triggered had the partner walk across the room before my character teleport to them. they then stood at the same exact spot while being naked. No animation was playing though, and I checked the Mod configurations for it to tell me that the animations have been enabled and registered.

 

So it's working, just need to figure out what's wrong.

 

I haven't used the LOOT program you sent me yet. I wasn't sure what to do with it, so maybe that's a factor.

There's also the FNIS HKX File or other check boxes I haven't filled out yet.

I think there's some devices in the FunnyBizness Animations for SSE, but I'm not totally sure if that was the problem.

1764839661_MissingFilesforSkyrim.png.33140f844e24f19100379b37c2bff228.png

Link to comment

Now hold your horses there. ^^

It's alright that you ask that many questions. No problem.

 

7 hours ago, Slickbutter said:

I remembered how I did it last time, so I fixed it!

I seem to be missing files according to the Mod configuration.

Should I do something about this?

Missing Files for Skyrim.png

That is alright. Should work anyway. 

 

No animations, huh ? Hm... could be multiple things, but I guess it has something to do this FNIS.

 

Yes run loot please. You should always do that.Maybe it solves problems then.

Uh ok, have to clicked on those patches yourself or did FNIS do it on its own ?

Also if you run FNIS, does it have a warning about something ?

And when you downloaded animations, did you make sure to look at the requirements, if they have any ?

Just asking, so I can narrow it down.

Link to comment

Hope Im posting this in the right place. New to modding Skyrim myself. Having much of the same issues. After 24 hours ive narrowed it down to when I add Devious Devices Integration, is when the FNIS gets errors. Nothing ive downloaded or played with has stopped it from causing everything to freeze in a pose. FNIS error:

 

>>Warning: \character\behaviors\FNIS_DD_Behavior.hkx not Skyrim SE compatible<<
Reading DD V4.0.0 ...     ChAnims:640(493)     CTD:11.2%     pOpt:1.0%
>>Warning: \character\behaviors\FNIS_DD2_Behavior.hkx not Skyrim SE compatible<<
Reading DD2 V4.0.0 ...     ChAnims:330(330)     CTD:9.3%     pOpt:0.0%
>>Warning: \character\behaviors\FNIS_DD3_Behavior.hkx not Skyrim SE compatible<<
Reading DD3 V4.1.0 ...     ChAnims:102(102)     CTD:2.5%     pOpt:0.0%
>>Warning: \character\behaviors\FNIS_DDSL_Behavior.hkx not Skyrim SE compatible<<

Link to comment
9 hours ago, outcast512 said:

Hope Im posting this in the right place. New to modding Skyrim myself. Having much of the same issues. After 24 hours ive narrowed it down to when I add Devious Devices Integration, is when the FNIS gets errors. Nothing ive downloaded or played with has stopped it from causing everything to freeze in a pose. FNIS error:

 

>>Warning: \character\behaviors\FNIS_DD_Behavior.hkx not Skyrim SE compatible<<
Reading DD V4.0.0 ...     ChAnims:640(493)     CTD:11.2%     pOpt:1.0%
>>Warning: \character\behaviors\FNIS_DD2_Behavior.hkx not Skyrim SE compatible<<
Reading DD2 V4.0.0 ...     ChAnims:330(330)     CTD:9.3%     pOpt:0.0%
>>Warning: \character\behaviors\FNIS_DD3_Behavior.hkx not Skyrim SE compatible<<
Reading DD3 V4.1.0 ...     ChAnims:102(102)     CTD:2.5%     pOpt:0.0%
>>Warning: \character\behaviors\FNIS_DDSL_Behavior.hkx not Skyrim SE compatible<<

Well you see it says it right there: not Skyrim SE compatible. You have the wrong version. Maybe you accidentally downloaded Devious Devices for Skyrim, not for the Special Edition.

This is for Special Edition -> https://www.loverslab.com/files/file/5878-devious-devices-se-beta/

 

 

Also it has a lot of requirements. Don't forget that and please check if you have all of them.

Link to comment

I managed to fix it by using LOOT and FNIS after double checking on both the configuration of FNIS on Vortex and using FNIS directly

 

It works! Thank you so much!

There are some weird things that occur before and after scenes, like how the transition to the sex scene is the partner awkwardly walking over. But that's not as much of a problem.

The cum isn't very visible though. I'm thinking of finding another mod to replace it with something more visible

 

By the way, I have FNIS Creature Pack

But do I also need Creature Frameworks to make the animations happen?

 

 

I only have Sexlab Framework for SSE.

Link to comment
2 hours ago, outcast512 said:

Yeah I was afraid someone would point that out. Its not the case though, unless the dl was marked incorrectly. I just started downloading this week so everything is the newest version.

 

 

https://www.loverslab.com/topic/99700-devious-devices-se-beta/#comments

Uh ok, well it is beta. Probably some minor thing wrong in the update. I'm sorry to say, you probably need to wait and deactivate the mod :( 

Link to comment
2 hours ago, Slickbutter said:

I managed to fix it by using LOOT and FNIS after double checking on both the configuration of FNIS on Vortex and using FNIS directly

 

It works! Thank you so much!

There are some weird things that occur before and after scenes, like how the transition to the sex scene is the partner awkwardly walking over. But that's not as much of a problem.

The cum isn't very visible though. I'm thinking of finding another mod to replace it with something more visible

 

By the way, I have FNIS Creature Pack

But do I also need Creature Frameworks to make the animations happen?

 

 

I only have Sexlab Framework for SSE.

Haha that's grand ! Happy to help :)

Yeah just adjusting the load order makes a differenz ^^ I have that too sometimes with the awkwardly walking. Don't really know what causes it. 

 

Yeah I know. I changed the cum too. Here is one for SE -> https://www.loverslab.com/files/file/8876-insane-cum-retexture-sse-lite-versionpainted/

 

 

Ah shit yeah, I totally forgot that part. You need new bodies for the creatures too, of course ! https://www.loverslab.com/files/file/5464-more-nasty-critters-special-edition/

 

That link should work, and then you need the creature framework, yeah. 

 

First you install the more nasty critters and as it says on the page: do not let XPMSSE overwrite those files.

So if it askes something about overwriting files, you press "no to all" or something.

Then you install the creature framework. After that you are done. Maybe run FNIS again just incase.

 

Creatures can be a bit buggy, you try that out and tell me if it works with the creature penises. Also: I did not find a More Nasty Critters SLAL Edition for SSE. I hope it works just fine with the normal MNC.

 

Link to comment
40 minutes ago, Dovakeks said:

Uh ok, well it is beta. Probably some minor thing wrong in the update. I'm sorry to say, you probably need to wait and deactivate the mod :( 

Would I be able to dl the previous version or would that create more problems deleting and putting in a new mod?

Link to comment

Well normally , yes. Load your save game, see if it stills works without the mod. Save again and exit the game. Now install a previous version of the mod, if you can find one. See if that fixes anything.

And always update FNIS to that.

So: Uninstall DD -> Update FNIS -> Load Save -> See if you can still load it -> Save again, exit -> Install previous version -> Update FNIS -> Load your save.

 

If you can't load your save, try a new one. Well create a new game, see if that works. If both don't work, then I would delete the whole mod and search for a other one.

Link to comment

Okay, closer to solving this.  It seems the SE edition of the mod contains both the needed Assets and Integration. FNIS reads with no warnings. 

Now though i cant launch the game, just crashes. After looking at my plugins page of NMM it shows 4 mods as needing an Integration .esm-MISSING. 

Thoughts?

Link to comment

Okay, so I already downloaded Creature Framework SE with the download of More Nasty Critters

The animation are present as well as the correct models

 

I notice the cum issue wasn't that it wasn't big enough, but there's actually no cum even after I downloaded the mod. Is there a setting or something I supposed to change?

 

Also after having some animation scenes with the creatures, I couldn't unsheathe my weapons. Can still walk, pause, open item/spells, and talk to people, but no unsheathe. It apparently stays on until I exit the game to desktop. Switching files or loading a game will have the same problem until then.

Link to comment
11 hours ago, outcast512 said:

Okay, closer to solving this.  It seems the SE edition of the mod contains both the needed Assets and Integration. FNIS reads with no warnings. 

Now though i cant launch the game, just crashes. After looking at my plugins page of NMM it shows 4 mods as needing an Integration .esm-MISSING. 

Thoughts?

Do you mean the previous Version now of DD ?

Yeah thats normal, without the esm. Which one is missing, well from which mod ?

Well just get the mod with the esm in it. I don't know which one it is that is missing. Or isn't it ticked in your mod list ? 

Link to comment
1 hour ago, Slickbutter said:

Okay, so I already downloaded Creature Framework SE with the download of More Nasty Critters

The animation are present as well as the correct models

 

I notice the cum issue wasn't that it wasn't big enough, but there's actually no cum even after I downloaded the mod. Is there a setting or something I supposed to change?

 

Also after having some animation scenes with the creatures, I couldn't unsheathe my weapons. Can still walk, pause, open item/spells, and talk to people, but no unsheathe. It apparently stays on until I exit the game to desktop. Switching files or loading a game will have the same problem until then.

Oh ok, yeah in Sexlab menu there is somewhere a menu option, that you have to switch on. You can also set how long the cum should stay on. You can normally wash the cum away, when you swim in game.

 

Did you try un equip/unequip your weapon ? Like going into your inventory, equipping/unequipping it again. That normally works or go into the console and type enableplayercontrols

Also this could be a bug from the game itself. Although that shouldn't occur anymore when you have the unoffical patch installed. Hope you did that ^^

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...