Jump to content
IGNORED

Outfit Studio/Nifskope .nif conflict


Recommended Posts

I used to do my scale/move in .nifskope before pushing and pulling the verts in OS for any actual reshaping, but I realized this was silly since I could just so everything in OS. So I did! Only I've run into a small issue with my first such project.

 

I edited a set of torso armour meshes in OS and everything turned out perfect. Only when I check the new file in nifskope, the edited elements are now tiny for some reason? And flipped front-to-back? Searched for a while but did not see anything regarding scaling errors in this way.

 

I assume I need to confirm the transformation somehow in OS before saving it, but how exactly? What did I need to do that I missed?

 

Please help, thanks! File attached:

 

cuirassheavychieftain_1.nif

Link to comment

Okay, this is weird as fuck, because when I open the file (the one I attached, not the one you edited) in OS, it looks like this (and I completely closed and re-opened OS):

 

0Dmuj7D.png

 

Why would it be displaying differently for you and me?

 

Going to be something of a pain if I have to go back to the old way in order to get reliable scale/move transformations, since doing everything in OS allows me to use transparencies and reference meshes to get a much better fit.

Link to comment

My skyrim outfit studios is a older version so the problem could also be with whatever version of outfit studios you are using. You could check with author and have them look at the file and see if it's being caused by the outfit studios version you are using and if it is then they can see what needs to be done to fix the problem.

Link to comment

So I still haven't solved this issue. I tried this with some other outfits and it turns out this happens with every mesh I use any transform (move/scale/etc.) commands on in OS. So I don't think this is a mesh issue?

 

I also could not reverse the armour 180 degrees as you did and I'm not sure why - when I tried any transform command in .nifskope it would not apply!

 

Is it possibly because I'm converting male meshes to female ones? Do I need to maybe set something up with regards to the Skeleton? I don't think so because I've tried starting off with both a female mesh and a male mesh as the base and they generally have the same nodes (and if they don't I wouldn't be able to paste them anyway without adding any required nodes), but I figure I should ask? I have also set the female skeleton as the base in BodySlide correctly as far as I know.

 

I also never installed the slider sets for UUNP or CBBE for Bodyslide when I installed the newer OS because I found I don't really use BS for conversions usually, I only use OS to directlly hand-edit meshes. Could this be the issue?

 

Just banging my head against the wall here... either my options are to just eyeball my transformations in nifskope, or to go all the way back to a much older version of OS, with less features and an unfriendlier UI (I upgraded to the latest OS and it has some fixes I've wanted for a long time).  This seems like something really basic and fundamental to OS, but I don't know why or how I'm breaking it so badly!

Link to comment

Another small update.

 

I was able to get my edited mesh to appear correctly in Nifskope by applying the transformations the mesh preloaded with, but now the torso appears enormous in Outfit Studio.

 

So basically, I can mirror the problem, but I still can't get the mesh to appear the same in both OS and nifskope. 

Link to comment

So I ended up contacting Ousnius directly and he provided the answer to the mystery:

 

Quote


ousnius, on 02 Apr 2018 - 08:34 AM, said:

Hey,

 

meshes in Skyrim and FO4 have a vertex position, a shape transform, a skin transform and bone transforms for each bone.

Outfit Studio renders all of them except for the individual bone transforms, because those would be in the way a lot when editing meshes or when transforms aren't correct.

 

Now the problem is, often meshes were created in really unclean ways using the various 3ds max or Blender plugins (or bad practices in the tools).

They can have transforms all over the place, including skin transforms that are then "corrected" using bone transforms, which is horrible and Outfit Studio won't render the latter so it will be off.

 

In older versions of OS, there were no transforms being rendered yet, so those meshes can sometimes "accidentally" appear in the right spot, because neither the positive (skin) nor negative (bone) transforms were rendered.

If you have the latest version of NifSkope (Dev 7), what you will see there is exactly as it will appear in-game. So you can use that to check.

 

To fix any and all transforms, you can always export meshes to OBJ files, unload the current project (or close OS) so that any stored transforms are deleted and import the OBJ files back.

Preferably you should load a reference body with correct transforms before loading other meshes. Then you can copy bone weights back.

 

An alternative is disabling the "Skinned" checkbox in the shape properties of the meshes.

This will delete all weights, bones and bone transforms from the mesh and you can copy those of a reference (again make sure to load the reference first).

 

In the end it all comes down to bone transforms and unclean exports. This isn't something that happens for every outfit.

 

Regards,

ousnius

 

 

Problem solved!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...