Jump to content

Animations triggering but not playing


Recommended Posts

So I'm a first timer for running this, and I've run into an issue. When I have a situation that a sexlabs animation should trigger it instead gives a pop-up saying that the animation has been triggered, but the characters get teleported to the starting positions and then do not move or do anything until the scene has ended. All of the other mods work fine, so I am lead to belive that it is something to do with either sexlabs or FNIS. I was pretty certain I set them up properly. If anyone who has had similar problems could point me in the right direction it would be greatly appreciated.

Link to comment

Same as above, make sure that FNIS patches and does it correctly, if you are using Mod Manager remember to execute GenerateFNISForUsers inside MM, or it won't detect your mods.


Also, if you have any Devious mods, some of those items prevent you from the animations triggering.


If you did install SexLab in MCM make sure you have toggled the animations on.

Link to comment

I made sure sexlabs installed, and I have none of the devious devices, But i'll try to make sure that I generateFNISforUsers, but for some reason that doesn't show up and reinstalling didn't make it appear.  I've been searching for FNISbehaviors.exe but its nowhere to be found. I'm on windows 7 if that helps.

Link to comment

You didn't install FNIS correctly.


FNIS is not a mod that you just download, and then activate and all is well. You actually have to use the program.




Watch this video. It will guide you through installing FNIS correctly with both MO and NMM. Gamerpoets videos are very well done, and I would recommend them to anyone who is starting modding.

Link to comment

I figured out the setup, I watched that video previously, but must have missed the section for launching FNIS because I had no idea how to find it even after scouring my computer. I found it through manager, but when I run the program it says that the animations for sexlabs have no coresponding behavior file and will be ignored. Is that normal or has my download fucked up?

EDIT: I tested it and it seems to be working, but that warning concerned me. Thanks so much for your help!

Link to comment
9 hours ago, therudolph said:

but when I run the program it says that the animations for sexlabs have no coresponding behavior file and will be ignored. Is that normal or has my download fucked up?

Incomplete installation.

Reinstall the mod and then run FNIS again.

Link to comment
  • 2 weeks later...

I tried running the reinstall from NMM and fully reinstalling, but I'm still ahving the same problem of FNIS saying there is no corresponding behavior file no matter how many times i do it.


EDIT: 10th time is the charm. No warnings. I think I started downloading the patch instead of full, so it goes to show you that instructions can only prevent so much stupid.

Link to comment
  • 2 weeks later...

I recently had the same issues with animations not playing when initiated. Sexlab and other mods were all correctly installed and the load order was correct. Two different things worked for me:

1. in one game I completely removed the overwrite - FNIS folder I created for that playthrough (I use MO), re-ran FNIS and created a new one. Success!

2. in my current game (new) all I had to do was open the console and type 'enableplayercontrols'. Don't know why, but it worked.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...