Jump to content

Animations not working...at all.


Recommended Posts

So when i first installed sexlab, everything seemed to work, i got the animations to work twice before it simply stopped functioning, and even when they DID work, they worked only partially, meaning the animation didn't play at first, and then it did, then it stopped again, and then it worked again, and so on and so forth. So i only got a glimpse of the animations, not the whole thing.
 
Basically, what happened is this: Whenever i tried playing an animation (i used the sexlab Zzz spells, and also tried using just sexlab from the MCM) The characters would simply get stiff and stand there in place, facing each other, no animation, no sound, no nothing. I checked the sexlab MCM menu and in the sex journal tab it shows that the game registered the act like it happened, but it didn't.
 
I tried triggering the animations with vanilla, modded and custom followers, and i always got the same result.
 
I quickly went over to the troubleshooting thread and read over what may be the problem, i tried a few methods listed there, but to no avail.
 
I got all the required things for it to work (FNIS, SKSE, SkyUI, all is up to date) I also have XP32 Maximum Skeleton which is highly recommended, although i got it way before acquiring sexlab.
 
I removed Animated Prostitution and Adult Show XXX because they are both script heavy, but even after removing them, nothing changed.

 

Link to comment

Hmm, I am not an expert on Papyrus logs, but from what I can see SL is registering that the animation did in fact happen. So the error of not actually seeing the animations might not be with SL, but another mod. It could be a simple load order issue.

 

But basics first: did you run FNIS at least once after installing any mods that include animations? And did you check that there are no errors reported by FNIS?

 

And/ or: have you tried rebuilding SL in the MCM menu?

 

if you are absolutely sure all these steps are correctly done, can you post your loadorder? maybe that will give a clue about what could be the issue.

 

- V.

Link to comment

I got zero modding experience, so even if the problem in that papyrus log is as obvious as day, i wouldn't be able to see it.

 

Yes, i did run FNIS as I'm no stranger to it, been using quite a few animation mods before so I'm sure i got that bit right.

Anyway, here is my FNIS log: 

 

 

 

Skeleton female: XPMS (242 bones)   male: XPMS (242 bones)

Patch: "SKELETON Arm Fix" 
Patch: * rongphale's "Horsemen Mounted Combat Enh." 
 
Reading ActionPoser V?.? ...
Reading DPoser V?.? ...
Reading FNIS V5.1.1 ...
Reading FNISBase V5.1.1 ...
Reading MomoAJ V?.? ...
Reading PinupPairs V?.? ...
Reading Pinups V?.? ...
Reading Pinups2 V?.? ...
Reading Pinups3 V?.? ...
Reading Pinups4 V?.? ...
Reading Pinups5 V?.? ...
Reading PinupsEX1 V?.? ...
Reading PinupsEX2 V?.? ...
Reading PinupsEX3 V?.? ...
Reading PinupsEX4 V?.? ...
Reading PinupsEX5 V?.? ...
Reading PinupsMen V?.? ...
Reading P_CombatIdles V?.? ...
Reading P_FemaleIdles V?.? ...
Reading P_Pose_And_Animations V?.? ...
Reading SexLab V1.59 ...
Reading SexLabCreature V1.58 ...
Reading SNSD V?.? ...
 
All Anim Lists scanned. Generating Behavior Files....
 
Creature Pack not installed
 
 2302 animations for 23 mods successfully included (character)
 1 Warning(s).
 

 

 

 

NOTE: I did NOT tick the gender specific animations patch in FNIS, only the skeleton one.

 

I fiddled around with SL in the MCM menu and i did all the steps required to rebuild it, sadly there was no change. Perhaps i didn't do it right, but I'm pretty sure i did, i followed the step-by-step procedure and everything thats supposed to happen, happened...except fixing SL.

 

My load order is rather...huge, not sure how i i can fit the load order of 134 mods into one picture.

Link to comment

Okies, your FNIS does show an error. Probably caused by not ticking the gender path.

As far as I know for FNIS to work and register properly, you must tick at least the first two boxes wether you have mods installed that depend on it or not. (will have to look that up).

And of course tick the boxes of other patches as well.

I am not sure if this would cause your problem, but could you run FNIS with the Gender patch as well? as a matter of illimination.

 

I also see that you don't have the FNIS creature pack installed. Again, I am not entirely sure if this would cause problems with regular animations, but the SL creatures part will need this.

 

- V.

Link to comment

If my memory serves me well, i don't need the creature pack if i don't plan to use any creature related anims. I mean, sounds pretty logical.

 

I ran FNIS with both patches ticked and i still get 1 warning at the end, tbh i have been getting that one warning for quite some time now, but i never encountered a problem before so i didn't mind it, every other animation mod i got worked just fine.

 

I tried the animations out as soon as i ran FNIS with the gender patch, but nothing changed.

 

As for my load order, i had to divide it into 4 pics (There was probably an easier way to do this, but oh well...)
 

Check if you find anything that may cause the problem, i was actually thinking of deactivating every mod and starting a completely new game, but I'm afraid it might screw some things up.

post-438510-0-48574300-1410638402_thumb.jpg

post-438510-0-88509900-1410638414_thumb.jpg

post-438510-0-37946000-1410638425_thumb.jpg

post-438510-0-58751100-1410638428_thumb.jpg

Link to comment

Yah, I reread the FNIS descriptions and you don't need the Gender box or FNIS creature. Sorry about that, my memory got muddled (easy thing to do).

 

So ok, I browsed through your load order and, apart from Sexlab Zzz, you have no mods that use the sexlab animations. At least that I recognised. Just keep that in mind, when you get it working again. (You can find a list of Sexlab mods in the SexLab Index post)

 

So next step, try to download another mod that uses Sexlab, i.e. SexLab Matchmaker, disable SexLab Zzz, and see if with the matchmaker spells the animations will show for you.

If that still isn't the case, I will direct you to Ashal's Troubleshooting post. Ashal is the creator of SexLab and the troubleshooting guide lists all manner of possible fixes.

 

I was kinda convinced that you have a FNIS issue since the animations don't play. I still can't exclude the possibility, since you have that one error. Have you checked your data/tools/GenerateFNIS_for_Users/temporary_logs/GenerateFNIS_LogFile.txt to see if the error says which mod might cause the error? If it doesn't say anything, try following Ashal's guide.

 

Sorry that I can't be more help.

Link to comment

The Gender Specific animation box should NOT be ticked. It's used for very specific animations and if you tick it without having any of those animations, things get wonky. The warning that's showing up is due to the FNIS Creature Pack not being installed. It's just a warning and doesn't break anything. Of course if you're using any of the creature mods (SexLab Nude Creatures, More Nasty Critters, etc.) and don't have FNIS Creature Pack installed, these mods won't work.

 

I notice you're using Pinup Poser. Great for screenies. Not so great for gameplay. If I'm going to take screenshots, I enable it, load the game, take the screenies and exit without saving. Then I disable it again before I go back to my gameplay.

 

After removing Animated Prostitution and Adult Show did you start a new game? Or are you running an old save? If you're running an old save, try starting a new game.

 

But before you do anything else, your load order has a few issues that stand out... like Alternate Start - Live Another Live should be at the very end. Download LOOT (http://loot.github.io/) and run it. I also recommend downloading and installing the Unofficial Patches. They fix a lot of issues with the game that can cause problems. You can find the Unofficial Skyrim Patch (USKP) here: http://www.nexusmods.com/skyrim/mods/19/? and you'll find links to the ones for the DLCs on the USKP description page. Every time you install a mod or batch of mods, run LOOT to fix the load order.

Link to comment

If characters stand their stiff or playing their idles instead of playing sex animations it is unquestionably an issue with your FNIS setup and not SexLab. For starters it looks like you have the mounted combat patch checked but skimming your load order you don't even have that mod installed, you have MomoAJ installed but aren't using the FNIS patch for "Momo Acrobatic Jump".
 
If correcting those two mistakes doesn't fix it, then reinstall your FNIS to make sure you're using all it's proper files, ASX, AP, or other animation related mods may have overwritten FNIS's behavior files, leaving a broken FNIS install when they were added/removed; which is something using ModOrganizer instead of NMM helps avoid to begin with. (reason #324 of why people should just stop using NMM and make the switch to MO)
 
If none of the above doesn't help, and you can confirm FNIS is working otherwise testing other animations you've added with it (such as all those poser/pinup mods you have installed) Then follow the troubleshooting guide for doing a complete SexLab save clean (The big list of instructions all in red)

 

Also everything sorsharavenwing said before me: LOOT, Unofficial Patches, disable poser. And I could be wrong but I'll say leaving the gender specific animations patch ticket should be fine, as far as I know it just makes the genders override a default animation with one found in the male/female folder if they exist, if none exist it should be harmless and they'll just select the animation from the gender neutral folder. If you don't have any gender animations installed at all though, than just leave it disabled, in the case of troubleshooting like this and you don't have any it should absolutely be disabled.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...