Jump to content
IGNORED

Crash Fixes: CustomMemoryBlockTotalSizeMB=?


Recommended Posts

What am i supposed to use in that setting on crash fixes ini? I enabled the custommemoryblock but all my blocks in game console ~ show 100%. I kinda want to reduce it as much as i can. I went as far as to set it to 80 but it still shows 100% in all memory blocks

 

Edit: The reason im looking into that setting is due to the fact that while running JK's Skyrim, while the fps is bearable, im getting MASSIVE framedrops when turning the camera which doesnt happen when not using it.

By fps falls i mean literal mini freezes

Link to comment
3 hours ago, killer8217 said:

What am i supposed to use in that setting on crash fixes ini? I enabled the custommemoryblock but all my blocks in game console ~ show 100%. I kinda want to reduce it as much as i can. I went as far as to set it to 80 but it still shows 100% in all memory blocks

 

Edit: The reason im looking into that setting is due to the fact that while running JK's Skyrim, while the fps is bearable, im getting MASSIVE framedrops when turning the camera which doesnt happen when not using it.

By fps falls i mean literal mini freezes

Quote

CustomMemoryBlock=1


CustomMemoryBlockTotalSizeMb=256


MemoryInfoConsole=0

You must put CustomMemoryBlock=1 because the parameter CustomMemoryBlockTotalSizeMb=256 is used only when CustomMemoryBlock=1

 

Read the coments: Has no effect if CustomMemoryBlock is not enabled.

 

Aditionally, i really doubth that parameter can help when you rotate the camera.

The memory managed by OsAllocators is requested before you enter the cell.

If you have stutering, or freezes or lag when rotate the camera can be a problem in ENB configuration.

Revise the parameter ReservedMemorySizeMb=256 inside enblocal.ini and up it in increments of 128.

Take a look to the ENB documentation in the STEP guide.

 

If the problems persist can be a problem in the load order

Or maybe your machine not support that mods.

Link to comment
2 hours ago, GenioMaestro said:

You must put CustomMemoryBlock=1 because the parameter CustomMemoryBlockTotalSizeMb=256 is used only when CustomMemoryBlock=1

 

Read the coments: Has no effect if CustomMemoryBlock is not enabled.

 

Aditionally, i really doubth that parameter can help when you rotate the camera.

The memory managed by OsAllocators is requested before you enter the cell.

If you have stutering, or freezes or lag when rotate the camera can be a problem in ENB configuration.

Revise the parameter ReservedMemorySizeMb=256 inside enblocal.ini and up it in increments of 128.

Take a look to the ENB documentation in the STEP guide.

 

If the problems persist can be a problem in the load order

Or maybe your machine not support that mods.

Would these be way too much for my GTX 960 4GB and the i7 2600 3.9?

Used the DX9 tool to get the proper value for the VideoMemorySizeMb but im having a really hard time figuring out the proper Reserved Memory Size

 

[MEMORY]
ExpandSystemMemoryX64=false
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=640
VideoMemorySizeMb=11842
EnableCompression=false
AutodetectVideoMemorySize=false

Link to comment
4 hours ago, killer8217 said:

Would these be way too much for my GTX 960 4GB and the i7 2600 3.9?

Your ENB parameters are correct.

I think your i7 is enougth to run Skyrim with your GTX 960 but take a look to your CPU ussage.  Skyrim is multi-thread but use DirectX 9 that is mono-thread. If in any moment one of the cores get 100% can be the core that manage the DirectX and can be the cause of the problems.

 

But I think you are requesting too much from your GTX. I recomend you monitor your videocard, for example with GpuZ, and see memory ussage and GPU ussage. If your GPU ussage is 100% or the Vram is totally filled you go to have stuttering and microfreezes.

Link to comment
9 hours ago, GenioMaestro said:

Your ENB parameters are correct.

I think your i7 is enougth to run Skyrim with your GTX 960 but take a look to your CPU ussage.  Skyrim is multi-thread but use DirectX 9 that is mono-thread. If in any moment one of the cores get 100% can be the core that manage the DirectX and can be the cause of the problems.

 

But I think you are requesting too much from your GTX. I recomend you monitor your videocard, for example with GpuZ, and see memory ussage and GPU ussage. If your GPU ussage is 100% or the Vram is totally filled you go to have stuttering and microfreezes.

Yup its almost always at 99%. Rarely dips now that i increased the ReservedMemory thingy.

 

This is random and a completely diferent subject but it might be stupid of me to make a whole support thread for this.

How come my vanilla start is not working at all?

Like i chose to go vanilla start on alternate life and the horse was literally missing.

I thought it was Helgen Reborn but i removed it and the horse was still nowhere to be seen.

The guys are in the cart. The cart is NOT moving at all.

They all talk normally too. Lol

Link to comment
2 hours ago, killer8217 said:

Yup its almost always at 99%. Rarely dips now that i increased the ReservedMemory thingy.

That is not recomend. Must be maximun 90% with average from 50% to 80% but depend of the game.

If you always have your GPU in 100% the stuttering and microfreezes are practically guaranticed.

If your GPU not have a single nanosecond free any thing that you make, like move the camera or change cell, can cause stuttering and microfreezes. 

 

The CPU, the GPU, the RAM and the Vram must have, at least, a small part free. If one component is saturated the problems are guaratized. If you can live whit it, good. If not search the cause and solve it.

 

2 hours ago, killer8217 said:

How come my vanilla start is not working at all?

Like i chose to go vanilla start on alternate life and the horse was literally missing.

That is a common problem caused by the physics of the game. Some player say that the vanilla start is very bugged and can not be used. But that is not true today. The exact problem is caused by some specific mods that change the physics of the game.

 

In my case is caused by the combination of BakaFactory Animated Beast Cocks + Beast HDT + Naturalistic XMLs for HDT. With that mods enabled my vanilla start, launched from the Alternate Start cell, is bugged as hell and the camera move in a weird way, the horse walk in a straigth line and collide with the trees.

Disabling that mods my vanilla start works but in your case can be caused by others mods.

The problem is not severe and we preffer skip the vanilla intro to have the game with all our physics mods.

Link to comment
1 hour ago, GenioMaestro said:

That is not recomend. Must be maximun 90% with average from 50% to 80% but depend of the game.

If you always have your GPU in 100% the stuttering and microfreezes are practically guaranticed.

If your GPU not have a single nanosecond free any thing that you make, like move the camera or change cell, can cause stuttering and microfreezes. 

 

The CPU, the GPU, the RAM and the Vram must have, at least, a small part free. If one component is saturated the problems are guaratized. If you can live whit it, good. If not search the cause and solve it.

 

That is a common problem caused by the physics of the game. Some player say that the vanilla start is very bugged and can not be used. But that is not true today. The exact problem is caused by some specific mods that change the physics of the game.

 

In my case is caused by the combination of BakaFactory Animated Beast Cocks + Beast HDT + Naturalistic XMLs for HDT. With that mods enabled my vanilla start, launched from the Alternate Start cell, is bugged as hell and the camera move in a weird way, the horse walk in a straigth line and collide with the trees.

Disabling that mods my vanilla start works but in your case can be caused by others mods.

The problem is not severe and we preffer skip the vanilla intro to have the game with all our physics mods.

My GPU is always running 99% no matter the game. Its most likelly due to the long years of overclocking.

Saddly i cannot afford an upgrade anytime soon and even if i do i will be going for the RTX 2060 at most

 

Also thanks for the reply on the vanilla start part. I honestly dont mind it at all i was just wandering why that was happening

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...