Jump to content

Windhelm problem: Blood on the Ice quest

Recommended Posts

The abovementioned quest is supposed to be one part of being able to buy a house in Windhelm, having done enough quests for residents of the city is the other. I have been told I am now able to buy a house but when speaking to the steward they say its involved in some "unpleasant business" and will not let me buy it yet. I cannot get Blood on the Ice to start though. I did not side with the Imperials for the civil war quest line, I have entered the trigger area during the times mentioned in the UESP wiki entry on the quest, I have tried startquest MS11 (quest number listed for it), done addtopic with entries related to the quest to progress it, setstage MS11 with stages from 1 all the way to 30, and nothing has worked. I have also unlocked the door and gone into Hjerim (house for sale, unable to buy until BotI is complete) and found the journals inside and taken them to Viola. Didn't work either. Does anyone know how to fix this so I can buy the f^%^ing house? To help out, there are no bloodstains, no body, and no guard where the body would be. The steward does not have the dialog option to investigate the murders either, and the addtopic command didn't add it either.

Link to comment

That quest is bugged in many places, that includes the trigger, the murderer's apprehension, and a few other parts. I personally didn't glitch it untill the end where you have to chase the murdere down at his/her hideout, waited a bit then patched the game (to 1.5 I think) and all was fixed, even the faulty quest trigger. So if you try the above mentioned ways to trigger the quest, it might be because it is glitched, try patching the game.


Hope this helps!

Link to comment

I completed that quest, but could not buy the home. There was no dialogue options from the steward to buy property.


When I first went to Windhelm I was searching for the merchant shops. I did the Cracked Phial quest and left Windhelm to explore around. When I returned to sell some things I accumulated I passed by the cemetary and noticed the crime scene (it was not there while I was doing the Phial quest). So something I did triggered it or it just happened to glitch. Also I didn't take sides with the Civil War and I didn't help anyone else except game some money to the beggar woman who also trained me in pickpocketing.


With the latest patch I'll give this quest another try.

Link to comment

I have patched it to 1.5 before I even started the character this occurred on. Did the phial quest too. From the UESP entry on it, you need to enter Windhelm between 7pm and 7am and have caused the Windhelm cell to be called 4 times (entering it, passing close enough to it, etc...) before this quest will start. Been in and out of Windhelm 31 times, and even did a setgamehour to 0, left the cell, then re-entered to try and get it to start. Nada. Still no body, no guard, no bloodstains, and the priest wanders everywhere in town with no dialog about the murders. Women in the tavern? Which one? Candlehearth Hall or New Gnisis Cornerclub? Only the bartender in the Cornerclub mentioned anything about murders and it did not initiate the quest or enable dialog options in others. I am about to say fark it and dissect the bastard in the CK to see if I can spawn the references to force it to start....


EDIT: Yes, I am fairly thorough when it comes to troubleshooting things. Thanks for all the suggestions so far. Greg, I'll try your first suggestion as its the only one I can do. Guards do not have a dialog menu for me yet, just the random messages unless of course I get confronted about a crime...

Link to comment

For me it triggered when I talked to some of the women in the evening in Candlehearth hall. It was not one of the workers but rather a citizen who had stopped in for a drink. Then I went to the Jarl's steward and asked him about it and he sent me to the grave where I talked to the priestess and then went from there.


Yea that quest is pretty buggy so if it drives you to distraction just use the console codes to advance the quest.

Link to comment
Guest Lady Luck

this is how you solved windhelm bug "minor spoiler"


if you take side with ulfric


- this will trigger "stormcloak quest" which they need you to kill ice

wraith and then ulfric will mentioned " i let you buy the house"


- When you go to hjerim which "Windhelm player's house" you stumble upon a note or a poster saying " the butcher"


- Talk to voila " she will talk about crazy old coot practicing some experiment or something.


- and then go to windhelm steward ask him about the butcher journal

he will find the culprit


- after the scene ends press t to wait 1 hour for npc to restart

their ai , " talk with him again and he will let you buy hjerim"



if ulfric dies on imperial quest


- Talk to the new jarl " you will automatically have hjerim deed,

and he ask you to talk with the stewart"


- when you arrived hjerim it's same step as the butcher quest

clear out the quest


- do same step again wait for 1 hour and then talk to stewart

decorate your home etc..




let's recap


1. this quest isn't a bugged it's just confusing

2. if ulfric dies , you can still buy the house and can still be


3. if ulfric survive you need to complete stormcloak Initiation

quest after all that done you can buy the house afterwards

4. hjerim is not yours yet, you need to complete " the butcher"

quest find this girl "viola" and she give you the quest

5. after the culprit captured, hjerim will be yours you can

decorate it later.


i know i don't explain it very well but it's pretty self explanatory how to fix this bug , this quest isn't bugged it's just very confusing so i compile solution so you don't have to wonder in limbo trying to find solution.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...