Jump to content

Super glossy meshes (HELP)


BenChang

Recommended Posts

Can someone please explain what is going wrong here

 


 


 

I've tried adding normal maps, I've tried changing bsshader tags, I've tried everything, but the rhydon is still glossy as all hell. 

 

I've been referencing (and thus copying over) vanilla animobj bsshader property nodes in nifskope for hours now. The Rhydon is still glossy as all hell. It is getting very exhausting trying and failing and trying and failing and I really have no idea what the hell is going wrong

 

(Also it's for personal use, I'm really tired so please don't come in here and wail on me for imagined copyright infractions)

Link to comment

Maybe it has something to do with the ..._s.dds texture file? 

 

Already tried:

 

With _s.dds file

Without _s.dds file

 

It's glossy af regardless of whether there is a specular map or not. The map is in the correct nifskope slot for sure (second last). Besides, most vanilla animobj meshes don't even have a specular map assigned to them, which indicates that a _s.dds specular map doesn't have to play a part in the extreme glossiness at all.

 

I've also tried the glossiness setting, and specular colors amongst other settings. Nothing seems to be changing the extreme glossiness demonstrated

Link to comment

Looks like an environment map issue for me.

 

Go to BSLightingShaderProperties for the mesh, under Environment Map Scale, set it to something low like 0.1 and see what happens.

 

You can also remove the environment  map texture altogether if you don't need it, it's the 5th entry under BSShaderTextureSet

Link to comment

Load up the nif and click the item and go to BSLightingShaderProperty and look at what the glossiness float is set at. 

 

 

 

It was set to 30, I set it to 20/40 and saw absolutely no difference whatsoever.

 

Looks like an environment map issue for me.

 

Go to BSLightingShaderProperties for the mesh, under Environment Map Scale, set it to something low like 0.1 and see what happens.

 

You can also remove the environment  map texture altogether if you don't need it, it's the 5th entry under BSShaderTextureSet

Environment map scale, or UV scale? I'm not too sure where that is

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...