Jump to content

FNIS is evil, CTD on startup


CJCon

Recommended Posts

Hello~! I'm really sorry for the trouble, but I was wondering if anyone could help me figure out what's going on.

 

I realized that none of my animation mods were working because, while I did have Fores New Idles,

I had forgotten to run the GenerateFNISforUsers.exe that comes with it- so nothing was actually changing.

 

However when I finally did run that exe, my game consistently CTDs on startup now- before I even get to the main menu.

It was working completely fine before (other than the animation mods that were doing nothing) but right after I ran

that GenerateFNISforUsers.exe, it wouldn't run anymore. The program didn't give me any errors either.

 

I can normally figure out why I'm CTDing between LOOT messages and TES5Edit,

but I'm getting no errors from either of them.

 

I've tried deleting FNIS but I still CTD, and reinstalling it didn't help either.

 

Here's my Modwat.ch link for the load-order and list of mods.

And this is what my Papyrus log looks like, although it's really short:

 

 

[02/12/2015 - 07:13:20PM] Papyrus log opened (PC)
[02/12/2015 - 07:13:20PM] error: Native function GetUseSound in empty state does not match existing signature on linked type Potion. Function will not be bound.
[02/12/2015 - 07:13:21PM] Update budget: 1.200000ms (Extra tasklet budget: 1.200000ms, Load screen budget: 500.000000ms)
[02/12/2015 - 07:13:21PM] Memory page: 128 (min) 512 (max) 76800 (max total)
[02/12/2015 - 07:14:17PM] Cannot open store for class "_CW_Potions_0weight_Quest_Script", missing file?
[02/12/2015 - 07:14:17PM] Error: Unable to bind script _CW_Potions_0weight_Quest_Script to _CW_Potions_0weight_Quest (360012D2) because their base types do not match
[02/12/2015 - 07:14:17PM] Cannot open store for class "_arissa_inpc_behavior", missing file?
[02/12/2015 - 07:14:17PM] Cannot open store for class "chherdingquestscript", missing file?
[02/12/2015 - 07:14:23PM] Cannot open store for class "GoScript", missing file?
[02/12/2015 - 07:14:23PM] Cannot open store for class "ReturnScript", missing file?
[02/12/2015 - 07:14:23PM] Error: Unable to bind script jaxonzstringutil to JaxonzDiagnosticsQuest (5D000800) because their base types do not match
[02/12/2015 - 07:14:23PM] Error: Unable to bind script jaxonzdiagnostics to JaxonzDiagnosticsQuest (5D000800) because their base types do not match
[02/12/2015 - 07:14:23PM] Error: Unable to bind script JaxonzConsolePlugIn to JaxonzDiagnosticsQuest (5D000800) because their base types do not match
[02/12/2015 - 07:14:23PM] Error: Unable to bind script jaxonzstringutil to JaxonzNamedSaveQuest (60000D62) because their base types do not match
[02/12/2015 - 07:14:23PM] Error: Unable to bind script JaxonzDateTimeUtil to JaxonzNamedSaveQuest (60000D62) because their base types do not match
[02/12/2015 - 07:14:25PM] Cannot open store for class "KRY_QD_PlayerAliasScript", missing file?
[02/12/2015 - 07:14:25PM] Cannot open store for class "AAFlyStorm", missing file?
[02/12/2015 - 07:14:38PM] Cannot open store for class "QF__01064481", missing file?
[02/12/2015 - 07:14:38PM] Error: Unable to bind script QF__01064481 to LTDDragonTest09 (A7064481) because their base types do not match
[02/12/2015 - 07:14:39PM] Cannot open store for class "ChargeLH", missing file?
[02/12/2015 - 07:14:39PM] Cannot open store for class "ChargeLHConc", missing file?
[02/12/2015 - 07:14:39PM] Cannot open store for class "TestWeaponCharge", missing file?
[02/12/2015 - 07:14:39PM] Cannot open store for class "Charge2HWeaponConc", missing file?
[02/12/2015 - 07:14:41PM] Cannot open store for class "QF_DavjesQuest_02017F3F", missing file?
[02/12/2015 - 07:14:41PM] Error: Unable to bind script QF_DavjesQuest_02017F3F to DavjesQuest (DB017F3F) because their base types do not match

 

 

Thank you to anyone who takes a look!

I've tried to figure it out for a few hours now but I really don't know what else to do. >-<

Link to comment

Ahh I do already have XP32 Maximum Skeleton.

 

Also sorry xD I didn't think of that! Good idea though:

 

FNIS Behavior V5.2   2/12/2015 8:32:21 PM
Skyrim: 1.9.32.0 - E:\Programs\Steam\steamapps\common\Skyrim\ (Steam)
 
Skeleton female: XPMS2 (115 bones)   male: XPMS2 (115 bones)
Patch: "SKELETON Arm Fix" 
 
Reading FNIS V5.2 ...
Reading FNISBase V5.2 ...
Reading P1FlyingRing V?.? ...
Reading P_CombatIdles V?.? ...
Reading P_FemaleIdles V?.? ...
Reading P_Pose_And_Animations V?.? ...
 
All Anim Lists scanned. Generating Behavior Files ...
 
Creature Pack not installed
 
 262 animations for 6 mods successfully included (character)
 
 0 possible consistence issues

 

Link to comment

Maybe u need to install all 3 Fnis files? -creatures, spells and the patcher.

 

Or:

1.Copy your profile in MO and activate it.

2.Disable half of your esps from the bottom up.

3.Start the game through SKSE

4.if still ctd, disable another half of esps.

5.if no ctd, enable half of the disabled esps.

6.and so on until u find the bad esp and disable or fix it, remember there may be more than one bad esp.

Link to comment

Hello~! I'm really sorry for the trouble, but I was wondering if anyone could help me figure out what's going on.

 

I realized that none of my animation mods were working because, while I did have Fores New Idles,

I had forgotten to run the GenerateFNISforUsers.exe that comes with it- so nothing was actually changing.

 

However when I finally did run that exe, my game consistently CTDs on startup now- before I even get to the main menu.

It was working completely fine before (other than the animation mods that were doing nothing) but right after I ran

that GenerateFNISforUsers.exe, it wouldn't run anymore. The program didn't give me any errors either.

 

I can normally figure out why I'm CTDing between LOOT messages and TES5Edit,

but I'm getting no errors from either of them.

 

I've tried deleting FNIS but I still CTD, and reinstalling it didn't help either.

 

Here's my Modwat.ch link for the load-order and list of mods.

And this is what my Papyrus log looks like, although it's really short:

 

 

[02/12/2015 - 07:13:20PM] Papyrus log opened (PC)

[02/12/2015 - 07:13:20PM] error: Native function GetUseSound in empty state does not match existing signature on linked type Potion. Function will not be bound.

[02/12/2015 - 07:13:21PM] Update budget: 1.200000ms (Extra tasklet budget: 1.200000ms, Load screen budget: 500.000000ms)

[02/12/2015 - 07:13:21PM] Memory page: 128 (min) 512 (max) 76800 (max total)

[02/12/2015 - 07:14:17PM] Cannot open store for class "_CW_Potions_0weight_Quest_Script", missing file?

[02/12/2015 - 07:14:17PM] Error: Unable to bind script _CW_Potions_0weight_Quest_Script to _CW_Potions_0weight_Quest (360012D2) because their base types do not match

[02/12/2015 - 07:14:17PM] Cannot open store for class "_arissa_inpc_behavior", missing file?

[02/12/2015 - 07:14:17PM] Cannot open store for class "chherdingquestscript", missing file?

[02/12/2015 - 07:14:23PM] Cannot open store for class "GoScript", missing file?

[02/12/2015 - 07:14:23PM] Cannot open store for class "ReturnScript", missing file?

[02/12/2015 - 07:14:23PM] Error: Unable to bind script jaxonzstringutil to JaxonzDiagnosticsQuest (5D000800) because their base types do not match

[02/12/2015 - 07:14:23PM] Error: Unable to bind script jaxonzdiagnostics to JaxonzDiagnosticsQuest (5D000800) because their base types do not match

[02/12/2015 - 07:14:23PM] Error: Unable to bind script JaxonzConsolePlugIn to JaxonzDiagnosticsQuest (5D000800) because their base types do not match

[02/12/2015 - 07:14:23PM] Error: Unable to bind script jaxonzstringutil to JaxonzNamedSaveQuest (60000D62) because their base types do not match

[02/12/2015 - 07:14:23PM] Error: Unable to bind script JaxonzDateTimeUtil to JaxonzNamedSaveQuest (60000D62) because their base types do not match

[02/12/2015 - 07:14:25PM] Cannot open store for class "KRY_QD_PlayerAliasScript", missing file?

[02/12/2015 - 07:14:25PM] Cannot open store for class "AAFlyStorm", missing file?

[02/12/2015 - 07:14:38PM] Cannot open store for class "QF__01064481", missing file?

[02/12/2015 - 07:14:38PM] Error: Unable to bind script QF__01064481 to LTDDragonTest09 (A7064481) because their base types do not match

[02/12/2015 - 07:14:39PM] Cannot open store for class "ChargeLH", missing file?

[02/12/2015 - 07:14:39PM] Cannot open store for class "ChargeLHConc", missing file?

[02/12/2015 - 07:14:39PM] Cannot open store for class "TestWeaponCharge", missing file?

[02/12/2015 - 07:14:39PM] Cannot open store for class "Charge2HWeaponConc", missing file?

[02/12/2015 - 07:14:41PM] Cannot open store for class "QF_DavjesQuest_02017F3F", missing file?

[02/12/2015 - 07:14:41PM] Error: Unable to bind script QF_DavjesQuest_02017F3F to DavjesQuest (DB017F3F) because their base types do not match

 

 

 

Thank you to anyone who takes a look!

I've tried to figure it out for a few hours now but I really don't know what else to do. >-<

 

Step 1: Run Loot

Step 2: Look at your modlist in Mod Organizer for items with a red triangle.

 

You are missing a master to some ESP.

 

FNIS won't make you crash on startup, since it 100% only messes with animations. Even if incorrectly updating your HKX files it'll just make all the npcs/models have no movement animations.

Link to comment
 

Maybe u need to install all 3 Fnis files? -creatures, spells and the patcher.

I didn't think so- it said that they were optional.

In any case, I installed them as well and it doesn't seem to have helped.

 

Step 1: Run Loot

Step 2: Look at your modlist in Mod Organizer for items with a red triangle.

 

You are missing a master to some ESP.

 

FNIS won't make you crash on startup, since it 100% only messes with animations. Even if incorrectly updating your HKX files it'll just make all the npcs/models have no movement animations.

I mentioned that I've run both LOOT and TES5Edit. They would normally point out if I was missing a master or if my esps were out of order.

But there's no errors from either of them.

 

Everything was alright until I ran that exe file, so I assumed that FNIS was what was making it crash.

I understand why that shouldn't be the problem, but I'm not sure what else is going on then.

That was my only lead >-<

 

For the record, I'm using Nexus Mod Manager to organize my mods- not MO.

 

Try moving your CharacterMakingExtender.esp as close to the bottom of your load order as you can. I run Alternate Start which is at the bottom and CharacterMakingExtender.esp just above it. I've had CTD's with it anywhere else in my LO. It usually tells you to give it priority which means moving it closer to the bottom of your LO. That was the only thing I noticed from your Load Order.

Moved it all the way to the bottom! Doesn't seem to have fixed it though <=o

Link to comment

i would also try wyre bash.   it is really good at finding items that are missing masters (and will tell you what masters are missing!) and I find it more reliable at that then loot, boss or any of the other programs.   About all I use it for but its nice to have around.

 

i would also try to uninstall then re-install your skeleton.   It gets overwritten at times and if you have a naked body in the zone you are loading at start it may ctd.

Link to comment

Something to keep in mind when modding Skyrim CJCon is that LOOT is not god. Even though it establishes a stable baseline 90% for example, there's still 10% room for error(i'm obviously just throwing out example figures). Anyways I have had problems with BOSS and LOOT being imperfect from day one. You realize that basically the only way to truly establish a stable LO is through trial and error by using Wrye Bash to determine your mod dependencies and if need be TESEdit to create a patch . My suggestion is if you're not using MO then I suggest you start by uninstalling the game(only if you're not using MO) and re-install the game. Install MO directly into the Skyrim directory and place your mods into it's download folder. Then install each mod one at a time until you find the trouble mod. I only suggest this if you are unable to troubleshoot your problem. FNIS doesn't cause the issues you're describing as it has already been said by Aydoo. Really MO is your best friend and is the only way to achieve a stable heavily modded Skyrim generally speaking(and with greater ease). I'm not an MO fanboi or w/e they call people who advocate its use but I've been through the headache of using NMM for select games. I used to use NMM for dragon age and such which is no problem.

 

However for games like the TES series where the number of mods that can be used and the sheer volume of mods that exist is staggering. A system like NMM is just simply obsolete. If you screw up, having to bloody well re-install the game every time one mod doesn't behave like it's supposed is insane. It could be due to a conflict and you don't know; that mod might have a zillion small files that you would have to manually remove and what if they were files that overwrote other files that were detrimental to the stability of another mod and inevitably the game itself. However if you use MO none of these problems exist because all you have to do is just organize your sub-folders, re-establish your overwrite and enable/disable each mod to troubleshoot. It's that easy. In this case, if FNIS was truly the problem all you would have to do is disable your FNIS subfolder installation and re-establish your overwrite. Then reboot the game to test if it caused the crash. I think you would find that it wouldn't be the cause and so what you would do is just sort your mod folder installation window by the date it was installed. Then you just find the most recent mods installed and start systematically disabling them and any dependencies they have using Wrye Bash. 

 

I hope this helps you troubleshoot your issue. In addition to my advice judging by the log you posted I would say your problem is you probably disabled a quest mod or some sort of multiple content mod or you disabled it's dependencies by accident(more than likely this). With MO you can just right click on your plugin list and click enable all. After that run Wrye Bash through MO to diagnose.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...