Jump to content

NV ESM help - changing/setting master flag, converting to ESP


Recommended Posts

Hi - pretty much like the title says, I have an .esm I'd like to convert to an .esp for reasons. I've tried using FOMM to save the file as an .esp, and while it does do that it doesn't change the header, so it's still flagged as an .esm which doesn't really solve the problem.

 

Is there a way to manually edit the header? I've tried using FOMM and FNVEdit but haven't been able to figure it out, and Google has not been my friend on this one. Any help/links greatly appreciated, thanks in advance!

Link to comment

Either that, or just open up the file you want to edit in FNVEdit, go to the file header and remove the part that says "esm" under record flags. Close FNVEdit, save and rename the file extension to *.esp.

This is exactly what I had in mind, the only problem is it didn't f'n work - the File Header section in FNVEdit for every damn mod was gloriously blank.

 

Apparently, FNVEdit has this really awesome feature where, in the right-hand viewing pane, you have to select the "View" tab on the bottom, then right-click in the pane itself and deselect "Hide no conflict rows" in order to actually see the header information, much less change it.

 

It's amazing how tiny little issues like that can be so disproportionally frustrating. Anyway, thanks for the help BW, and if anyone else ever has this same problem I hope this bit of trivia helps square them away...

 

Link to comment

You do realize this option HAS to be selected by the user first to generate the "issue" ?

 

From the Tutorial for FO3Edit/FNVEdit: A Comprehensive Tutorial on Mod Management:

 

"The records to be cleaned will be shown in the View Tab, though at first you won‟t see anything in the view.

This is because the default setting for the View Tab is the, “Hide no conflict rows”, which means any rows that don't have a conflict are normally not shown (as they play no role in conflict resolution, they are not conflicted!)."

 

But really, thanks for being a constructive part of the team - you're as helpful as you are accurate...

Link to comment

This is false. The default value is to not hide those.

Well, both the reality of the situation (the fact this setting being enabled by default hid header information I wished to edit, thus prompting my original request for help) and the utility's own documentation suggest otherwise. Fortunately, I was able solve my issue while you, on the other hand, seem unable to move on with life. I sincerely hope one day soon you can accept the mind shattering idea that people will often have experiences that differ from your own. Yes, I do realize that's a tough pill to swallow, but I believe in you, jaam...

Link to comment
Guest
This topic is now closed to further replies.
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...