Jump to content

Texture issue in Proudspire Manor (general question)


ButchDiavolo

Recommended Posts

Hi guys (and gals),

 

I am using a remodel mod for Proudspire (Proudspire Remodeled), which is an amazing remodel. I have been using it for ages, but suddenly a few days ago I have started getting problems with textures disappearing. I haven't added or removed any mods in a while.

The mod adds a remodeled, wider staircase and in this staircase at certain points, the next room completely disappears. I have attached a pic of it so you can seen what I mean. This happens in the basement, first floor and second floor, all in the staircase.

 

I would like to know: what causes this and is there a way to correct it? I checked on the mod page and did all the "troubleshooting" provided. There have been other mentions of the same issue, but the mod creator doesn't (seem to) know what causes it or how it can be fixed. So of course I thought of the talented and wise community here. I hope someone can offer some insight.

 

Thanks in advance as always.

 

post-487896-0-36718300-1412730200_thumb.jpg

Link to comment

That's weird... I use that mod, and it never happened to me.

It looks like it's more than just the texture that's missing... the mesh itself. If it was the texture missing, you would see a vivid purple to match Supercow's outfit.

Can you walk through where the wall is supposed to be?

 

EDIT: You said this started just a few days ago. Add any mods around that time?

Link to comment

Nope, I didn't add or remove any mods, nor did I move anything in the load order. It just started happening.

 

The thing is, if I take a few more steps in the direction of the "void", everything snaps back into view. So I can't walk through walls or anything. Since you use the mod as well, it happens mainly on the stairwell at the bottom of the stairs, one or two steps towards the living room. It also happens in the basement, again around the same area. It is very weird. I have never experienced something like it before.

Link to comment

This is a portal/room marker problem.
Most of the time caused by mods that edit the affected cell or by accidental edits which can't be cleaned up automaticly by TES5Edit as those accidental edits are not iTM.

 

if it did happen out of nowhere, than that's really unusual and maybe caused by an ini edit, driver issue or the used ENB (if present).

Link to comment

This is a portal/room marker problem.

Most of the time caused by mods that edit the affected cell or by accidental edits which can't be cleaned up automaticly by TES5Edit as those accidental edits are not iTM.

 

if it did happen out of nowhere, than that's really unusual and maybe caused by an ini edit, driver issue or the used ENB (if present).

 

Ah! now that you mention it... I did update my graphic driver right before it started happening! Do you have an idea of how I can solve it? Reinstall the driver or go back to the old version or something?

 

Link to comment

I have learned an important lesson in my life - don't update drivers unless there is a reason to do so. Half the time it breaks something.

 

EDIT: This happens to me all the time in Riften prison (in addition to other problems there). Are there any mods out there that fix it?

Link to comment

That is not what the Riften Jailer told me...

 

But anyway, I reinstalled the old graphic driver, checked my ini-files and ENB and... still get the nasty "void". It doesn't appear to alter anything in the workings of the mod/house, so I guess I will have to live with it for now. Maybe it will sort itself out *crosses teats*

Link to comment

I've never seen that in Proudspire Manor, but I saw it in Riften Jail, as Content Consumer did, and also in Bleak Falls Barrow. I *think* some of my early misadventures with the CK were to blame (my experienced CK misadventures now destroy stuff on a much subtler level), but I can't prove it and this was many many months ago. IIRC, everything was back to normal after deleting those experimental mods and/or reinstalling Skyrim). How's that for helpful? :P

Link to comment

As Vachnic said, it is an issue with a portal/room marker, likely when the staircase was changed it went outside of the room marker. I bet it appears if you walk into the void area, if so then that is definitely the cause. A lot of people have no idea about them or what they do since they are disabled in the render window by default so they never see them. I ran into the same issues setting them up in Captured Dreams in some of the new spaces, if even part of the model is outside of it then it may not render.

Link to comment

As Vachnic said, it is an issue with a portal/room marker, likely when the staircase was changed it went outside of the room marker. I bet it appears if you walk into the void area, if so then that is definitely the cause. A lot of people have no idea about them or what they do since they are disabled in the render window by default so they never see them. I ran into the same issues setting them up in Captured Dreams in some of the new spaces, if even part of the model is outside of it then it may not render.

You must have fixed them then, I didn't see anything like that in any of the CDX cells.

 

How do you fix them? I can't find a setting to turn on markers in the CK...? I'd like to fix the Riften Jail...

 

EDIT: Is it "validate room/portal alignment" ?

Link to comment

 

As Vachnic said, it is an issue with a portal/room marker, likely when the staircase was changed it went outside of the room marker. I bet it appears if you walk into the void area, if so then that is definitely the cause. A lot of people have no idea about them or what they do since they are disabled in the render window by default so they never see them. I ran into the same issues setting them up in Captured Dreams in some of the new spaces, if even part of the model is outside of it then it may not render.

You must have fixed them then, I didn't see anything like that in any of the CDX cells.

 

How do you fix them? I can't find a setting to turn on markers in the CK...? I'd like to fix the Riften Jail...

 

EDIT: Is it "validate room/portal alignment" ?

 

 

Yes, that is one of the reasons it took so long to make those interiors.

 

The first thing you have to do is to have the CK show them, in the Toolbar click on view and the option you want is Show/Hide Window. In the window that opens you want to check Portals and Rooms, once you do you will see blue boxes show up surrounding different parts of things. You will have to expand the boxes to cover any parts that are not in the boxes, hit the 2 key and click on one of the boxes that needs adjusting, you will see an axis show up, click and drag on the directions that need extended. On boxes that come together they need to meet but not overlap each other. The portals between rooms should be ok and not need fixing.

 

If you are wondering what they do they allow you to only render certain areas at a time. Even though you can't see an area it is still checked by the GPU to see if it can be seen, basically it renders from the farthest thing to the closest. With rooms it will only look at what is in that box or ones joined directly to it. Room Portals are used to make a "window" into an adjacent room so you can see into it. I used it on both the VIP house and Manor house to break up the interiors since they are so large.

Link to comment

@ Veladarius

 

But how could something like that just happen out of the blue? Vachnic said it just started a short time ago after using that mod for a while, and he didn't add new mods that could cause an issue? I'm not disagreeing with your diagnosis - but is it just a Skyrim thing that stuff like this just stops working for no apparent reason?

Link to comment

@ Veladarius

 

But how could something like that just happen out of the blue? Vachnic said it just started a short time ago after using that mod for a while, and he didn't add new mods that could cause an issue? I'm not disagreeing with your diagnosis - but is it just a Skyrim thing that stuff like this just stops working for no apparent reason?

Well, as a matter of fact... :)

Link to comment

@ Veladarius

 

But how could something like that just happen out of the blue? Vachnic said it just started a short time ago after using that mod for a while, and he didn't add new mods that could cause an issue? I'm not disagreeing with your diagnosis - but is it just a Skyrim thing that stuff like this just stops working for no apparent reason?

I'm sort of curious about this myself. I could understand if it was a driver thing since the cow downloaded a new driver, but if it's something internal to the game, that would take a mod alteration.

 

But yes, Skyrim it seems will often break things for no apparent reason. I've given up trying to understand it, shit just happens.

Link to comment

In some of the places it did it on me it did not happen all the time. The only other thing I can think of is that something happened to the portal between rooms but that is unlikely as it isn't something that you can really do anything with in the CK other than place it. The rooms and room portals are the only thing that I have seen that will cause an item like that to disappear but reappear if you walk past a certain point (where you enter the other room box). It may also be that another mod changed the interior slightly and reset the room box.

 

This is one of the things I had happen to me:

 

post-101267-0-60589500-1412770563_thumb.jpg

 

I was using 2 different room boxes, one for the upper floor and one for the lower but the pieces of the outer walls go from basement floor to the top of the ceiling. It didn't disappear all the time, just from certain angles which confused me for a while, once I figured it out I removed the room boxes since I couldn't get the wall parts into the entire box.

Link to comment

Working with room markers and portals is rather tedious and if one marker is to close to each other you get to see the same on the edge of the screen in specific angles. Hence why most people don't work with them, so i'm really happy that Veladarius is and by this i'm not the only one getting more gray hair from room marker/portal based graphic glitches.. ^^

 

So if the issue is not caused externaly (driver settings included, like AA and such), then something (usually) was edited.

 

Worth knowing: Skyrims engine does occlusion culling in software (barely [if any] title uses the nVidia method so its recommeded to have it disabled in the driver), so the CPU better got some spare cycles and the engine should not be at its limits with textures, models and scripts.

On new CPUs the engine will be at its limits while the CPU barely goes over 30% usage, so that's no indicator.

Link to comment

As Vachnic said, it is an issue with a portal/room marker, likely when the staircase was changed it went outside of the room marker. I bet it appears if you walk into the void area, if so then that is definitely the cause. A lot of people have no idea about them or what they do since they are disabled in the render window by default so they never see them. I ran into the same issues setting them up in Captured Dreams in some of the new spaces, if even part of the model is outside of it then it may not render.

 

I didnt say that, cause I am not clever enough ;) CGi said it.

This is exactly what happens yes. The "void" only appears at certain points and when I walk towards it, the room appears. So I guess it is safe to say it is caused by this portal/room marker thingymabobs. So far, I can understand what is being said.

But as for the way of fixing it... I have only opened the CK once, because I was curious what it was like, but I have absolutely no idea how to use it/ work with it. So your description went "woosh"... way over my head.

 

I still find it bizarre though that this just suddenly started to happen. As I said before, I haven't changed anything about my install in a while. The only thing that has changed is that I updated my graphic driver, but I somehow doubt that updating that would screw up portal/room markers in Skyrim and more specifically, only in Proudspire Manor. I have never seen it before elsewhere in the game.

 

Link to comment

Working with room markers and portals is rather tedious and if one marker is to close to each other you get to see the same on the edge of the screen in specific angles. Hence why most people don't work with them, so i'm really happy that Veladarius is and by this i'm not the only one getting more gray hair from room marker/portal based graphic glitches.. ^^

 

So if the issue is not caused externaly (driver settings included, like AA and such), then something (usually) was edited.

 

Worth knowing: Skyrims engine does occlusion culling in software (barely [if any] title uses the nVidia method so its recommeded to have it disabled in the driver), so the CPU better got some spare cycles and the engine should not be at its limits with textures, models and scripts.

On new CPUs the engine will be at its limits while the CPU barely goes over 30% usage, so that's no indicator.

 

I have checked my driver settings against STEP and I double-checked that the occlusion is off. I reverted to the old driver as well, so I am quite sure the settings are correct, since I didn't have the issue with the old driver and the STEP settings. And I most definately didn't edit anything, because I don't know how to. Also didn't install/remove/update any mods. Which is what makes it so flabbergasting. I have uninstalled/reinstalled the offending mod about 6 times now, but it keeps happening. *shrugs*

I guess I will just pretend that I have Sithis as my new housemate and that he brought parts of the Void with him ;)

 

Link to comment

if you rollback to an older driver version, you first got to make sure that you completly removed the previous driver first.
Nowadays driver come with profiles to help games run, either by replacing shaders to improve performance or by wrapping games calls to DirectX/the driver so it actually can run.

So if you have a left over profile, your reinstalled old driver will load it and by this load the possible reason for a problem as well.
Recommended: Display Driver Uninstaller. Works for ATi and nVidia as both share the same "problem".

Link to comment

Well, I tried the DDU, reinstalled the graphics driver and STEPified the profile for Skyrim, but still the problem persists.

 

I am too hesitant to start screwing around with CK, since I have no idea how it works. I did manage to find Proudspire Manor in CK (with the mod as active file, go me!) but nothing made sense to me. So I will just leave it be for now.

 

Thanks everyone for the help though! *cow hug*

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...