Jump to content
IGNORED

Sexlab 1.57 causes corrupt save file


Recommended Posts

This happened with 1.5 so I went back to a stable 1.39 and was playing that for a while.

 

Today I gave up and tried to update to 1.57.

 

AFAIK I've updated all the mods that have updated to 1.57. I started from a clean indoor save. All the menus load up fine, everything appears to install fine. All the animations work etc etc.

 

I make a save. Try loading within the game, corrupt. Same with quicksaves and loading from the main menu.

 

 

Link to comment

Any chance you could put up link to a stable archive (1.39) version?

https://www.dropbox.com/s/i6g4806yl3yq6jl/Saves.rar

 

That's the link to my save file. It's relatively stable and has the 1.39 version. I'm running the near maximum of mods, 230+. For this save my character is at 115 level Frost Elf. I'm currently in the weight abandoned dwemer boat in the middle of Solstiem on top of a mountain.. with Vilja.

 

I've kept that save as a standbye but I have not been able to advance very far after this. Even this save file tends to screw up and CTD when I try to load it. When I would load it fine.. I'd play for a few hours, quicksave lots.. then I'd get a random CTD at some point and find that stupid fucking hdtPhysicsExtension Autosave  file. I don't know how to avoid those. They happen less frequently than in the past but shit I hate them.

 

So that's why I tried to update to sexlab 1.5+.. hoping things were better. I moved to an interior space and did a clean save. I've been trying to load skyrim without ANY sexlab mods but it would CTD before the start menu would come up if I did not have the Devious Devices mods installed. That left me no choice but to install all the sexlab related stuff including DD and all the beast models. Then things worked. I loaded the save game fine, menu said everything was reinstalling, animations were working fine, I waited a bit (2 game hours) did a quicksave and saved to a new slot. I tried reloading that new game both from the menu and from a reboot. Both times it would load the same scene, all the characters would be frozen in place with arms out and I'd hear music and sounds.. but a little menu would tell me the save file is corrupt (both new save and quicksave) and the game would revert to the main load menu again.

 

I have BOSS and TES5edit but barely know how to use any of them. I only have the most basic understanding that they tell me when there is something wrong with a mod or it's out of order or missing something. I've looked at the tutorials on how to 'clean' with TES5edit and I'm fucking clueless. All I saw was a wall of text and I don't think I have the patience to learn. (I meant Wrye Bash, barely know how to use that either) The only save game cleaner I used.. erased all my sexlab data and I lost all the items I had stored in my house.

 

EDIT: HOW THE HELL DO YOU USE SPOILER TAGGS?? I've got my mod list but I don't want to spam it.

 

 

Link to comment

Wryebash tells me that my save is a purple color, meaning Good. Exactly synced with the current load order. 

 

But it still says it's corrupted when I try to load my saves. :(

 

EDIT1:Vanilla Voices. Fucking Vanilla Voices!

 

I always had a problem with that mod. The voiced never stayed. On a whim I took that out of my mod list and and holy shit snacks the games loaded fine!

 

I saved it again, and loaded a new game just fine.

 

EDIT2: now creatures don't work.

Link to comment
  • 5 weeks later...

The same thing happens to me and the save game cleaner does not help. I would be greatfull if someone would point me to the nearest fix for this ^^'.

EDIT: Yes I tried a new game the same thing happened and after reinstalling 1.49b it works just fine. A weird thing is when I installed 1.57 everything works fine but the strapons do not load every time.

And I am preatty sure the cleaning option does not work in 1.57 when I click it nothing happens (one of the warnigs that is there in 149b does not display either).

EDIT: I used setstage "ski_sonfigmanagerinstance 1" And the rebuild fuction worked... But the save was still corupted.

 

So the 1.57 corrupts the next save I make no metter what I do. Everything loads and every character is standing straight like doll, there is the corrupted save file massage. reinstaling skeleton does not help.

 

Ok since I realised I can not be helped when I do not put some work myself here is the log.

 

I would be really happy If someone translated this gibberish, until someone competent reads this I am in the dark.

 

Link to comment

It has literally nothing to do with anything mentioned in this thread.

 

Some newer versions of the SKSE plugin PapyrusUtil has an added dependency, one that if your missing will cause SKSE to fail when it comes to writing the .skse file. Deleting the associated .skse file associated with your save in My Documents/Documents/My Games/Skyrim/Saves should allow you to load the save, but is only a temporary solution as it'll just happen again and potentially permanently damage some mods you might have that depend on it and have no fallback for properly handling it's sudden absence.

 

SexLab 1.58 includes a newer version of PapyrusUtil that hopefully fixes this problem, which in addition to fixing the potential dependency issue should prevent it from happening again.

 

As for what the dependency is that you're missing. I have no clue, I've never had the problem myself, and nobody has ever confirmed what install fixes it for them. The likely candidates though from most likely to least likely are:

 

 

If your willing to help track down the cause for the benefit of others. Keep your current version that's causing the corruption, SexLab 1.57 (NOT the newer SexLab 1.58 which has the allegedly fixed version of PapyrusUtil), then install each of these one by one, between each install testing to see if the issue is fixed by doing the following:

  1. Load a save that doesn't have SexLab 1.57 installed (one that isn't giving the corrupt error)
  2. Let SexLab finish installing/updating SexLab 1.57
  3. Do a quick test sexlab scene to make sure it installed correctly
  4. Save your game into a new slot
  5. Quit Skyrim
  6. Reload Skyrim and attempt to load the save made in step 4.
    • If it gives corrupt error still, install the next redistributable package in the list and repeat these steps.
    • If it loads fine and everything works, do another quick save/reload to confirm and let me know which redistributable package fixed it.
Link to comment

You seem to have messed up the link on the fourth redistrubatable.

EDIT: Found it anyways.

 

I already had most installed with no savegame corruption (fairly sure 2013 isn't an issue).

 

But I'll see about uninstalling each one and running through the list.

Link to comment

My notes:

(Should note I disabled all mods save for SkyUI, Sexlab and their dependencies, Random Alternative Start installed as well as Matchmaker to get a game and scene going with minimal fuss. I'll make a new game and "coc riverwood". Not even a body mod. We're going with nudesuits, captain. God help us all!)

 

Dry run (all uninstalled.. I think. Add/Remove Programs looks like this):

 

-New save. Came up with this: http://i.imgur.com/xlR1ybp.jpg

-Quit without saving. Something's obviously up here.

-Checking SKSE log to see if anything is up. Will spoiler what stands out:

 

checking plugin C:\Program Files\Steam\steamapps\common\Skyrim\Data\SKSE\Plugins\\StorageUtil.dll
couldn't load plugin C:\Program Files\Steam\steamapps\common\Skyrim\Data\SKSE\Plugins\\StorageUtil.dll

 

 

Installing the first on the list, Visual C++ 2010 Redist Package

Load Sexlab-agnostic "control" save: worked without issue this time.

Animations test: works

Saved to new slot. Quit. Reloading: Worked.

Repeated: worked.

 

No soup.. er.. save corruption for you.

Mind you, I was never having save corruption in the first place, I was simply following instructions you posted here.

Link to comment

 

Mind you, I was never having save corruption in the first place, I was simply following instructions you posted here.

 

You test with storageutil.dll from SL1.58 or 1.57?

 

 

 

That's the thing. I can ONLY test 1.57 since 1.58 makes my game fail to even show window, SKSE hangs when loading at StorageUtil.

Link to comment

 

 

Mind you, I was never having save corruption in the first place, I was simply following instructions you posted here.

 

You test with storageutil.dll from SL1.58 or 1.57?

 

 

 

That's the thing. I can ONLY test 1.57 since 1.58 makes my game fail to even show window, SKSE hangs when loading at StorageUtil.

 

 

 

Which is why you were supposed to test WITH 1.58, to find out what version of the redistributable fixes it for you.

 

While this would be nice information to know. It's rather moot at this point as I'm currently working on a complete recoding of StorageUtil that should fix any issues for good.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...