Jump to content

Recommended Posts

Hi all, once more I am in need of your collective intelligence.


Haven't played in a few days and when I tried loading my most recent saves I encountered CTDs. I only added one mod before starting skyrim, so removed it tried again... CTD. Remembered the LE trick of loading older saves and loading the newest save from ingame, the older save loaded just fine but the recent ones result in a CTD again.


Quick research let me believe it has to do with the 65k string limit, but it seems this is no longer a problem in SE. However when comparing one of the recent broken saves and the last working one (not more than 1 hour of playtime between those two) the line count of the file increased from 6.467 to 186.325 (which even to my amateur eyes does not look fine) and when trying to open it with ReSaver I get "Error while reading the Papyrus section".


Broken save: Autosave2_1736BDFA_0_41727961_RiftenWorld_001937_20210810224159_19_1.ess

Working save: Autosave1_1736BDFA_0_41727961_TwilightSepulcher02_001808_20210810205926_18_1.skse


Does anybody know what happened here? Is it fixable, is there some way to avoid this in the future?

Edited by devilishmind
Link to comment

Try loading a save from before you added the mod. This will ensure that whatever went wrong with it isn't baked into the save files.


Fixable? Hmm.. maybe? But in my personal *experience*, most likely not. 


That's why I started off with the original comment. I spent a lot of time early in trying to fix problems that in the end turned out to irreparable. That took time away from enjoying the game (and moreover, granted me frustration and discouragement) . I "bought" funtime back by deciding to, wherever possible, dismiss things that make that fun overly difficult to achieve. One of the things I dismissed was debugging corrupted saves. I figured out that if I installed something, and it left me with corrupted saves, that loading a save prior to when I installed the offending mod, AFTER uninstalling said mod, resulted in the quickest route to the fun I was seeking. Even if I lost/lose a little game progress. Because honestly, unless you've created one of those challenging  "I almost can't win and I like it that way" configurations (cool if that's your thing, don't get me wrong ain't  mine though. I spent forty years with serious real world challenges, I'm worn out with everything being a difficult chore) game progress is pretty easy to achieve. 


said another way, it comes down to a cost benefit question. Is it worth your time to chase a problem that could take you days weeks months to find an answer to and solve, for 343 gold pieces, 30 various crappy weapons, another 30 or 40 crappy pieces of armor, some second rate potions, and even a level or two of progress? ...



good luck

Edited by anjenthedog
Link to comment

I agree and am more interested in preventing this from happening again. It don't think it was the mod I installed though, because I now added it to the last working save and was able to save, close and restart the game and load the save. It wouldn't corrupt only a few saves and not all I tried loading with it or am I wrong?

Link to comment

Well... if not a mod, sometimes a save just gets corrupted. I have no idea why, but ime,  if you continue to play (same session) and create another save(s) during the session, whatever glitch caused the first corruption can linger, causing corruption in new saves during that session.


So that's a possibility as well. 


Idk if you can prevent all save corruptions. Maybe, but I sure haven't accomplished it yet. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...