Jump to content

Recommended Posts

First off I Want to thank all the people who make mods. Game developers owe you so much for helping with the longevity and interest in a game.

Second, If I am posting this in the wrong place, I apologize but I am not sure if my issue is due to the vanilla game or a mod.

I am playing on Windows 10. The Sims 4 is updated to the latest version as well as are my mods which are listed below:

-Wicked Whims

-Kinky Whims

-Basement drugs

-Various animations for the mods

-hair,clothing and body mods.


My problem. Everything was working fine. I started a new game and now my sim cannot purchase drinks from a bar. I created a bowling alley and bar. When I go to order a drink, the menu pops up and my order options become available. I click what I want and nothing happens. I cannot purchase for myself, another or a group. Once I click the option I want the menu options disappear and nothing happens. I have also tried going to a vanilla bar that came with the base game with the same results. I can buy food.


Thanks in advance for any helpful response.

Link to comment

The latest version of Kinky Whims also requires the Community Library mod.


If those are the only script mods you have it should be working, so it sounds like a game bug maybe.


Try doing an Origin repair next.


You should also consider adding the Basemental Drugs mod if you want real booze, smoking, and other fun stuff.


Don't forget to delete your localthumbcache in your TS4 folder whenever you add, remove, or update any mods or the game itself. 

Link to comment

Thank you Scorpio. I went online and am doing the repair option now. I didn't know there was a repair option. It says 22 minutes left. I hope it's not doing the update as well. I usually stay offline and only update when I want something. I just updated everything so I could get university last week or so ago. I have basement drugs and you are right, it's great. I initially forgot about that one.

I hope the repair works. Again, thank you for responding.

Link to comment

Scorpio I just wanted to let you know it appears that solved my problem. I was only able to do a quick test. I had a sim make a drink and another sim drink it. It worked. Unfortunately I ran into another issue before I could further test it. I created a topic for that separate since it's a different issue. I just wanted to let you know how much I appreciated your response and your help. Thank you.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...