Jump to content
IGNORED

Creationkit: lighting issues in narrow buildings - black surfaces and on/off flickering


Recommended Posts

I am filling the quite narrow space on a ship with stuff and light sources.

 

Now, I see two issues when I test it in game:

 

1. Black surface, where they seem to be unimpressed by the light sources

Here, the door and on the table to the left is a map, which stays dark

Spoiler

CK61.jpg.08c790065f0159277d6f324cca543fe2.jpg

As far as I know, all light sources here are omnidirectional and no-shadow versions ?

Now, I wonder what I isunderstood or what I am doing wrong.

 

Same type of lightsources behind me, but everything works well:

Spoiler

CK58.jpg.6aa98eea440154c6aa09a3d32948b101.jpg

 

And my second issue is on/off flickering when I move through the cargo bay. Plus you can see the effect on the ceiling.

I am standing at the bow and look aft: ceiling is lit

I am standing at the other entrance and look forward: ceiling is dark

When I move along the planks, I get the on/off flickering

Spoiler

CK63.jpg.d98888f3ff359c871f5d28eda90c0204.jpgCK62.jpg.b44f8fb85ebf0d7c2a45acc7e72506a7.jpg

 

I think it must have something to do with the light sources ?

Link to comment
42 minutes ago, worik said:

As far as I know, all light sources here are omnidirectional and no-shadow versions ?

Now, I wonder what I isunderstood or what I am doing wrong.

Can also be caused by too many non-shadow lighting sources being visible to the camera at once (I think the number is 12, or maybe 16).  You can use portal-strict lights with room bounds/multibounds to solve this.  Also can be managed with enable/disable effects based on proximal trigger volumes.

 

This effect can also be caused if the lighting source is clipping through the wall.

 

This can also be caused if the 3D model of the tables (or whatever) is clipping through another lit surface.

Link to comment
10 minutes ago, Laura 'Lokomootje' said:

That could be an engine limitation when using shadow casting lights. You can't have more than 4 shadow casting lights overlap because it will show darkness like in your screenshot.

I'm not sure if that's the case for you, but you can try to use fewer lights.

 

1 hour ago, worik said:

As far as I know, all light sources here are omnidirectional and no-shadow versions

 

Link to comment
1 hour ago, Seijin8 said:

Can also be caused by too many non-shadow lighting sources being visible to the camera at once (I think the number is 12, or maybe 16).  You can use portal-strict lights with room bounds/multibounds to solve this.  Also can be managed with enable/disable effects based on proximal trigger volumes.

I didn't know that they are limited, too. ?

Will try that :classic_smile:

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...