Jump to content

How to shut down Skyrim if the game freezes during load on win 10?


xboronx

Recommended Posts

Got a new gaming rig 2 weeks ago and reinstalled Skyrim now. My old PC was windows 7, now i have windows 10, but i couldn't manage to shut Skyrim down in the task manager when i got this occasional endless loading screen freeze.

Is there some trick? So far googling didn't help, i have basically the issue the user in post #3 said here:

http://www.gamefaqs.com/boards/615805-the-elder-scrolls-v-skyrim/72397529

 

It didn't let me switch to the task manager, i could tab out but windows always moved me back to the frozen skyrim.

 

 

Link to comment

if all else fails you can ctrl alt + del and select log out. then when it starts to close things quickly select cancel. i usually always keep one unsaved text document open in case i get really bad freeze so when i try to log out it asks if i want to save and then i cancel the log out and so far every time i have done that it has closed the stuck program.

Link to comment

Got a new gaming rig 2 weeks ago and reinstalled Skyrim now. My old PC was windows 7, now i have windows 10, but i couldn't manage to shut Skyrim down in the task manager when i got this occasional endless loading screen freeze.

Is there some trick? So far googling didn't help, i have basically the issue the user in post #3 said here:

http://www.gamefaqs.com/boards/615805-the-elder-scrolls-v-skyrim/72397529

 

It didn't let me switch to the task manager, i could tab out but windows always moved me back to the frozen skyrim.

 

How are you setting skyrim to full screen? i found setting this in the ENBlocal.ini instead of trying to use the skyrim settings/setting this on the icon ment that on game freeze i could still get to the task manager, it seems this is a general gaming problem with win 10 as i've had it on other games as well

 

Link to comment

Make sure that task manager is Always on top, in options r you won't see it.

 

This seems very helpfull, will try it.

 

 

Got a new gaming rig 2 weeks ago and reinstalled Skyrim now. My old PC was windows 7, now i have windows 10, but i couldn't manage to shut Skyrim down in the task manager when i got this occasional endless loading screen freeze.

Is there some trick? So far googling didn't help, i have basically the issue the user in post #3 said here:

http://www.gamefaqs.com/boards/615805-the-elder-scrolls-v-skyrim/72397529

 

It didn't let me switch to the task manager, i could tab out but windows always moved me back to the frozen skyrim.

 

How are you setting skyrim to full screen? i found setting this in the ENBlocal.ini instead of trying to use the skyrim settings/setting this on the icon ment that on game freeze i could still get to the task manager, it seems this is a general gaming problem with win 10 as i've had it on other games as well

 

 

 

Did set it to fullscreen in the skyrim launcher settings indeed. Will try first what Vortec suggested, if this fails i will try your solution.

 

It's fun how Skyrim keeps beeing Skyrim, i also had to limit FPS to 60 because with FPS >60 i got an annoying water flickering effect. Also have some annoying motion effect when running, if this continues i'll try to capture it on video asking for help.

 

Hopefully the new edition which comes out in a few months will fix some of those issues. But even if i have to play with some small graphic glitches i will still stay addicted to Skyrim :D

Link to comment

You might want to try running with it with V-Sync enabled in the enblocal rather than with the fps limitor (tbh i've read about both causing/solving issues on win10) and if the stutter you are getting (running forward it runs fine until you reach the edge of what it has loaded and then there is a momentary delay while it loads a bit more, its only a problem in open world) the only way i found to get rid of that was to set ReservedMemorySizeMb=1024 to a stupidly high amount

Link to comment

I noticed that in Win10, if you just press ALT+TAB it switches focus back to the game immediately.

This can be fixed by holding down ALT and releasing TAB first, then move the mouse on the taskbar and click on it before releasing ALT. Usually the mouse pointer is invisible until you click on the taskbar, so make sure you move the mouse as far down as you can.

After you openened something in the background once, it should fix the ALT+TAB combo during that game session. Although the mouse pointer might stay invisible until it reaches something clickable.

 

 

 

Next thing that also sounds related to your issue, Skyrim doesn't support tabbing to desktop so i recommend enabling the 2 options in enblocal.ini

 

ForceBorderless=true

ForceBorderlessFullscreen=true

 

And keep all the Skyrim launcher and INI settings on default, unless they are required to be changed for ENB to work. Not sure if this was ever fixed, but after setting up everything for ENB you should never ever start the Skyrim launcher again or this might revert some important changes in the INI files.

 

On my old PC with a Radeon 7980 this would severely cripple performance, but seems fine on a GTX980. So make sure that you still get enough FPS with that.

Without that fake fullscreen, Skyrim will always freeze after tabbing to windows. While the infinite loading screen technically doesn't freeze the game, it just never completes the loading process.

There also are some options you can set in the graphics drivers to optimize the performance in fake fullscreen mode, but i don't remember what exactly since it seems to run fine with standard settings for me.

 

 

 

Lastly there is one major issue with Skyrim under Win10: It limits the VideoMemorySize to 4064MB for all DirectX9 applications. That is not the VRAM on your GPU, but the total available memory resulting from RAM + VRAM - OS / background apps.

This means that even with 32GB RAM and a TitanX with 12GB VRAM, you have to set the VideoMemorySizeMB setting in ENB to something ridiculously low like 3600. Which also means that you probably can only run the game in 1080p max, and may have to replace a bunch of HD textures with smaller and/or compressed ones.

 

With SKSE memory fix you should set ExpandSystemMemoryX64=false. At least this is the latest conclusion for this setting, as it's either redundant or conflicting.

 

And finally the infinite loading screens should go away by increasing the ReservedMemorySizeMb in increments until they no longer happen. Starting with 64, then keep doubling it like 128 -> 256 -> 512 and 1024 should the highest this can go.

However it seems important to keep this as low as possible to minimize stutter and loading times. This reserved memory is what the game can't use for the total video memory, and since you only have such a low amount available due to Win10 this is quite critical.

 

There also are the new settings for [THREADS] which might help if set correctly, you may want to look at ENB forums or STEP on how to configure them.

Link to comment

Thanks, the Vsync did it, now it works.

Also with the borderless windows setting i can now tab out and shut it down if it crashes.

Now it works at least as good as it worked on my old PC, with the benefit of having less script lag and constant high fps.

 

You are awesome, thank you all for the helpful responses.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...