Jump to content

Problems with importing from skyrim, Outfit Studio, Nifskope, and seeing the result in-game


Recommended Posts

Greetings.

 

So this has been a project of mine for the last two weeks or so (on and off), and all of the day today.

 

I have been working on an amalgamation of a few outfits that are bundled together to create one single outfit, with various combinations of the various imported articles to accentuate it's aesthetic look.

 

I had done this before using only assets from fallout 4, so this was nothing new to me. However, this time I was converting meshes from skyrim to fallout 4.

 

I had thought it was the single occurence, but it turned out that any outfit that I would personally try to import over (after going over the vigorous instructions outlaid on this site and many others) would inevitably end in failure.

 

Nifskope *always* displays *at least* one/two error messages when it opens up one of these conversions and Fallout 4 just displays the infamous red square when displaying this outfit.

 

 

Warnings were generated while reading NIF file.

device position incorrect after block number 59 (NiTriShape) at 0x23eb ended at 0x244f (expected 0x244c)

device position incorrect after block number 88 (NiTriShape) at 0x1db06 ended at 0x1db6a (expected 0x1db67)

device position incorrect after block number 111 (NiTriShape) at 0x101852 ended at 0x1018b6 (expected 0x1018b3)

device position incorrect after block number 131 (NiTriShape) at 0x2efcf1 ended at 0x2efd55 (expected 0x2efd52)

infinite recursive link construct detected 59 -> 0

infinite recursive link construct detected 88 -> 0

 

"Unknown property: NiNode"

File:

Function:

Line: 0

Category: nifskope.nif

Message:

 

"Unknown property: NiNode"

 

"Unknown property: NiNode"

 

File:

Function:

Line: 0

Category: nifskope.nif

Message:

 

"Unknown property: NiNode"

 

An MD5 hash comparison indicates this file will not be 100% identical upon saving. This could indicate underlying issues with the data in this file.

 

D:/Program Files (x86)/Steam/steamapps/common/Fallout 4/Data/meshes/Armor/Technicus Fanatixa20/Technicus Fanatixa20.nif

 

These were the 4 windows that were summoned when I tried to summon the outfit I had put together.

 

I would then go on to follow 'Guide 0' of the unofficial outfit studio tutorial, and that would merely cause Nifskope to fail to load the file altogether!

 

I have no idea what is causing this to happen, but I've been scouring the forums relentlessly and it seems I may be the only one who is suffering from this problem.

 

Does anyone have any idea what to do in this situation? Any input on the matter would be greatly appreciated. Thank you.

Link to comment

Tried exporting the pieces as .obj, then right clicking> copy bones.

Are you using the new or old Nifskope?

Some Skyrim outfits have extra bones (boucy boobs, etc) that break Fo4

 

I have just exported all parts to .obj, and then imported them under a completely new project. All textures are missing from the models (I'm not sure if I am to assume if that's normal). I select all meshes and select 'copy bone weights.' Did you mean that I should be doing it in this way?

 

It's the newest one as of the 12th of april of this year.

 

On attempting to save, a particular message appears which states that 'At least one vertice does not have any weighting to it.' The message also prompts me to use the weight brush tool, which appears to be permanently greyed out. The message also closes to reveal an area which is masked, but I cannot currently deal with it because I cannot use the weight brush.

 

Not sure where I'm going wrong here :s

 

each block is looking for properties that aren't there - down in "children" or "num properties" (iirc) in the trishape block, erroneously linking back to ninode's - clear them out.  If you can use blender or max you're better off doing that tbh.

 

I did think of going into 3ds for a while but it seemed a tad overkill for something which I would have thought would have been as simple as converting an outfit from one mesh to another. Still, not entirely surprised I was wrong, but at least now hopefully some progress is being made x)

 

So, when opening one of these files in Nifskope, I should search for these properties that exist under the 'trishape block' and remove them? What could be accomplished in blender or max that could not be already done in OS so far?

Link to comment

Not having textures is normal, since youll have to assign them using the material file (.bgsm)

 

The not weighting is fixed by right clicking the mesh parts>copy bones. It will copy the weight from cbbe body into the outfit.

 

Link to comment

Okay, So I have clicked on 'copy bone weights' and 'mask all weighted vertices' on all outfits and still no weight paint is available. 

 

I had read somewhere that 'clear mask' will allow weight paint to be used in the older versions, but not the newer edition I suppose.

Link to comment

I opened a non affiliated outfit and I couldn't open the weight paint in that either - even after closing the whole application, reopening it, copying the bone weights, clearing the mask, etc.

 

Should I just reinstall bodyslide?

 

Seems like whatever I do, I cannot open weight paint.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...