Jump to content

SL, Enhanced Camera and Immersive First Person


Recommended Posts

Immersive First Person works best with SL for viewing animations in first person but has terrible first person combat animations. Enhanced Camera on the other hand has great viewing of first person combat animations but viewing SL anims in first person is bugged and you see some glitched hands in front and then the rest of the body. Is there way to compromise? Would love to have great viewing of the first person animations both in combat and in SL.

Link to comment

Yes that is what i was experiencing especially with bows makes it really difficult to view and attack a target in 1st person there is no hands and bow visible so you are unable to target an enemy correctly because of this.

 

Was hoping there was an option to only use immersive when walking and sexlab but disabled during combat. This will make a better compromise.

Link to comment

Enhanced Camera has a secondary 1st-person camera mode that works reasonably well with SL anims. Copying from another thread:

 

 


After installing, open SKSE_EnhancedCamera.ini in \Skyrim\Data\SKSE\Plugins and make sure the following 3 variables are all set to 1:

 

bDetectMouseWheel

bForceFirstPersonCamera

bForceFirstPersonSitting

 

You'll now have 2 camera modes available for 1st-person. When you start a SexLab animation, go into 1st-person then zoom out just a little bit with the scroll wheel, to access the secondary mode. This mode will remove the static mesh and ensure the camera is matching the player character's head.

 

Link to comment

You can disable IFPV during combat in the settings.

Can you setup Enchanced Camera only to be active during combat? I don't use so I can't help, sorry.

 

Where in the settings is this option ?? i looked in the immersive 1st person mod but did not see this option or are you talking about enhanced camera ??

Link to comment

 

You can disable IFPV during combat in the settings.

Can you setup Enchanced Camera only to be active during combat? I don't use so I can't help, sorry.

 

Where in the settings is this option ?? i looked in the immersive 1st person mod but did not see this option or are you talking about enhanced camera ??

 

 

\SKSE\Plugins\FirstPersonPlugin.txt

 

Search for combat and you'll find it.

Link to comment
  • 4 months later...

 

Enhanced Camera has a secondary 1st-person camera mode that works reasonably well with SL anims. Copying from another thread:

 

 

After installing, open SKSE_EnhancedCamera.ini in \Skyrim\Data\SKSE\Plugins and make sure the following 3 variables are all set to 1:

 

bDetectMouseWheel

bForceFirstPersonCamera

bForceFirstPersonSitting

 

You'll now have 2 camera modes available for 1st-person. When you start a SexLab animation, go into 1st-person then zoom out just a little bit with the scroll wheel, to access the secondary mode. This mode will remove the static mesh and ensure the camera is matching the player character's head.

 

 

I added the bDetectMouseWheel=1 and set the other 2  to 1 as well.

I can see my character's body during a scene, but I'm unable to look around - the camera is set in a fixed position for the duration of the sex animation.

I can look up and down though.

Link to comment
  • 3 weeks later...

 

 

Enhanced Camera has a secondary 1st-person camera mode that works reasonably well with SL anims. Copying from another thread:

 

 

After installing, open SKSE_EnhancedCamera.ini in \Skyrim\Data\SKSE\Plugins and make sure the following 3 variables are all set to 1:

 

bDetectMouseWheel

bForceFirstPersonCamera

bForceFirstPersonSitting

 

You'll now have 2 camera modes available for 1st-person. When you start a SexLab animation, go into 1st-person then zoom out just a little bit with the scroll wheel, to access the secondary mode. This mode will remove the static mesh and ensure the camera is matching the player character's head.

 

 

I added the bDetectMouseWheel=1 and set the other 2  to 1 as well.

I can see my character's body during a scene, but I'm unable to look around - the camera is set in a fixed position for the duration of the sex animation.

I can look up and down though.

 

 

Same here. Can only look up/down now, although it looks much better... Also the range of looking down isn't great

Link to comment
  • 3 months later...

 

 

 

Enhanced Camera has a secondary 1st-person camera mode that works reasonably well with SL anims. Copying from another thread:

 

 

After installing, open SKSE_EnhancedCamera.ini in \Skyrim\Data\SKSE\Plugins and make sure the following 3 variables are all set to 1:

 

bDetectMouseWheel

bForceFirstPersonCamera

bForceFirstPersonSitting

 

You'll now have 2 camera modes available for 1st-person. When you start a SexLab animation, go into 1st-person then zoom out just a little bit with the scroll wheel, to access the secondary mode. This mode will remove the static mesh and ensure the camera is matching the player character's head.

 

 

I added the bDetectMouseWheel=1 and set the other 2  to 1 as well.

I can see my character's body during a scene, but I'm unable to look around - the camera is set in a fixed position for the duration of the sex animation.

I can look up and down though.

 

 

Same here. Can only look up/down now, although it looks much better... Also the range of looking down isn't great

 

 

I checked something, so the aneswer about settings was added in 14 April 2016 which probably was for version 1.3a which was added 11 january 2016, the problem is the new version 1.4 doesn't have the "bDetectMouseWheel" option, so i guess for it's to work you gotta install version 1.3a which have it.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...