Jump to content

Issues with selfmade Armor


robinhood11

Recommended Posts

Hello,

I've been working on an own armor. Everything looks fine, except for two things, which you can see in the following image:

 

 

zKxNTRL.jpg

 

 

As you can see the pouch is dark, the light of the fire doesn't seem to illuminate it. And the other are those black spots on the shoulderbelts.

In nifskope seems everything Ok as you can see in the following image:

 

 

64zz5K5.jpg

 

 

Any suggestions on how to fix those? :/ Especially the black spots, the dark pouch isn't that bad, because this effect only happens indoors.

 

Link to comment

For the black spots try to select that part onf the armor and in BSlightingShaderProperties in shader Flag 2 make sure it has Double Sided. Otherwiseit could be the textures fault. Remember that Skyrim can only use "square" (power of 2) textures. i.e 256x256, 512x512, 1024x1024, 2048x20481 4096x4096. 

Nifskope wil show your textures correct even if they are not in the power of 2, but they will not work correct ingame

 

For the pouch you can play with the specular strenght a bit. Try increasing it a bit.

 

*Edit

For the pouch try to set the Emissive colour to 0 as well.

Link to comment

Hmmm... well the texture is at 2048.. and there is a "SLSF2_Double_Sided" modifier under Shader Flag 2.. :/

Maybe it has something to do the way I made the ends of the belt? I cut them and deleted some vertices in 3ds max, and extended the mesh again at the borders to cover the ring

Link to comment

try some nifskope stuff

right click on the mesh in 3d window -> mesh -> make skin partitions

mesh -> face normals or flip normals if the normals are not ok

sometimes black meshes are due the vertex color thing, not sure what it is. There is a shader flag that must be on if the "has vertex colors" on the Nitrishape say yes, or viceversa.

Link to comment

try some nifskope stuff

right click on the mesh in 3d window -> mesh -> make skin partitions

mesh -> face normals or flip normals if the normals are not ok

sometimes black meshes are due the vertex color thing, not sure what it is. There is a shader flag that must be on if the "has vertex colors" on the Nitrishape say yes, or viceversa.

 

Is the number of bones per vertex/per partition important?

tried it with 4/18 stripify triangles on and pad small partitions off.

sadly didnt solve the issue :/

 

Not quite sure which shaded flag you ment there .. hm

 

and also tried adding the normals modifier with "unify normals" checked - also no improvement.

 

Slowly I'm starting to believe that I just apply those fixes in a stupid way and thats the reason why they dont work  :dodgy:

 

If I'd upload the mesh + textures, might there be a chance one of you guys could look over it?

Link to comment

Fixed it with:

Exporting it as OBJ, reimporting it. than it worked... well yeah atleast that worked.

 

Btw. is there a way to reduce the number of seperare NiTriShapes? Got like 10 different ones in that mesh and that is kinda annoying :/

 

In Max you can use the Utilities - Collapse to attach objects under the same poly/mesh, this is pretty useful for those objects that use the same material (texture), grouping them under the same NiTriShape branch. Try that in your next project.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...