Jump to content
IGNORED

Armor From Mod To Npc - Npc Naked!?


Recommended Posts

Hey there

 

I've a very annoying problem. I recently downloaded some Armor for CBBE and they work fine so far.

Then I thought I could add them to a few NPCs with the Creation Kit.

 

So I created a new file with this armor as master file, created an outfit with the armor parts in it and added it to the desired NPCs. But instead of wearing this armor they now are all naked. I even checked their inventory via console: They don't even have the armor in it.

So the next thing I did was adding the part of the armor one by one in their inventory. Still the same result.

The last thing I tried was adding the armor directly in its esp-file to the NPCs by creating the outfit there and then adding it to the NPCs. But nope - all I get is striptease.
 

 

 

Here is what I did so far:
 

1.) Added a completely new Outfit with the CK.

I) I created a new outfit

II) I added the armor parts I wanted the NPC to wear to that outfit

III) I added the outfit to that NPC

-> NPC is displayed correctly in the CK. Ingame he/she ist still naked.

 

 

2.) Edited an already existing outfit with the CK

I) added some of the new armor parts to an already existing outfit

II) added that outfit to another NPC

-> NPC is displayed correctly in the CK. Ingame he/she would only wear the stuff which has been in the outfit from before.

 

 

3.) Replaced armor parts

I) replaced some of the meshes from working armor with new ones

-> Again the f*cking NPC is displayed correctly. Ingame he/she would only wear the replaced meshes without any problem. All other armor parts are still whown as naked.

 
 

This has happened to me now with the Sorceress Armor, the Ashara Imperial Outfit and the Midnight Breed Armor. I can't figure out why the hell it wouldn't work.

 

 

WTF!?


What ist wrong with this s***? Why don't they wear that armor? Not even have it in their inventory? Did I do something wrong or is the CK just completely useless!?

Link to comment

CK works fine, you probably forgot to do something. Let's see what is missing:

 

Have you set the same body armor part in the BSDismemberskinInstance branch (Nikskope) and in both the Armor Addon & Armor (CK)?

 

Also, in the Armor window, don't forget to change in the models window to the Armor Addon you have created earlier. 

 

Edit: wait, probably you have just added the armor to the NPC inventory and you didn't created an outfit for him. Create an outfit for you character, then assign that outfit to him. This guy explains it very well.

Link to comment

@ JRCosta: I didn't do anything to the meshes itself. I only took the armors from the existing mods. As standalone mods they work properly so I think the meshes are all set correctly. I also created the armor as outfit in the same way like said in your tutorial.

 

@clp2011: Yes I was thinking about that too but no - the CK says that's fine.

 

 

What's even more strange is, when I use TESVSnip to assign the outfit to the NPCs it works. Don't know what that tool does differenct in comparison to the CK but anyway - as long as it's working I'm fine with that.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...