Jump to content

Mashup Armors


Recommended Posts

I'm trying to make a mashup armor from various armor parts, and one of the parts I want is from the raider sadist armor, specifically the severed hands hanging from the belt. However, when I select the hands in Nifskope to copy the branch, it selects the entire armor. I only want the hands!


Is there a way to "take apart" meshes in Nifskope? Or would a 3D Model editing program like 3DS Max be needed? I have both.

Link to comment

You can't delete a armor piece out if it is all connected you try to delete it and the whole thing will get deleted. You can however copy the branch and paste the whole thing into the armor that you want it in and then throw the texture file for the armor into gimp you will need the .dds plugin so that it will load them up and lasso everything that is there that you do not want and use the edit tab to cut those parts out and use the overwrite .dds file to save it. You will also have to click that armor part in nifskope and go to node attach property and select NiAlphaProperty. That will make what you cut out of the texture file disappear in the nif then save as so that the nif gets saved and once you have removed all of the parts you should be good to go.  http://www.gimp.org/

Link to comment

okay I tried that nialphaproperty thing and it looks fine in NIFskope, but when I look at the armor in the GECK the parts I added are all this ghostly, near-invisible purple color. What gives? I know I only blacked out the parts I didn't want showing.

Link to comment

myuhinny your a genius. i can't believe i finally got somewhere with nifscope. slamwich - sounds like the hardest part is behind you. the purple sounds like remnants of the texture file. until the real master gets back on, you could play around in gimp or paint.net (application) with your texture file. WOOT

Link to comment

Yeah, there's just the color map and the normal map. I've made custom copies of both with all the stuff I didn't want blacked out in their alpha channels, but it still ends up with the whole outfit, including the parts I want to have visible, appearing as transparent purple.


I tried fiddling with the flags under the nialphaproperty in Nifskope, but I have no idea what it actually does and it just ends up making it worse. Thankfully I have backups.

Link to comment

Photoshop that would explain the purple maybe it might also mean missing texture files. I used photoshop 1 time because I was having problems with gimp I used it to cut out parts of a texture file the same way that I do it in gimp. It looked great in nifskope but in game the spots that I had cut out were now black. I finally figured out what was wrong with gimp and I was thinking that photoshop saves the shit weird. So I threw them into gimp went to file hit the overwrite .dds file. Went into game the shit was the way it was suppose to be.


Also I forgot to say when you do a mashup you have to place those texture files into the folder of your choice which ever part of the mash up that you want them placed in then you need to change the texture path in the nif file for those parts to the folder that you placed them in.


I usually place the texture files of the parts that I add to a armor into that texture folder for that armor I then click the armor part that wasn't added to the nif go down to BSShaderTextureSet click the arrow to the left of it to get the drop down then double click the texture file line to get the texture file path copy it then click the armor part/parts that you added 1 at a time and paste in your texture file path but do not change the .dds part and it should stay rendered.

Link to comment

Okay, I think I'm on the right track now: I edited the NiAlphaProperty flag to:




Good news is that the armor parts I added are no longer see-through purple. Bad news is that ALL of the armor parts are invisible. I only want one little piece of the armor visible! Like before, it looks fine in Nifskope but the parts I added are all invisible in the GECK.

Link to comment

You can do all this with nifskope... BUT... you can only add or remove entire vertex groups. It greatly depends on how the items were made in the first place. Accessory items are generally easy to cut and paste between meshes... more major parts like sleeves, jackets, pants, etc. are not...


In the 3d Pubic Hair for T6M thread I gave some instructions on copying a vertex group from one nif to another.

Link to comment

Alright, so I cut the armor up in 3DS Max, isolating the armor bit I wanted. The bone attachments and textures still work, so no need for any fiddling there. I deleted the old armor I had pasted to my custom armor before and pasted the new armor bit on in Nifskope. a little fiddling around and it looks like this:




Looks great! However, looking at it in the GECK looks like this:




What the fuck? Is the GECK just being stupid or what?

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...