Jump to content
IGNORED

Neck seam using UNPB & Barbarian skin


Recommended Posts

Hi.

 

After much searching I finally found the perfect skin texture for me in Barbarian skin. Only problem is I have a pretty bad neck seam the I can't seem to get rid of. I've tried uninstalling other mods which I thought might be affecting it but so far nothing is working. I had a look for a texture blender and found this one but there is no option for barbarian skin in the downloads. Can anyone help me with this?

 

Here are some pics of the problem:

 

 

 

 

2014-04-14_00002_zpsa481e13c.jpg

 

 

2014-04-14_00001_zps57fec99e.jpg2014-04-14_00003_zpsb24bc62d.jpg

 

 

 

And a pic of my load order:

 

 

 

 

LO_zpsc96a8ed6.jpg

 

 

 

Thank you.

Link to comment

You'll need to some blending. But as far as LO goes, I've found that Zaz modifies head .tri files so placing it above your textures and body (or the textures and body below Zaz) can help. I've gotten gaps before and changing the where Zaz and the body/texture mods were located fixed it.

 

Sorry I don't have any better info, though. I am using Barbarian with Seven Base Bombshell and have a very similar color seam to yours. My character is now wearing a collar. :lol:

Link to comment

I can't recall having as bad a seam with Barbarian skin as those pics show. Are you using the "UNP Texture Blender - Navetsea" file with UNP Blender & is it CORRECTLY installed? Did you open the textures in GIMP prior to blending, allow GIMP to generate MIPMAPS, and then Export from GIMP (don't DO anything to the textures, just open & Export with the "Mipmaps" option ALWAYS selected), again allowing MIPMAPS to generate?

 

If the answer to any or all of the above is "No" or "I don't know", junk your ...\Skyrim\Data\Textures\actors\character\female folder, uninstall Barbarian skin, then re-install it using NMM. Then do the above. :huh:
 
Did you check whether the seam is being caused by your ENB? *Temporarily* remove the d3d9.dll from your Skyrim folder, then load the game to see if the seam is still present. If it is not, then use the SOLUTION POSTED HERE to fix it. :)

Link to comment

Thanks for the info Fastestdog.

 

No I'm not using a texture blender at all yet.

 

In those pictures I have no ENB installed so it can't be that. (although since then I have installed ENB so that info may come in useful still :))

 

Bit of info that may help narrow down the problem: I just installed a couple of standalone followers which use their own meshes and textures, there are visible seams on those as well, very similar (maybe the same) to the seams I have here.

 

"If the answer to any or all of the above is "No" or "I don't know", junk your ...\Skyrim\Data\Textures\actors\character\female folder, uninstall Barbarian skin, then re-install it using NMM. Then do the above. :huh:"

 

I will try this this weekend when I have some more time to spend getting this sorted.

 

Thanks.

Link to comment

Ah - in that case, yes, you will have a seam until you actually do use the blender. There *IS* an option for Barbarian - read the description for the NAVETSEA option in the Files section & you should see it. Ensure that you follow the steps outlined in the post above, and that you use Svarog's blender correctly. :huh:

 

I would advise making sure you have your skin textures installed correctly, and make a backup copy of your "female" folder before you do anything. That way, if you need to repeat the process more than once you don't have to uninstall & reinstall everything. Once you have everything properly blended, junk the pre-blend backup, and make a backup of your newly blended female folder. Keep the blended backup somewhere handy. :)

 

*Followers who use their own textures - if you really feel you want to use those - are a separate issue. You can, if you like, force them to use the textures your player model uses (better option). The follower will have a separate folder somewhere which contains its textures - just replace those with your blended Barbarian textures once you've done them. Do bear in mind that if a follower is using its own separate meshes that are NOT UNP, then UNP textures will not work on them unless you replace the body. If that breaks the follower, I would begin to question why you really need to use them in the first place (*there are ways of getting around all this, but as a beginner they can be more trouble than they're worth). ;)

Link to comment
  • 2 weeks later...

Thanks. Been trying to download that Navetsea texture blender for a while but it keep saying it's hidden. So I hit a bit of a wall now on the neck seam :(

 

By the way I'm using Mod Organiser so I don't think a lot of what you're saying applies to like junking my Skyrim\Data\Textures\actors\character\female folder.

 

I have recently noticed some more issues, they're a lot more apparent on darker skin tones though you can see them on lighter skin as well.

 

Line on wrist:

 

 

 

2014-05-01_00009_zps33cbee83.jpg

 

 

 

 

Strange flicking line of white dots across buttocks(Harder to see in pic but in game those dots are jumping across in a line):

 

 

 

dots_zps12e62ab9.jpg

 

 

 

Anyone know what this is?

Link to comment

Okay, so to try and find out where the problem begins I want to go back to the start so I can add meshes and textures one at a time to see where the problem begins. So in MO I uncheck UNPB and the texture mods expecting that should revert me back to vanilla body with underwear. But no, I still have no cloths on (no nipples either) so I think there must be something in my other mods that is affecting the texture/meshes so I start unchecking/running FINIS etc, 1 by 1 all mods to do with apparel. Still have this weird body with no nipples. So i uncheck everything SOS and sexlab related, still the same.

 

I'd almost got rid of everything, so I thought... I know, I'll just create a new profile in MO and just install 1 mod, Alternate Start, so I can quickly look at my character. I do this and my character is floating around(I assume because FINIS is not installed) and still has the weird body with no nipples........................................................................................................

 

WTF? I thought MO doesn't touch skyrim data files? Why don't I have any movement animations if this is the case and why do I not have the vanilla body on a new profile?

 

 

 

 

 

2014-05-02_00001_zps8929cb7b.jpg

 

 

 

Please help.

 

EDIT: ok, so I'm running FINIS through MO but FINIS I assume is still messing with the skyrim folder making permanent changes to animation. That would explain that but why can't I get back to default mesh and textures?

Link to comment

Okay - as per pour PM exchange, here is a Beginners' Step-by-Step I wrote for a Nexus member recently. Experienced users may find it a little over-worked, but it's the method I use, and it works perfectly for me... ;)

 

 

 

HOW TO BLEND BODY TEXTURE SEAMS FOR UNP BODY MESHES, INCLUDING ZZJAY'S UNP MESH FIX - BY FASTESTDOG
 

*Work slowly & carefully, and ensure that you are not skipping steps. Once you are familiar with the process, it's a snap, but for now just take it easy. FOR INFORMATION ON HOW TO PROPERLY INSTALL AND SETUP ANY PROGRAMS REQUIRED FOR SKYRIM MODDING (eg: NifSkope, GIMP), REFER TO GOOGLE, THOSE PROGRAMS' MODPAGES & AUTHORS.

 

 - NIGHTASY'S TUTORIALS ON YOUTUBE PROVIDE A DETAILED GUIDE ON NIFSKOPE INSTALLATION.

 

 - GIMP REQUIRES A .DDS PLUGIN. AGAIN, GOOGLE.

 

 

Okay - here's what I do. For reference, my card is an AMD. ZZJay has some additional instructions to follow for NVidia users. Let's assume you have correctly installed your SeveNBase or other UNP-type body according to the authors' instructions. You have correctly installed your textures, again according to the authors' instructions. If in doubt, return to the Descriptions & Files sections of the mods you used, and slowly & carefully double-check. Uninstall & reinstall correctly if you need to. If you're confident you have correctly installed your textures, make a backup of your ...Skyrim\Data\Textures\actors\character\female folder on your desktop (this way you don't need to reinstall mods if anything goes wrong). :huh:
 

Now, you're ready to start on the meshes. Ensure that you have downloaded & correctly installed NifSkope.
 
 - Go to your ...\Skyrim\Data\meshes\actors\character\character assets folder, and locate your femalebody_0.nif and femalebody_1.nif files. Open them both with NifSkope (right-click & select "Open With..." & browse for the NifSkope .exe file if you haven't already).
 
 - Refer to the first pic at ZZJay's "UNP Neckseam Resources" page (the one showing the body mesh open in NifSkope). See how ZZJay has opened up the options on the left-side "Block List" bar? You can click on the little " > " symbol next to an item, and it will open the next element (just like opening files in Windows).
 
ZZJay has clicked on 0 NiNode > 1 NiTriShape > 2 NiTriShapeData. When NiTriShapeData is clicked on in NifSkope, the Data for that NiTriShape (ie: that piece of the mesh) is visible in the "Block Details" bar at the bottom of the NifSkope window. This window shows the values that ZZJay is saying need to be manually changed by the user. You can scroll up & down in that window by using the mousewheel.
 
 - See that ZZJay has circled two of the values in the Block Details bar - "BSNumUVSets" and "Has Normals"? Your values need to match those shown in ZZJay's pic. BSNumUVSets should already be set to "1" - if it is not, click on whatever is there instead of 1, and change it to 1. To change "Has Normals" from "yes" to "no", simply double-click on the "yes".
 
 - All done! Go to File > Save As... > and simply save over the mesh without changing the name (select "Yes" in this case). Repeat this for both the femalebody_0.nif and femalebody_1.nif files. Close NifSkope when you're done.
 
 
Okay - pretty simple yes? Now it's time for the textures! Ensure that you have downloaded & correctly installed GIMP (*remember - the .DDS plugin is required!). :)
 
 - Locate your ...Skyrim\Data\Textures\actors\character\female folder. Open the first texture (.dds) file you see there in GIMP.
 
 - You will be prompted with a little "Load DDS" window, which has clickable options for "Load MipMaps" and "Show this Dialogue". ENSURE BOTH OF THESE ARE TICKED. Select "Yes" to continue.
 
 - Now, do NOT do ANYTHING to the texture! Just let it load!
 
 - Once the texture is loaded, go straight to File > EXPORT. Without changing the name, select Export. You will be prompted to Replace ("yes"), and then a DDS Image Warning will appear stating that Volume maps etc. etc. A little window will appear with it, looking like the one shown in ZZJay's Description (*the last pic shown BEFORE any of the NVidia stuff). Ensure "Generate MipMaps" is ticked. You can if you like change the Compression & Format values to match ZZJay's (I do not - but it might be a good idea if your computer struggles with textures). Click "OK".
 
 - Done! Repeat this process for ALL of the body, hands, and head textures in your ...Skyrim\Data\Textures\actors\character\female folder. Make a backup copy of this folder on your desktop (you can overwrite the backup you made earlier if you feel you've got it right).
 
 
Okay - now that your textures all have MipMaps, it's time to use a texture blender! This is the final step. :yes:
 
 - Go to Svarog's UNP Texture Blender page, and manually download the correct version for the textures you selected. Read the Descriptions CAREFULLY, and do not bug Svarog (woe betide ye if you do not read Descriptions! ). :D
 
 - Manually unpack the contents of the version you chose into your Skyrim\Data folder - double-check the file path in the archive & be sure you put it in the right place (it should be as simple as dragging & dropping the "data" file from the archive into your Skyrim folder).
 
 - Let's say you chose the "Navetsea" version. Go to ...\Skyrim\Data\CalienteTools\UNP Texture Blender - Navetsea and open TexBlend.exe
 
 - The TexBlend window will open. At the top left are two drop-down menus - "Select Texture Set" and "Select Texture Type". Open "Select Texture Set", and select the first option down: Body and Feet. Go to "Select texture Type", and select "Colour".
 
 - A new option will appear in the middle window: "Choose texture Mod to Apply". It should be labelled "UNPBodyColour.png". Click on it to highlight it, then move the mouse arrow to the "Preview" tab on the right hand side of the window. Click "Preview", and allow the blender to generate the preview (this may take several seconds).
 
 - When the Preview is complete, click the "Blend Images" tab.
 
 - Repeat the process for all the options in the "Select texture Type" menu - Colour, Normal, Skin, Specular. When you are done, return to the
"Select texture Set" menu & select "Hands", repeat the process for all options, then for "Head" as well.
 
 - Done! Yay! Now open your game to see how you did! You should now be (mostly) seam-free. If the process worked & you are happy with the results, make a backup of your blended textures & keep them stored safely. ^_^
 
 
***There is another cause of seams, and one that I had forgotten about but encountered recently when I installed a new ENB. Some ENB versions can cause a neckseam. If this happens when you install an ENB, simply go to your enblocal.ini file, and locate the following line:
 
FixTintGamma=true
 
Replace it with:
 
FixTintGamma=false
 
 
There y'go - that's how I blend away UNP seams! It's not foolproof, and any method will always result in a slight seam remaining somewhere, but this method greatly lessens them! Good Luck! ^_^

Link to comment

Thanks a lot for the help I appreciate it. :shy:

 

Now I have to figure out how to do this using Mod Organizer.

 

I have located the femalebody_0.nif and femalebody_1.nif files but MO is tellling me those are being overwritten. They're in red and the tooltip says: Also in data. I've looked in the data folder in MO and there are no such files. MO is making this whole process a lot more confusing. I'd like to uninstall it and start fresh with NMM or something but MO does have its perks and I've restarted several times already. I've also spent weeks if not months gathering and installing all the mods I have so far with it.

 

 

Untitled_zps073363ef.jpg

 

 

 

sigh

Link to comment

Try to move barb skin under Lith face enchancement... or give Barb skin higher priority... or how it's done in MO i dunno.

LiFE has a couple of textures that overwrite parts of barb texture set. Might be the problem here. LiFE also comes with .esp, that might do some bad stuff.

 

edit: no, .esp seems fine. It only adds some eyes and warpaints.

Link to comment

Ah crap! Unfortunately Mod Organiser is not something I am at ALL familiar with - best of luck! :unsure:

 

*Just locate those files in your actual Skyrim folder, not MO.

 

Yeah I am. :) I'm just using this to see exactly what files MO is using and where they're located. Then I'm finding the actual files in the Skyrim/ModOrganizer folder. I'm pretty sure that those files being in red is just a false alarm now though, it's just there to tell me that these files are overwriting something else. So now I'm just going to go ahead and follow your steps for blending. Not too hopeful though, whatever I do I seem to have a neckseam, barbarian skin or other from what I'm seeing.

 

Try to move barb skin under Lith face enchancement... or give Barb skin higher priority... or how it's done in MO i dunno.

LiFE has a couple of textures that overwrite parts of barb texture set. Might be the problem here. LiFE also comes with .esp, that might do some bad stuff.

 

edit: no, .esp seems fine. It only adds some eyes and warpaints.

 

Thanks I will try that, though I have seams with or without LIFE installed so... :-/

Link to comment

So, I followed your instructions carefully. I had to install the navetsea blender manually into skyrim folder because I don't know how to do it with MO so don't know how it would locate the barbarian textures, if it needs to do that. During some of the blending there was no option. For set: Body and Feet, Type: Skin, in the middle window it just says 'no files found for this set and type'. There were a few others that said this too.

 

Anyway, I went through it all and even tried the enb fix, still the same old seams :(

 

Here's a pic I took right after doing the blending:

 

 

 

2014-05-04_00002_zps066345cc.jpg

 

 

 

Close up of neck front:

 

 

 

2014-05-04_00005_zpscc9af662.jpg

 

 

 

In game it looks actually a little worse than these pics. very noticeable like the head was just placed on the body like some weird bride of Frankenstein. :(

Link to comment

yeah, that could be right. It's really weird though because even if I remove barbarian skin I still have a neck seam. Whatever I do I have seams or lines somewhere, something is seriously wrong and it's probably a very easy fix once you know what the problem is.

 

What files should I be looking in for things that could have stuff in that will affect this? Is textures/actors/character/facegendata/facetint relevant?

 

 

Link to comment

In your first post, in the pic of your MO installed mod pane, it shows Barbarian skin overwriting files and being overwritten by something else. Double click Barbarian and choose the "conflicts" tab to see what is overwriting it. That should lead you to the issue. Whatever is overwriting it should be placed above Barbarian or Barbarian moved below the offending mod. Keep Zaz above both of those since that overwrited head .tri files and can cause seams or gaps itself.

 

I'm assuming it's LiFE that's overwriting it. Try moving that above Barbarian and see what happens.

 

Also, check the red triangle at the top right of MO. That will point you to any issues that MO notices could be going on. And be sure that .bsa files are activated in the right pane if there are any with red triangles.

Link to comment

In your first post, in the pic of your MO installed mod pane, it shows Barbarian skin overwriting files and being overwritten by something else. Double click Barbarian and choose the "conflicts" tab to see what is overwriting it. That should lead you to the issue. Whatever is overwriting it should be placed above Barbarian or Barbarian moved below the offending mod. Keep Zaz above both of those since that overwrited head .tri files and can cause seams or gaps itself.

 

I'm assuming it's LiFE that's overwriting it. Try moving that above Barbarian and see what happens.

 

Also, check the red triangle at the top right of MO. That will point you to any issues that MO notices could be going on. And be sure that .bsa files are activated in the right pane if there are any with red triangles.

 

Yeah I've tried deactivating LiFE, moving it above barbarian skin, nothing is making any difference.

 

Here's what the conflicts for barbarian skin say:

 

 

 

Untitled_zps6dbf8234.jpg

 

 

 

In the red ! mark in the top right I have 1 issue telling me I have stuff in my overwrite folder.

 

And Zaz is above everything. Al my .bsa are activated.

Link to comment

Like I said before, I have a slight color seam there with Barbarian on a 7BB body. Instead of going anal over blending it perfectly I try to ignore it (it isn't really that bad in my game) and most of the stuff that character wears covers that area anyway.

 

Your seam apparently is NOT a mod order conflict. MO is making that quite clear so that's one tree you can quit barking up. :D It may very well be just how that texture is working with the UNPB mesh, but even then I'd expect a gap or something if it was a mesh issue. I know that using it on a UNP BBP body I get a seam like yours, but it's not as bad on the 7Base Bombshell body. So different meshes must play a part here.

 

That texture is also being overhauled by author right now. So maybe when the newer version is released it will be better matched?

Link to comment

hmm yeah maybe you're right. I just have a weird feeling something is not right. Sporty sexy map has a neck seam for me too, but I guess barbarian skin is based off of that so maybe that explains it.... sooo I guess now I leave UNPB behindcries and try some other meshes. :)

 

If I get a neck seam with them too I may just give up lol

Link to comment

Well, I get a seam using it with UNP and SevenBase, too, so don't hold your breath. :lol:

 

Look on Nexus for the Top Model body and on the download page there is also the FSC Univision texture for UNP variants. That coupled with the fit body mod should look like Barbarian and I get no seam using the FSC texture on any UNP variant (it also has an ECE patch with it to use if you need it).

Link to comment

Yeah it seems like whatever I do I have a  pretty bad neck seam. Even with a different body mesh like top model with barbarian skin. I also tried your suggestion gvman and used FSC univision texture with UNPB, it was a little better but still a very visible seam.

 

Probably just going to stick with UNPB and barbarian and try to live with it. I had a look around for mods with collars but can't seem to find any right away. Any suggestions for that? :lol:

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...