Jump to content

Camera flip issue - upside down camera when running


Shinobi7

Recommended Posts

So... After a quick google search, this issue is fairly common it seems.

However I have yet to find a fix for it or what causes it.

 

Description:

 

Randomnly, when running towards the right the camera filps upside down - your character now running on the top of your PC monitor, the sky below.

It reverts to normal as soon as you walk or change direction.

 

I have also experienced camera flashing quickly when running towards you - using back arrow (achieved with 360 run included in XPMS 1.9 or VHH)

 

http://skyrim.nexusmods.com/images/256868/?

 

What is frustrating is that when this happens it'll stay for undetermined amount of time; and sometimes the issue disapears after some time.

 

I have tried reinstalling XPMS and also VHH - which includes 360 run direction and also Feminine run animation I'm using (also from XP32 - although maybe the skeletons included are outdated vs XPMS 1.9?)

 

Anyhow, if anyone knows the reason or better, how to fix, please reply!

Link to comment

I use BOSS for load order. There's nothing which should interfere there.

My issue does resolve itself after a few minutes just like you. But my point is, this is an unsolved problem and it happens to a lot of people it seems.

I think it's fair to create a thread to allow people to view and solve - including myself ^^.

Link to comment

boss isnt the best for load order ealier i had use boss for load order but i had only trouble..trust me boss doing often shit..by unknown mods...better say mods which boss dont know...since i do the load order by myself my game running already with nearly the max amount of mods  perfectly...

Link to comment
  • 3 weeks later...

This happens to me, but if i just sprint forward it fixes itself

See I'm just the opposite. If I sprint forward, I get that camera flip for that instance then it rights itself.

 

I'm using XPMS and also VHH but I'm using one of the compatibility skeletons from SoS. Not crazy about the skele personally due to a disfigurement in the hands while walking to the sides, but its the only way to keep the SoS main attraction working properly.

 

There has to be a common element. skeletons? sprint animations? some hidden scripting any of the above use?

Link to comment
  • 2 months later...

I've been trying to see if others had this problem as well and it seems this is an ongoing issue. The only in game fix I have discovered so far is from using the mod Better Vampires and then using the vampire spell Mortal's Mask with the change appearance option checked from the MCM menu while a vampire. Using the spell will change your appearance from a vampire to normal, assuming you are a vampire. This has fixed it 100% of the time so long as the appearance change actually happens from using the spell.

 

Maybe somebody could use the same idea behind the Mortal's Mask change in Better Vampires to making a fix to this in general.

 

Better Vampires

http://www.nexusmods.com/skyrim/mods/9717/

Link to comment

Wait, whoaaaaaah. This has not been answered yet? Since November? Geez guys, you're all wrong. And if my answer isn't right or close, then theres probably no solution. I just can't stand how much of a headless chicken you guys look like.

 

The origin of the problem resides on that particular animation which in Shinobi's case, is the running right animation.

Load order? Bullshit. Skeleton? Bullshit. UNPB? Even more bullshit. The solutions that you guys mention are all temporal. If you want to fix the camera flip, then you better do something with that particular animation that causes flip. So in summary, the solution is to delete the animation that triggers the flip. Unless of course, you are a modder which non of you seem to be.

Link to comment

Wait, whoaaaaaah. This has not been answered yet? Since November? Geez guys, you're all wrong. And if my answer isn't right or close, then theres probably no solution. I just can't stand how much of a headless chicken you guys look like.

 

The origin of the problem resides on that particular animation which in Shinobi's case, is the running right animation.

Load order? Bullshit. Skeleton? Bullshit. UNPB? Even more bullshit. The solutions that you guys mention are all temporal. If you want to fix the camera flip, then you better do something with that particular animation that causes flip. So in summary, the solution is to delete the animation that triggers the flip. Unless of course, you are a modder which non of you seem to be.

 

I fail to see how your post helps as I'm pretty sure people don't want to delete their running animations... Would you?

Also - yes - the culprit seems to be the animation, but it may well be xpms or unpb as they contain running animations (360 directional run).

Link to comment
I'm pretty sure people don't want to delete their running animations... Would you?

I suppose you'll have to rely on those temporal solutions then. So far I've seen no solutions. Did a quick search to get updated, still the same.

 

 

 

 

but it may well be xpms or unpb as they contain running animations

Huh? I don't recall XPMS and UNP/B containing running animations. Can you prove what you said?

Link to comment
  • 2 weeks later...

 

I'm pretty sure people don't want to delete their running animations... Would you?

I suppose you'll have to rely on those temporal solutions then. So far I've seen no solutions. Did a quick search to get updated, still the same.

 

 

 

 

but it may well be xpms or unpb as they contain running animations

Huh? I don't recall XPMS and UNP/B containing running animations. Can you prove what you said?

 

The UNPB body includes animations for BBP/TBBP. I just got this issue myself. I'm going to uninstall UNPB and use the other movement animation set to see if that fixes it, since it is an animation thing according to you.

 

Yes, UNPB gives you two options for your walk/run animations.

Link to comment

 

 

 

 

I'm pretty sure people don't want to delete their running animations... Would you?

I suppose you'll have to rely on those temporal solutions then. So far I've seen no solutions. Did a quick search to get updated, still the same.

 

 

 

 

but it may well be xpms or unpb as they contain running animations

Huh? I don't recall XPMS and UNP/B containing running animations. Can you prove what you said?

 

The UNPB body includes animations for BBP/TBBP. I just got this issue myself. I'm going to uninstall UNPB and use the other movement animation set to see if that fixes it, since it is an animation thing according to you.

 

Yes, UNPB gives you two options for your walk/run animations.

 

 

 

 

 

I'm going to uninstall

Holy crap, this problem hasn't been fixed yet? 

 

Anyways install the UNPB that doesn't include the animations. If you can't, stop using shi- uh, NMM and go for manual install. If you're using MO then good, just don't install the animations.

Link to comment
  • 2 weeks later...

I just had the same issue. After looking at this post http://www.loverslab.com/topic/15004-animation-problem-walk-animation-sprint-camera-bug/ I contacted the person who was kind enough to explain it's an animation issue where the camera isn't in the position where it should be. So I looked at my animations and saw I had Victorias High Heel Walk animation BBBB but hadn't installed the update. So if you have this animation http://www.nexusmods.com/skyrim/mods/25070/? make sure you install the update and re-run Fnis. It solved it for me.

Link to comment
  • 4 months later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use