Jump to content

Some animations line up but some don't


Recommended Posts

EDIT - Resolved. I needed to replace the idle. Beware of the idle from this mod https://www.nexusmods.com/oblivion/mods/33346

I am not sure what happened because I have used the mod before without problems. Currently some of my animations line up but others don't. And they are misaligned at such odd angles that the adjustment keys can't fix them

 

I tried reinstalling LAPF and starting a new game but still the same problem. Here are a few examples. As you can see one of the 4 are fine. It's so weird because I figure if I broke something it would break all the animations.

 

What could be causing this? ?

 

Load order

Active Mod Files:

 

00  Oblivion.esm
01  Lovers with PK.esm
02  LoversCreature.esm
03  CM Partners.esm
04  FOMO Main.esp
05  Unofficial Oblivion Patch.esp  [Version 3.5.4a]
06  UOP Vampire Aging & Face Fix.esp  [Version 1.0.0]
++  Oblivion Citadel Door Fix.esp
07  DLCShiveringIsles.esp
08  Unofficial Shivering Isles Patch.esp  [Version 1.5.8]
09  MigFTLtravel.esp
0A  MigMiscellanea.esp  [Version 1.9.1]
0B  DLCHorseArmor.esp
0C  DLCHorseArmor - Unofficial Patch.esp  [Version 1.0.8]
0D  DLCOrrery.esp
0E  DLCOrrery - Unofficial Patch.esp  [Version 1.0.6]
0F  DLCVileLair.esp
10  DLCVileLair - Unofficial Patch.esp  [Version 1.0.11]
11  DLCMehrunesRazor.esp
12  DLCMehrunesRazor - Unofficial Patch.esp  [Version 1.0.7]
13  DLCSpellTomes.esp
++  DLCSpellTomes - Unofficial Patch.esp  [Version 1.0.1]
++  MaleBodyReplacerV5.esp
14  VipCxj_HighHeels.esp
15  BreakArmor.esp  [Version 1.10.f]
16  tkRapiers.esp
17  BisSP_RHH_2.esp
18  VipCxjHHTest.esp
19  DLCThievesDen.esp
1A  DLCThievesDen - Unofficial Patch.esp  [Version 1.0.14]
1B  DLCThievesDen - Unofficial Patch - SSSB.esp  [Version 1.0.13]
1C  Apachii_Goddess_Store.esp
1D  DLCBattlehornCastle.esp
1E  DLCBattlehornCastle - Unofficial Patch.esp  [Version 1.0.12]
1F  DLCFrostcrag.esp
20  DLCFrostcrag - Unofficial Patch.esp  [Version 1.0.10]
21  Knights.esp
22  Knights - Unofficial Patch.esp  [Version 1.1.8]
23  AESWaitSleepNearerEnemies.esp
24  Oblivion Scaling Unclusterfucked.esp
25  LoversChorus.esp
26  LoversRaperS.esp
27  Lovers with PK.esp  [Version 96v5]
28  LoversCreature.esp
29  LoversMB2.esp
2A  Nudeshy X.esp
2B  PlayerSlaveEncounters.esp
2C  Alternative Start by Robert Evrae.esp
2D  SpellSinger.esp
2E  SetBody.esp
2F  FOMO Moments - A Pose Mod.esp
++  Specialanims.esp
30  Animation - Growlfs Body Resizing Mod.esp
31  VipCxj_HairEyeSet.esp
32  CM Partners.esp
33  Blood Elves.esp
34  CM Partners More NPCs.esp
35  Oblivion_Character_Overhaul.esp  [Version 2.0]
36  OCO v2 Balanced - Bonus Races Only.esp
37  VipCxj_Pose_Extend_System.esp
38  zConversion - Merged.esp
++  Replacer - Steel (mergeable).esp
++  Replacer - Blackwood (mergeable).esp
++  Replacer - Dwarven (mergeable).esp
39  GECK.O_Oblivion_MoreMales.esp
3A  DMRA BBB CC + AR Player Only v0.1.esp
3B  PlayerSlaveCry.esp
3C  zBUArmors.esp
3D  Bashed Patch, 0.esp
3E  LoversIdleAnimsPriority.esp
3F  LoversAnimObjectsPriority.esp

Elder Scrolls IV  Oblivion Screenshot 2021.04.02 - 12.09.47.55.png

Elder Scrolls IV  Oblivion Screenshot 2021.04.02 - 12.08.30.47.png

Elder Scrolls IV  Oblivion Screenshot 2021.04.02 - 12.06.58.70.png

Elder Scrolls IV  Oblivion Screenshot 2021.04.02 - 12.06.44.44.png

Edited by Art_B
Link to comment

If you installed or messed with animations then that is the cause.  The LAPF animations in the base mod do not have this issue.  While they may be "off" with regards to height (all animations were made for imperial height NPC's) they should not be off as per the pictures you have.  The pictures you have indicate that you have installed some animations that are not correctly matched up to offensive and defensive positions.  My suggestion would be to follow the install instructions for the LAPF upgrade and delete the entire Lovers animations folder prior to a fresh install of the LAPF.

Link to comment
2 hours ago, gregathit said:

If you installed or messed with animations then that is the cause.  The LAPF animations in the base mod do not have this issue.  While they may be "off" with regards to height (all animations were made for imperial height NPC's) they should not be off as per the pictures you have.  The pictures you have indicate that you have installed some animations that are not correctly matched up to offensive and defensive positions.  My suggestion would be to follow the install instructions for the LAPF upgrade and delete the entire Lovers animations folder prior to a fresh install of the LAPF.

I don't believe I did anything to the animations prior to encountering this. 


Where is the LAPF *upgrade*? The version I installed is the full 'LAPF - version 1.6a1.7z' from this website

 

Link to comment
57 minutes ago, Art_B said:

And by 'delete lovers animations' I take it that you mean everything in "meshes\characters\_male\Idleanims\ani2" correct?

 

If so, I did try this but no luck :classic_sad:

Yes.

Also delete the ini folder and reinstall it too.  Carefull however, as different lovers mods put stuff there.  If you just delete the numbered files and then reinstall them that should work.

 

When I said upgrade, I just meant the upgrade instructions for the LAPF.

Link to comment

Yes it used to be ok like what you haveabove. I am not sure what happened. ?

 

 

So I went back and  deleted both the animations folder and all numbered ini files. Then re-installed everything starting from step 1 in the sticky https://www.loverslab.com/topic/21241-lapf/

 

 

See bellow for the result. It's so weird some animations work fine but others don't. Example76 is still wrong but 124 is fine.

 

Overall I would say 4 out 5 animations are messed up now

 

 

Elder Scrolls IV  Oblivion Screenshot 2021.04.02 - 18.16.31.08.png

Elder Scrolls IV  Oblivion Screenshot 2021.04.02 - 18.20.26.51.png

Link to comment

76 is now right, you just need to use the adjustment keys to move the female character forward (0-9) at the top of the keyboard.  Moving it once will keep it in place for the rest of the game.

 

NOTE:  When you are on uneven ground or close to objects or walls, it can cause animations to be unaligned.  That is a normal with the game.  It is best to check stuff on a flat surface that is far from walls to check or fix unalignment.  

Link to comment
44 minutes ago, gregathit said:

76 is now right, you just need to use the adjustment keys to move the female character forward (0-9) at the top of the keyboard.  Moving it once will keep it in place for the rest of the game.

 

NOTE:  When you are on uneven ground or close to objects or walls, it can cause animations to be unaligned.  That is a normal with the game.  It is best to check stuff on a flat surface that is far from walls to check or fix unalignment.  

Is it really? Because when her hands are at her throat both his hands should be there too correct? But one of his hands are down low like in the next stage. And her legs should be closer together as shown in your screenshot.

 

Its seems like the animation stages themselves are somehow off. 

Link to comment

Upon further review, you are correct, your 76 is all messed up.  I just compared what is in the LAPF and what is in the Daedra Sutra and they are the same thing.  Something in your game is messing up animations.  It is rotating the defensive animations on an arc, plus the offensive one doesn't appear to be the same either.  Damned if I know what to tell you. 

 

 

Edit:  I just did a clean install of the LAPF with raperS and my 76 animation looks just like the screenshots from the Daedra Sutra.  There is some issue on your end.  Sorry that I can't be more helpful.

Link to comment
25 minutes ago, Art_B said:

Here is a more clear example. Motion 58 is way off and I don't believe the adjustment keys can fix it. This is using the default LAPF animations and ini and a new character.

Again, when I play animation 58 it looks just like the pictures in the Daedra Sutra.  Something has messed up your game.  I don't know what it is, but it is pushing animations around in odd ways.

Link to comment

It could be this: 

Animation - Growlfs Body Resizing Mod.esp or something like it. 

I'd recommend a clean start with just the LAPF and no other mods (don't use an existing save - make a new game) and you should be fixed. 

 

When you reinstall mods do it slowly and test things, being wary of any animation or skeleton mods as they can mess things up.

 

 

Link to comment

No worries, gregathit. I guess it's tough with an old game like this. I was just so hyped for the TES 6 announcement. I wanted to do one more Oblivion run with the new mods that have been out the last few years. I even wrote a new oblivion script for the first time in 5 years. ?

 

I'd dread a total re-install because I actually forgot where I kept my original copy of oblivion(I've moved) so I'd have to get my hands on another copy somehow. Also I have used Growlf's resizing for a few days before noticing errors but I did try uninstalling it too. Didn't help. :classic_sad:

 

Question: What do the fix bugs/animations spells do in LAPF? The only thing that I recall messing with on the day I ran into errors was using the spell to turn of collision settings and and then using the animation fix. I think now this is where the trouble started. Because why else would a few animations be fine while others are borked?

 

I have reinstalled everything as you said (default LAPF animations, esps, skeletons and inis), but could the spell have affected something else? Does it change a cache file somewhere?

Link to comment

The fix bugs spell just resets the 3d environment if things get borked in game.  Are collision settings still off?

As to why some animations are effected and not others......I don't have a clue. The whole thing is mind blowingly odd.  It is like something is jacking with the game physics.  But only doing it randomly.  I've never seen anything like that.  Generally it either works or it is broken.  

 

There are caches in saved games, but unless you use lovers backup, a new game should reset everything.  I'm at a total loss at what to tell you.  Is your load order still the same as the OP?  If so, maybe try removing other things to see if you can find a culprit.  I don't know what else to tell you.

1 hour ago, Art_B said:

I even wrote a new oblivion script for the first time in 5 years. ?

 

You have me beat.  I couldn't script my way out of a wet paper bag with sharp scissors.  ?

Link to comment
  • 2 months later...

Sorry to "necro" but I'm having this exact issue due to recently trying to edit and export an Idle.kf animation that for some reason causes poses during sex events to be misaligned.

I'm saying this issue could be caused due to a recent pose file that replaced your previous default.

Link to comment
  • 1 month later...
On 7/2/2021 at 1:20 AM, LostData751 said:

Sorry to "necro" but I'm having this exact issue due to recently trying to edit and export an Idle.kf animation that for some reason causes poses during sex events to be misaligned.

I'm saying this issue could be caused due to a recent pose file that replaced your previous default.


Thanks! Sorry I was away from the site for a while but this was the problem. I was using the idle from princesswalk on nexusmods. I replaced it with another idle and that fixed it. Thank you and also thanks to gregathit for helping :)

Edited by Art_B
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use