Jump to content
IGNORED

I keep getting conflicting sim animation rig fatal error


Recommended Posts

As the title says I keep getting this fatal error

xV2O3Eo.png

I've done everything mentioned on Penis-issues link

I deleted files that i think it could conflict with Wickedwhims as Better Body by hiroki (although this one never gave me issues) but I dont have any rig mod. I searched "rig or animated" as said but I dont have nothing about it.
maybe could be the sex animations i have? Since I downloaded every sex animation even from retired and veteran animators but I dont know honestly, never had any issue with them but not since the latests versions of WW.

May be the merman hair physics mod ? because I dont any animated wings or something. 

 

Link to comment

Some of these older animations might be outdated, but I don't know for sure. You can also try moving the one you're suspecting out of your Mods folder, as maybe it's the one causing the issue.

If it isn't, although it's a bit tedious, I'd recommend you remove EVERYTHING (cut and paste it somewhere else) from your Mods folder except for WW, and if you have them Basemental Drugs, Nisa's Wicked Pervs, MCCC and any of ColonelNutty's mods. I can confirm that these do not cause rig issues, so when you start the game, everything should be fine. If it isn't, re-download these mods and try again.

Now for the "tedious" part: The (in)famous 50/50 method. Half of your other mods (that you pasted to Desktop or some other location) go into the Mods folder, half stay out and you launch the game again. If you get the issue again, swap halves and check again - just to be sure that there aren't mods causing the issue in both groups. Now, narrow down the culprit by adding half of what's left into Mods as well, and so on, and so on...until all but one of your mods are back in the Mods folder. That final mod is probably the reason for your issue and if you add it to Mods, you should see the issue again. Once you've found that one, delete it (and maybe notify the mod creator of the issue).

In some (usually very rare) cases, there can be more than one mod causing a problem. If that happens, you will most likely face a situation, where both halves of the "mods you haven't confirmed to be good" contain one or more of them, so swapping halves won't do anything. In that case, you'll have to work through both halves individually - but that only ever happened once to me.

Link to comment
4 hours ago, Crashdown117 said:

Some of these older animations might be outdated, but I don't know for sure. You can also try moving the one you're suspecting out of your Mods folder, as maybe it's the one causing the issue.

If it isn't, although it's a bit tedious, I'd recommend you remove EVERYTHING (cut and paste it somewhere else) from your Mods folder except for WW, and if you have them Basemental Drugs, Nisa's Wicked Pervs, MCCC and any of ColonelNutty's mods. I can confirm that these do not cause rig issues, so when you start the game, everything should be fine. If it isn't, re-download these mods and try again.

Now for the "tedious" part: The (in)famous 50/50 method. Half of your other mods (that you pasted to Desktop or some other location) go into the Mods folder, half stay out and you launch the game again. If you get the issue again, swap halves and check again - just to be sure that there aren't mods causing the issue in both groups. Now, narrow down the culprit by adding half of what's left into Mods as well, and so on, and so on...until all but one of your mods are back in the Mods folder. That final mod is probably the reason for your issue and if you add it to Mods, you should see the issue again. Once you've found that one, delete it (and maybe notify the mod creator of the issue).

In some (usually very rare) cases, there can be more than one mod causing a problem. If that happens, you will most likely face a situation, where both halves of the "mods you haven't confirmed to be good" contain one or more of them, so swapping halves won't do anything. In that case, you'll have to work through both halves individually - but that only ever happened once to me.


I've done this like 20 times and is a pain in the ass so I posted this thread :(

Link to comment
1 hour ago, Maxwell47 said:


I've done this like 20 times and is a pain in the ass so I posted this thread :(

It's the "merman hair physics mod" - Remove it as it will conflict with the WW built in rig.

- I know this cause i remember somebody else had the same issue a while ago.

Also, you should remove the Better Body stuff= outdated.

And don't forget to Delete the "localthumbcache.package" in your "Documents > Electronic Arts > The Sims 4" folder.

You should always delete that file if you add/delete anything from your Mods folder.

stay healthy. ?

Link to comment
  • 4 months later...
  • 1 year later...
  • 5 weeks later...
  • 2 months later...
  • 1 month later...
2 hours ago, apetor97 said:

Hi guys, sorry for late comment, but I have the same issue, but I don't have Lv Furry in my mods folder, what can be a cause of this error?

Same problem here without the Lv Furry. Already deleted ALL the mod i had installed and just installed the MC and the Basemental Drugs. 

Link to comment
On 2/19/2022 at 7:43 PM, Shily said:

Same problem here without the Lv Furry. Already deleted ALL the mod i had installed and just installed the MC and the Basemental Drugs. 

 

 

Luckily, I fixed my problem. If you have Azmodan22 animations, just delete them, animations rig is the main problem and probably Azmodan22 animations caused it. If it worked for me, it can work for you as well, because you have the same problem.

Link to comment
  • 4 weeks later...
On 2/21/2022 at 1:17 PM, apetor97 said:

 

 

Luckily, I fixed my problem. If you have Azmodan22 animations, just delete them, animations rig is the main problem and probably Azmodan22 animations caused it. If it worked for me, it can work for you as well, because you have the same problem.

also be careful for any denton47 rigs. they conflict

Link to comment
  • 1 month later...

i have no animations for wicked whims, i just have the script file and tunning file installed, and when i launch the game it is still telling me there is a fatal error with a rig animation. but like i said, i have non installed. not sure what else to do 

Link to comment
  • 2 weeks later...
On 4/2/2020 at 11:37 AM, Maxwell47 said:

As the title says I keep getting this fatal error

xV2O3Eo.png

I've done everything mentioned on Penis-issues link

I deleted files that i think it could conflict with Wickedwhims as Better Body by hiroki (although this one never gave me issues) but I dont have any rig mod. I searched "rig or animated" as said but I dont have nothing about it.
maybe could be the sex animations i have? Since I downloaded every sex animation even from retired and veteran animators but I dont know honestly, never had any issue with them but not since the latests versions of WW.

May be the merman hair physics mod ? because I dont any animated wings or something. 

 

Have you tried updating your sims 4 game + updating the mod itself/updating MC command center? Also, i would suggest creators that are more active because i also have had that issue before

Link to comment
On 8/12/2020 at 2:44 PM, Tinypanman said:

Hi, i've had issues with the "rig" error. i've deleted EVERYTHING. Ww, animations, dumbaby body..ect. I've had WW by itself, done everything it said. But the error still pops up in game, and it's getting on my nerves! Help!

also i fixed this, i think i needed to update the mod

Link to comment
  • 1 month later...
On 2/21/2022 at 12:17 PM, apetor97 said:

 

 

Luckily, I fixed my problem. If you have Azmodan22 animations, just delete them, animations rig is the main problem and probably Azmodan22 animations caused it. If it worked for me, it can work for you as well, because you have the same problem.

I came here for the same error and this just save me, thank you so much!

Link to comment
  • 3 weeks later...

For me it was Devious Desires that was causing the "RIG CONFLICT" issue. Moved all the files for DD out of the Mods folder and no more errors. Didn't even use DD to begin with, had no idea what it was. 

 

Man! I should really curb my mod downloading strategy, end up downloading everything and not using much at all. 😋

Link to comment
22 hours ago, scarletzoe12 said:

i keep getting wicked whims is sad rig" error

There should be a button in that notification that takes you to the page on WickedWhims website, which explains how to get rid of that issue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...