Jump to content

Question regarding NIF block order


Alphaman

Recommended Posts

Hello everyone. I'm hoping I'm posting in the right place, since the mod I'm trying to make work is an adult one and all. Scroll down for a TL;DR version below
 
Here is the rundown: I've been trying to correct a weight problem in the Black Puppet armor (seen here http://imgur.com/aLNhYPq)

 

After reading a few things and spending a few hours around 3ds Max I've been able to successfully correct the problem. However, I could have used at least one less hour if I knew that the 3ds Max NIF Importer/Exporter plugin by figment (http://skyrim.nexusmods.com/mods/5622) messed around with the order of the NiTriShape blocks on .nif files

 

For some reason, either the import or the export procedure causes these attributes to change positions in the resulting .nif file (as seen here http://imgur.com/JLr4lwY, also here is the original file http://imgur.com/vawzj8f). The first NiTriShape block becomes the last, the second becomes the penultimate, etc. This wouldn't cause me any trouble at all, except for the game CTDing when I try to use these models. The thing is, everything seems to be in its place

 

All the blocks and references to blocks that I find seem to point to the right places, they have simply been reordered as far as I could see; yet, a CTD would happen. I tried importing the *_0.nif file too because I thought the *_0 and *_1 files needed the blocks in the same places to work correctly, but to no avail as it still CTD'd. After re-importing and exporting the inverted-order .nif file, all blocks switched place again, regaining their proper order, and the game read the model properly, so I didn't bother much

 

Anyway, I have since been trying to make a higher quality import of the Black Puppet armor. I've already adjusted most of it to a new body, but testing so far has resulted in CTDs. So I started to wonder if the block order could be the reason. I've searched a very good deal of websites for an answer but found none

 

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

My question, if anyone knows the answer, is if there's a proper order that different parts of the armor need to follow in a .nif file

 

If not, and in case someone has a guess as to why the CTDs happened after the "inversion", I uploaded an original file (http://www.mediafire.com/?p8ur8inpt9lcc99) and its inverted version (http://www.mediafire.com/?2ycgtdsux02dsuv) so that you may look for yourself. Also, here is the complete package (meshes + textures http://www.mediafire.com/?xpdds185u7vwc9q) in case you want to see how all the textures and stuff fits

 

Thank you in advance for your time

Link to comment

I've never encountered CTD issues after changing the order of the parts of an armor.

There is no "right order", unless the textures are assigned in the esp file.

Keep in mind that the order between _0 and _1 files must match or the weight slider will be a mess.

 

I don't see anything wrong in your nif file. Can you upload the entire archive that CTDs your game? with broken meshes and esp file. So I can test it ingame.

Link to comment

Thank you for your reply. I thought it was very weird as well, but couldn't rule out the possibility that the body needed to come first, or something along those lines.

 

It would be a bit hard to upload it all, as I used the Black Puppet armor included in the Full ANK Castle mod. Give me a few minutes, I'll open up the CK and export the bits that matter to a separate ESP

 

---------------------------------

EDIT

---------------------------------
 

Here it is. Took longer than I thought http://www.mediafire.com/?cy04r2z9tfg896g. Use it together with the complete mesh+texture package in the first post

 

To get the armor you can use the additem command with the code 27000D6A

 

The icecuirass_00.nif and icecuirass_11.nif files are the original ones, and won't cause a CTD. The icecuirass_0.nif and icecuirass_1.nif are the inverted-order ones, and will cause a CTD

Link to comment

I didn't do any modifications at all. And that order change just happens, and I don't know why

 

I do have a BBP compatible skeleton, but not in that \_1stperson\ folder. But can that really be the problem? I mean, with the original order the file works just right, for some reason. Wouldn't it crash even with the "right" order if the lack of compatible skeleton was the reason?

 

I'll try it now, anyway. Will copy the skeleton to that folder and try again

Link to comment

I'm not sure that will work, the 1st person skeleton is not the same as the skeleton_female.nif

I'm using the files from the UNPB mod (v2.2)

 

In my case, the order in the nif file is the inverse order I select each part in 3ds before export.

For example, if I want the body 1st, I select 1st the armor, then the body, then "export selected"

Also in NifSkope you can rearange the order. I do this with copy-paste the nodes, don't know a better way

Link to comment

I... I did what you told me to. And it worked. But why?! I'm even more confused now

 

The 1st person model is pointing at the cuirass .nif regardless of the order of the NiTriShape blocks, so why would one of the orders work perfectly fine and an altered order need a BBP compatible 1st person skeleton? I'm really, really confused. God...

 

Regardless, you figured it out. I guess figuring why things go wrong isn't as important as figuring how to make them work, anyway. So thank you very much for your time and help in this matter

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use