Jump to content

Animations not loading into FNIS or SexLab


Recommended Posts

So, I've been trouble shooting this for the past 2 days and I can't figure out what is going wrong here. It would appear as though MNC ( More Nasty Critters ) animations aren't "baking" in FNIS as in they do not appear in the output under creatures. as well when I am in game HCoS animations work just fine, playing as they should but when I try to use MNC animations characters just stand there, the same problem that I hear is caused by FNIS. I have ran the tool for users many times now, uninstalled and reinstalled the mod, through a manager as well as manually, doing everything in my power to try and understand the problem but nothing seems to work. any help would be much appreciated. it apears as though all other animations I have installed ( HCoS, SexLab Creatures, SexLab Default, SexLab Defeat, etc. ) all work as they should. MNC is my only problem.

 

If someone could enlighten me on how FNIS loads animations and behaviors that would be awesome as well. maybe I can troubleshoot a missing file.

 

On a side note I am also experiencing issues with solo animations not beginning, on the player or otherwise

Link to comment
6 minutes ago, Funnyman2214 said:

So, I've been trouble shooting this for the past 2 days and I can't figure out what is going wrong here. It would appear as though MNC ( More Nasty Critters ) animations aren't "baking" in FNIS as in they do not appear in the output under creatures. as well when I am in game HCoS animations work just fine, playing as they should but when I try to use MNC animations characters just stand there, the same problem that I hear is caused by FNIS. I have ran the tool for users many times now, uninstalled and reinstalled the mod, through a manager as well as manually, doing everything in my power to try and understand the problem but nothing seems to work. any help would be much appreciated. it apears as though all other animations I have installed ( HCoS, SexLab Creatures, SexLab Default, SexLab Defeat, etc. ) all work as they should. MNC is my only problem.

 

If someone could enlighten me on how FNIS loads animations and behaviors that would be awesome as well. maybe I can troubleshoot a missing file.

 

On a side note I am also experiencing issues with solo animations not beginning, on the player or otherwise

Okay, a few things you should check on.

 

1: Sexlab doesn't load it's creature module by default when it installs. Go into Sexlab's MCM menu under Animation settings and make sure the Creature Animations are active.

2: MNC falls under Sexlab Animation Loader, so there is a sequence to this. When first starting, activate Sexlab, then activate Sexlab's Creature module, then select the MNC animations you want in the SLALoader MCM menu, then click "Register Animations" in it's main section. It must be done in this order, or the animations won't fire correctly.

3: If none of that works, check under Data/Meshes/Actors/Character/Behaviors for a file called FNIS_MoreNastyCritters_Behavior.hkx. If this file is missing, or if FNIS is throwing warnings when you run it, post the results here.

Link to comment
2 minutes ago, Adviser69 said:

Okay, a few things you should check on.

 

1: Sexlab doesn't load it's creature module by default when it installs. Go into Sexlab's MCM menu under Animation settings and make sure the Creature Animations are active.

2: MNC falls under Sexlab Animation Loader, so there is a sequence to this. When first starting, activate Sexlab, then activate Sexlab's Creature module, then select the MNC animations you want in the SLALoader MCM menu, then click "Register Animations" in it's main section. It must be done in this order, or the animations won't fire correctly.

3: If none of that works, check under Data/Meshes/Actors/Character/Behaviors for a file called FNIS_MoreNastyCritters_Behavior.hkx. If this file is missing, or if FNIS is throwing warnings when you run it, post the results here.

I've gone through the process multiple times, Creature Animations is indeed active as the box is checked and HCoS works.

I've gone through the sequence of disabling all, rebuilding the registry, resetting the JSON, enabling all, and registering the animations [139 animations registered] pops up at the end.

and looking through the file structure FNIS_MoreNastyCritters_Behavior.hkx is indeed there but my FNIS ouput doesn't reflect it.

FNIS Behavior V7.4.5 XXL   12/15/2018 5:28:57 PM
Skyrim SE 64bit: 1.5.62.0 - E:\SteamLibrary\steamapps\common\Skyrim Special Edition\ (Steam)

Skeleton(hkx) female: Default (99 bones)   male: Default (99 bones)
Patch: "GENDER Specific Animations" 
Patch: "SKELETON Arm Fix" 

Reading DD V4.0.0  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 493 alternate animations) ...
Reading DD2 V4.0.0  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 330 alternate animations) ...
Reading DD3 V4.1.0  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 102 alternate animations) ...
Reading DDSL V4.0.0 ...
Reading Defeat V5  ( 0 furniture, 2 offset, 3 paired, 1 kill, 0 chair, 0 alternate animations) ...
Reading FHU V1.00 ...
Reading FNISBase V7.4.5 ...
Reading FNISCreatureVersion V7.0 ...
Reading FNISSpells V5.0.1  ( 0 furniture, 0 offset, 9 paired, 0 kill, 0 chair, 0 alternate animations) ...
Reading HCOSBestiality V1.0 ...
Reading HCOSVore V1.0 ...
Reading SexLab V1.63 ...
Reading SexLabAP V1.63 ...
Reading SexLabAroused V2.9 ...
Reading SexLabCreature V1.63 ...
Reading ZaZAnimationPack V7.00  ( 26 furniture, 29 offset, 0 paired, 0 kill, 0 chair, 0 alternate animations) ...

All Anim Lists scanned. Generating Behavior Files...
No GENDER directory male
No GENDER directory female
Alternate Animation mods: 3 sets: 42 total groups: 252 added file slots: 1998 alternate files: 925

Create Creature Behaviors ...
Reading HCOSWildlife V1.0 ...
Reading HCOSBestiality V1.0 ...
Reading SexLabCreature V1.63 ...
Reading HCOSVore V1.0 ...

 3594 animations for 16 mods successfully included (character)
 1104 animations for 4 mods and 28 creatures successfully included.

 0 possible consistence issues

I would expect it to be near "Create Creature Behaviors"

Link to comment
2 minutes ago, Funnyman2214 said:

I've gone through the process multiple times, Creature Animations is indeed active as the box is checked and HCoS works.

I've gone through the sequence of disabling all, rebuilding the registry, resetting the JSON, enabling all, and registering the animations [139 animations registered] pops up at the end.

and looking through the file structure FNIS_MoreNastyCritters_Behavior.hkx is indeed there but my FNIS ouput doesn't reflect it.


FNIS Behavior V7.4.5 XXL   12/15/2018 5:28:57 PM
Skyrim SE 64bit: 1.5.62.0 - E:\SteamLibrary\steamapps\common\Skyrim Special Edition\ (Steam)

Skeleton(hkx) female: Default (99 bones)   male: Default (99 bones)
Patch: "GENDER Specific Animations" 
Patch: "SKELETON Arm Fix" 

Reading DD V4.0.0  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 493 alternate animations) ...
Reading DD2 V4.0.0  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 330 alternate animations) ...
Reading DD3 V4.1.0  ( 0 furniture, 0 offset, 0 paired, 0 kill, 0 chair, 102 alternate animations) ...
Reading DDSL V4.0.0 ...
Reading Defeat V5  ( 0 furniture, 2 offset, 3 paired, 1 kill, 0 chair, 0 alternate animations) ...
Reading FHU V1.00 ...
Reading FNISBase V7.4.5 ...
Reading FNISCreatureVersion V7.0 ...
Reading FNISSpells V5.0.1  ( 0 furniture, 0 offset, 9 paired, 0 kill, 0 chair, 0 alternate animations) ...
Reading HCOSBestiality V1.0 ...
Reading HCOSVore V1.0 ...
Reading SexLab V1.63 ...
Reading SexLabAP V1.63 ...
Reading SexLabAroused V2.9 ...
Reading SexLabCreature V1.63 ...
Reading ZaZAnimationPack V7.00  ( 26 furniture, 29 offset, 0 paired, 0 kill, 0 chair, 0 alternate animations) ...

All Anim Lists scanned. Generating Behavior Files...
No GENDER directory male
No GENDER directory female
Alternate Animation mods: 3 sets: 42 total groups: 252 added file slots: 1998 alternate files: 925

Create Creature Behaviors ...
Reading HCOSWildlife V1.0 ...
Reading HCOSBestiality V1.0 ...
Reading SexLabCreature V1.63 ...
Reading HCOSVore V1.0 ...

 3594 animations for 16 mods successfully included (character)
 1104 animations for 4 mods and 28 creatures successfully included.

 0 possible consistence issues

I would expect it to be near "Create Creature Behaviors"

Okay then, let's take another route. This definitely helped to narrow it down. In a quote box, could you post your mod load order? Also, check your data folder for a folder labled "SLAnims". In this folder, check the json and souce folders for files with the MoreNastyCritters in the title, MoreNastyCritters.json and MoreNastyCritters.txt respectively.

 

Link to comment
9 minutes ago, Adviser69 said:

Okay then, let's take another route. This definitely helped to narrow it down. In a quote box, could you post your mod load order? Also, check your data folder for a folder labled "SLAnims". In this folder, check the json and souce folders for files with the MoreNastyCritters in the title, MoreNastyCritters.json and MoreNastyCritters.txt respectively.

 

SLAnims: Exsists
  Json: MoreNastyCritters.json [√]

  Source: MoreNastyCritters.txt [√]

 

Quote

SexLab.esm

SexLabAroused.esm

CreatureFramework.esm

ZaZAnimationPack.esm

SkyUI.esp

UIExtensions.esp

FNISspells.esp

FNIS.esp

SexLabTools.esp

HentaiCreatures.esp

MoreNasyCritters.esp

SexLab More Creatrues.esp

SexLab Aroused Creatures.esp

HornyCreatures.esp

SexLabMatchMaker.esp

SLAnimLoader.esp

SexLabDefeat.esp

 

Link to comment
3 minutes ago, Funnyman2214 said:

I'm using NMM for my manager and I did see the tools folder and grabbed the two files from that. one was a perfect copy of one already in there and the other was new. it hasn't changed anything thus far

Ah I see. In that case, tedious though it may be, I would go through all the contents of the zip file and make sure they're in your game folder. Some MOs, including NMM, are notorious for not thoroughly copying the contents of a mod file over to the game folder. I use BAIN/Wrye Bash myself, which is semi-manual.

Link to comment

OKAY! so instead of doing that.... I said screw it and manually installed it. backing up my "data" folder first. FNIS SAW IT! so, as the mod author says, MMs lie. soooo, I believe that's my problem. thank's for the sanity checking and trouble shooting. it was a big help on the road to actually figuring out what the hekk is going on here.

 

In the end that worked. the solution was to manually install the animations to the Data directory.

 

Should I create another topic to address the whole solo animations thing?  

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use