Jump to content
IGNORED

Bodyslide failed to load Setup.xrc


Recommended Posts

Are you just overwriting the previous version or are you actually uninstalling it FIRST and then installing the current version? If you're just overwriting, I strongly suggest you don't do that. Always uninstall the old version first and then install the new version - it's cleaner that way. If you've been overwriting all this time, you'll probably have to manually delete the old version to make sure you've gotten rid of all the old application files. MAKE SURE you don't delete your SliderPresets, SliderGroups, ShapeData, SliderSets, SliderCategories and ConversionSets folders.

 

After you install the new version, launch the GAME with the default STEAM launcher and then exit BEFORE you run BodySlide for the first time. This will update the game's registry, which BodySlide uses in it's setup process.

Link to comment

I'm pretty sure I did all of that in that order already but I'm giving it another shot. I started with uninstalling Bodyslide and deleting it, or as much as NMM deletes it, though I'm pretty sure I had done that when I updated. I re-downloaded and installed bodyslide, closed nexus, then launched Fo4 though steam. Do I stop at the launcher? I launched the game completely, even loaded an unmodded save file. I closed the game then launched nexus again and tried bodyslide. Still getting the error. :(

 

 

Link to comment

Ohhhh my god, I discovered the problem. Something messed up at some point, I don't if it just downloaded and installed like this or whatever. The point being, the only thing that actually downloaded was the executables. All of the folders in bodyslide were empty everything was missing. I thank you all for trying to help me anyway. ^_^

Link to comment
  • 4 months later...

i had the same problem actually. if you take a look in your bodyslide folders i bet they are empty :) but i found a post which helped me. when you have the same issue like i had you just have to open your mod manager as administrator then you can uninstall and reinstall bodyslide again and it will install the files properly. when you then open bodyslide everything should be there (you should also reinstall CBBE as administrator before bodyslide)

Link to comment
  • 1 month later...

i had the same problem actually. if you take a look in your bodyslide folders i bet they are empty :) but i found a post which helped me. when you have the same issue like i had you just have to open your mod manager as administrator then you can uninstall and reinstall bodyslide again and it will install the files properly. when you then open bodyslide everything should be there (you should also reinstall CBBE as administrator before bodyslide)

 

 

That still doesn't work and i am using the latest version. i aslo tried running NMM as Administrator, still nothing.

Link to comment
  • 1 month later...
  • 2 weeks later...

I had the same issue with NMM and newest bodyslide.

 

Seems NNM will write protect folders/files of mods that got overwritten by other mods or are connected in some way with other mods.

In the case of Bodyslide there is a massive amount of bodyfiles of armor mod, devious mod and body mod files, that are all connected to bodyslide folder via NMM, hence the folder/files will be write protected.

 

To solve the issue i just deinstalled (not deactivated, not deleted) all mods in NMM and reinstalled bodyslide.

THAT WORKED =D

 

Theoretical, to reinstall bodyslide, it should be enough if you only deinstall all bodyslide connected mods.

With my devious UUNP Setup that would be half of my mods anyways ^^

 

Hope that helps, good luck!

 

Edit: just saw this is for Fallout, i use NNM for Skyrim, but the bodyslide warning "failed to load setup.xrc" is the same, maybe the solution will be the same

 

Link to comment
  • 1 year later...

One other error that can cause bodyslide to not open in Mod Organiser 2 that you can make when installing a new version and running via MO2. Make sure you get the shortcuts correct for the binary and the folder. If you just select the Mod Organiser top level folder for Bodyslide you will get the same "failed to load Setup.xrc" error you need to make sure your start in folder is the one with the bodyslide 64.exe in it.

Link to comment
  • 1 month later...

Hi. I also had this issue with the setup.xrc. The way it was solved was i had to create a link to the desktop via Mod Organizer and then run that as an Admin. Its a kinda akward way but it works for me now.

Link to comment
  • 6 months later...
On 10/16/2018 at 4:45 AM, AntBob said:

One other error that can cause bodyslide to not open in Mod Organiser 2 that you can make when installing a new version and running via MO2. Make sure you get the shortcuts correct for the binary and the folder. If you just select the Mod Organiser top level folder for Bodyslide you will get the same "failed to load Setup.xrc" error you need to make sure your start in folder is the one with the bodyslide 64.exe in it.

This! I tried several of the other fixes, and nothing was working. I forgot to set the folder when I moved computers, thank you!

Link to comment
  • 1 year later...

Yep, any other ideas?

 

Also get the "Setup"-Error. Yet I didn't change anything since the last time using Bodyslide. When I start it through MO everything seems to be just fine: PC working, MO gets "locked", I see Bodyslide in the Task Manager. But that's it. No Bodyslide opening. I get the error only when trying to start Bodyslide again.

Nothing seems to work, no reinstalling, executing as an admin a.s.o.

 

 

Edit:

Ok, got it to work somehow: Just installed/unpacked BodySlide manually into the game's data-folder. Then installed it a second time via MO2. Then I renamed the .exe in the MO2-dictionary into "..._orig" (just to make sure I keep them), made a link to those in the game's data-folder, put it into the MO2-BS-folder and changed their names to the normal Bodyslide.exe (same for OutfitStudio). In MO2 I added the renamed "Link"-Exes to the list on the top right. So basically when I start BS and/or OS via MO2 it thinks it opens the one in it's own dictionary but in fact openes the one in the data-folder.

(Yes, just adding the one in the data-folder to MO2 didn't work.)

Maybe this helps others with the same problem.

Link to comment
  • 1 year later...
On 10/16/2018 at 7:45 AM, AntBob said:

One other error that can cause bodyslide to not open in Mod Organiser 2 that you can make when installing a new version and running via MO2. Make sure you get the shortcuts correct for the binary and the folder. If you just select the Mod Organiser top level folder for Bodyslide you will get the same "failed to load Setup.xrc" error you need to make sure your start in folder is the one with the bodyslide 64.exe in it.

does it have to be the folder or does it need to be the executable

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...