Jump to content

CK Compiler gives only errors


Xylcore

Recommended Posts

Hey there,

 

i hope I'm posting in the right section. It's my first post so far, even though I've been registered for a while now.

 

I wanted to add these animations to FNIS, so I followed the instructions posted here.

I used the FNIS_SexLab_Creatures.txt file to add the animations and then edited the sslCreatureAnimationDefault.psc to add them to the script.

First I got errors, because the CK couldn't find the flags file, so I downloaded it here and placed it. Everything was fine.

So as I compiled I got a bunch of errors again, saying that the variables cannot be used in the same function twice (by default, there often was declared the a1 variable for two positions in one function). So I changed the variables to get rid of these errors. That was fine aswell. But as soon as I compiled again, the CK gave me hundreds of errors saying it was unable to locate the script quest, there's an unkown type actor and many more.

 

I have only low knowledge in scripting for Skyrim, but since I'm programming with C++ and VB in my free-time, I'm known to the scripting itself.

 

I don't know why there are so many errors, but since the script worked before and had to be compiled recently, I guess it has something todo with the flags file?

 

Here is an example of one animation I tried to implement:

function BillySkeeverDoggy(int id)
sslBaseAnimation Base = Create(id)
Base.Name = "BillySkeeverDoggy"
; Base.RaceType = "Skeever"
Base.SoundFX = Squishing
int a1 = Base.AddPosition(Male)
Base.AddPositionStage(a1, "Skeever_BillyyDoggy_A1_S1", 0, up = 0)
Base.AddPositionStage(a1, "Skeever_BillyyDoggy_A1_S2", 0, up = 0)
Base.AddPositionStage(a1, "Skeever_BillyyDoggy_A1_S3", 0, up = 0)
Base.AddPositionStage(a1, "Skeever_BillyyDoggy_A1_S4", 0, up = 0)

int a2 = Base.AddPosition("Skeever", CreatureMale)
Base.AddPositionStage(a2, "Skeever_BillyyDoggy_A1_S1", 0, up = 0)
Base.AddPositionStage(a2, "Skeever_BillyyDoggy_A1_S2", 0, up = 0)
Base.AddPositionStage(a2, "Skeever_BillyyDoggy_A1_S3", 0, up = 0)
Base.AddPositionStage(a2, "Skeever_BillyyDoggy_A1_S4", 0, up = 0)
Base.Save(id)
endFunction

Registered with

RegisterAnimation("BillySkeeverDoggy")

I had the same problem with those errors with other scripts I tried to compile. Does someone know what kind of problem it could be and how I can solve it?

 

Kind regards

 

Link to comment

Try to compile and then copy the error log. Paste it here in a spoiler.

It may have clues about what is wrong.

 

Did you unzipped the scripts.rar archive? And overwrite all files with the ones provided by SKSE?

Link to comment

Try to compile and then copy the error log. Paste it here in a spoiler.

It may have clues about what is wrong.

 

Did you unzipped the scripts.rar archive? And overwrite all files with the ones provided by SKSE?

 

I didn't even know that the scripts.rar archive is important for this...I have unzipped the archive and also found a post of yours by searching for this archive in connection with my problem:

http://www.loverslab.com/topic/45100-how-to-solve-compile-problems-after-latest-ck-update-from-steam/

 

Man, you're a wizard. I'm having this error since weeks and you're solving it in seconds :D If you didn't told me, I wouldn't have found that post ever.

 

After these steps, the compile was successful.

 

Thank you very much!

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...