Jump to content

Oblivion Steam Ed + all DLC, OBSE 0021 Can they be made to work?


Recommended Posts

EDIT:  GOT THIS SORTED: THANKS TO ALL WHO CONTRIBUTED!

 

 

===========================================

 

EDIT:  THE SOLUTION TO MAKING OBLIVION Steam Ed, OBSE. and MOD ORGANIZER WORK TOGETHER is as follows:


NOTE THAT ALL OBSE PLUGINS MUST BE INSTALLED DIRECTLY INTO YOUR STEAM GAME'S OBLIVION/DATA/OBSE/PLUGINS FOLDER.  YOU CANNOT RUN THEM FROM WITHIN MO USING THIS GAME STARTUP METHODOLOGY


1 - Install the latest version of OBSE as per its installation instructions, ie .dlls in Steam's Oblivion Folder (ie where Oblivion.exe and OblivionLauncher.exe is located) and OBSE folder with .ini file in the DATA directory

2 - Open MO.  (I am using 1.2.18 - I know that's old, but i read elsewhere that later versions didn't like this solution, although I haven't tried those)

3 - In MO, click on the Spanner and Screwdriver icon at the top to open up 'Settings'

4 - Open the 'Workarounds' tab

5 - The Load Mechanism will show 'Mod Organiser'.  Click on the box drop down and CHANGE THAT TO 'SCRIPT EXTENDER'

6 - Close MO and re-open it

7 - Open STEAM

8 - Navigate to your Oblivion page in your Games Library    

9 - Press the blue '>PLAY' button

10 - The STEAM LAUNCHER BOX will open, with the options 'Play, Data Files, Options, Elderscolls.com, Technical Support, Uninstall, Exit'

11 - Click on 'Play'

12 - The game will launch

13 - if you have OBSE Tester, http://www.nexusmods.com/oblivion/mods/33574/?, running, this will report that OBSE is now running, and which version you have installed

14 - OBSE dependent mods should now start properly - ie without 'No OBSE' errors .... BUT REMEMBER THAT ALL OBSE PLUGINS MUST BE INSTALLED DIRECTLY INTO YOUR STEAM GAME'S OBLIVION/DATA/OBSE/PLUGINS FOLDER.  YOU CANNOT RUN THEM FROM WITHIN MO USING THIS GAME STARTUP METHODOLOGY

FWIW, I also have MO set NOT to close when any binary is run.  Don't know if it would make any difference not to, but this works so I'll stick with it  LOL

I take no credit for this solution

That goes to GSDFan, who wrote it up on STEP at
http://forum.step-project.com/topic/8011-double-launcher-when-running-through-mo/page-2

My own notes above are only intended as a slightly less techie explanation of the process for illiterates such as myself :-)

Hope this is of help to someone

 

===========================================

 

 

 

============================================

 

I have an old non Steam Oblivion game that works OK, but the LL Mods are all ancient versions

 

So I installed the Steam Version + all DLC

 

I added OBSE 0021 right at the outset, manually added to the main Oblivion directory in Steam, ie the .dlls and the OCSE folder into the main 'data, folder 

 

I then used Mod Organizer(MO) to manage the mods installed, with any omods installed through Oblivion Mod Manager, the resultant files appearing in MO's 'overwrite' and being made into MO Mods that way

 

I managed to install all the basic Nexus, and MBP mods, just fine and got to the point where I had a fully functioning save just prior to the Imperial Prison exit, and last chance character change

 

As an afterthought I added in the 'Thieves Arsenal' mod and at that point, when loading my save, the game threw a wobbly and said that OBSE wasn't running

 

So I tried installing LAPF v1.61a and that too refused to load, saying OBSE wasn't running

 

The OBSE test esp mod also confirms OBSE to be non functional

 

I have, with no success, tried....

 

1 - tried replacing OBSE v0021 with the v0020 version that works fine on my non Steam game, although I don't have the version of obse_steam_loader.dll included there, it not being necessary and the original archive having vanished in my last HD bereavement - that game launches from fine directly from obse_loader.exe

 

2 - running the game through MO from the main Steam game directory via Oblivion.exe file, as well as via obse_loader.exe

 

3 - tried running the game from directly from obse_loader.exe - which fails as expected

 

4 - making every .exe file involved 'Run as an Administrator' all the way down the chain from Steam.exe

 

5 - checking the 'Enable the Steam Overlay while in-game' setting option for every game in my Steam library, and that in the Main Settings section too.  This is supposed to be set for the OBSE to be kicked off properly, but when the game is running at the main menu, the Shift+Tab combo does not open up Steam as I think it is meant to

 

6 - searched Google high and low for a solution with no success

 

....and probably every combination of these as well

 

Every time, when loading a save to which one is adding a new, OBSE dependent, mod, the game sulks and says OBSE isn't running

 

I'm just baffled.  Clearly the Steam/OBSE link, where Oblivion .exe is supposed to fire up OBSE via the steam loader.dll, is failing.  The 'Enable the Steam Overlay while in-game' functionality being unhinged may be the main cause, but I don't know how to fix that

 

Has anyone out there got the Steam game running with OBSE functioning properly?  In particular anyone doing so while also using MO?

 

 

Link to comment

i had minor problems with the Steam version myself (OBSE not injecting, rather random crashes a.s.o.) so i switched back to my CD version (before i bought the GotY DVD version).
Works from MO with OBSE, Oblivion Reloaded and most LAPK mods just fine.

But as i never managed to figure out why the Steam version gave me those problems, i can only recommend you to buy a hardcopy of the game.

i bought my GotY edition for 5€ and it only misses the one DLC that was only published in english and only available for a very short time.

Link to comment

No Steam game, all CD versions.

 

Maybe your install path ?   NEVER IN C:\program files (x86)  !!!

You can read my yellow Link below. for Steam and No Steam installation.  OBSE , 'Enable the Steam Overlay while in-game' ,....

Maybe you find something you haven't tried yet.

 

obse_loader.exe you don't need for Steam version, you can delete it ( But you use CS/CSE you need the obse_loader.exe. If you want to save a Mod with OBSE scripts you must start CS with OBSE )

 

Link to comment

i had minor problems with the Steam version myself (OBSE not injecting, rather random crashes a.s.o.) so i switched back to my CD version (before i bought the GotY DVD version).

Works from MO with OBSE, Oblivion Reloaded and most LAPK mods just fine.

 

But as i never managed to figure out why the Steam version gave me those problems, i can only recommend you to buy a hardcopy of the game.

i bought my GotY edition for 5€ and it only misses the one DLC that was only published in english and only available for a very short time.

 

 

No Steam game, all CD versions.

 

Maybe your install path ?   NEVER IN C:\program files (x86)  !!!

You can read my yellow Link below. for Steam and No Steam installation.  OBSE , 'Enable the Steam Overlay while in-game' ,....

Maybe you find something you haven't tried yet.

 

obse_loader.exe you don't need for Steam version, you can delete it ( But you use CS/CSE you need the obse_loader.exe. If you want to save a Mod with OBSE scripts you must start CS with OBSE )

 

Thank you both very much for taking the time and trouble to respond.  That's much appreciated!

 

I found a fix (Yay!) and have edited my original post to make that appear first in the thread

 

EDIT : modified the explanation slightly to clarify exactly how the OBSE plugins installation should be handled.  They can't be activated from within MO itself as they can be in Skyrim :-)

 

Thanks again

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...