Jump to content

Devious Devices Quest trouble


Recommended Posts

So I just installed Devious Devices Integration recently.
Followed the instructions carefully, installed all the requirements and when I try to do the Forbidden Tome Quest: Get the key, open the bookshelf, take the books and read them but no Quest notification shows up. I tried talking to Urag about the book but the book dialogue option is nowhere to be found. He did not talk to me as soon as I took the books. I tried many times but still no results. Tried clean reinstalling. Still, nothing happens. Anyone can help me?

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use