Jump to content

Help Please: FNIS run in MO always missing hkx files now


ntblood

Recommended Posts

I was running FNIS just fine from within MO at first but now it's always gives errors missing hkx animation files. First it was 1hm_behavior.hkx  but I moved the Unofficial Skyrim Patch so where that file came from wouldn't be overwritten. That fixed it for that file but then dogbehavior said it was missing. So I think I disabled Dawnguard plugin that I guess caused that to only get a third error message from FNIS that draugrbehavior.hkx now cannot be found.   Argh!

I've searched the forums about this and found not much.

I've done what it said in the step tutorial page for setting up FNIS with MO. I think FNIS is looking in the Syrim game folder for these files because that's where the FNIS error says it's missing from. I didn't install MO in my skyrim folder like some people I see have. I didn't think it was necessary and still would be surprised if it is.

Any help would be greatly appreciated. I've been working a very long time to get my game working and learning MO is a bit overwhelming.
 

Link to comment

No worries man I didnt install MO in my skyrim folder either it.

 

 

How are you activating your FNIS?

 

 

Through MO or another way you might have to install it again maybe something messed up or MO and FNIS can't determine their correct folder paths.

 

 

Give it a whirl and hit me back.

Link to comment

I've tried installing FNIS straight into the Skyrim data folder and then run it through Mod Organizer to get it to work but that didn't help.

 I manually installed "fnis always necessary" in the game folder as well as installed it in MO. If I target (*addresses below) either to launch fnis within MO I get the same missing 1hm_behavioir.hkx  error.

Do you just leave fnis wherever LOOT puts it in the LO or do you have to move it to the bottom? It doesn't seem like either place helps.

*
E:\Program Files (x86)\Mod Organizer\mods\FNIS Behavior V5 1 1 -- ALWAYS necessary\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
*
E:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
 

Link to comment

If I uncheck Ultimate Combat then all my fnis errors go away.    I found I can have fnis-always necessary, fnis-spells, and fnis-creatures all installed in MO, or manually, it doesn't seem to matter as long as the executable is targeted in MO correctly (gears button in MO).   My huge issue seems to have been with Ultimate Combat. I would like to use Ultimate Combat so it would be nice to further resolve this but at least fnis will run without it.

  This took me a long time to get some handle on. How fnis was installed had nothing to do with my fnis missing behavior errors.

Link to comment
  • 1 month later...

 I was able to Ultimate Combat enabled in my LO for the past month nearly and I didn't get any FNIS errors but now they've just come back. First it couldn't find 1h_weaponbehavior.hkx or some such file. Then I changed the priority of Ultimate Combat so nothing was overwriting it in MO and then FNIS was missing dogbehavior.hkx. I tried fixing my issue by disabling Ultimate Combat mod because I remember it fixed all of this before but that didn't work. FNIS run in MO is for some reason not finding the Creature pack. Re-installing FNIS didn't help. Aha, removing the Creature Pack mod & Ultimate Combat allow FNIS to finish without terminating errors for me now. I've a bit later been able to add Ultimate Combat back in as long as I had it's priority # in MO high enough that so many to no other mods are over-writing it. I hope I can add FNIS Creature pack back in a bit later too without FNIS giving me terminating errors. *update: creature pack is still causing terminating errors when running FNIS so it's still out of my game for now.

 

Link to comment

In My Mod Organiser setup, on My Left Pane FNIS Behaviour Files is #37 in Priority, FNIS Creatures is #38.

I have installed both Mods exactly as the STEP Video for using FNIS with MO explained.

I have set the Executable in MO for FNIS to look in C:...\Skyrim\ModOrganiser\mods\FNIS Behaviour\tools\GenerateFNIS_for_Users\...

I then tested to make sure MO has registered the correct FNIS (I am using the 5.2.1 Beta), MO seems to dislike registering the Executables correctly on a first install of an update of FNIS.

I have not had any issues once MO has registered the correct Executable.

I have heard that older versions of FNIS did not work correctly with Mod Organiser, and many Users report the same problems with 5.1.1. The cure may be to keep rerunning the FNIS Generator until it works correctly. 

I also use Wrye Bash and BAIN and have never had any problems with FNIS, but I also pay a lot of attention to what gets overwritten by Mods and I learned how important Install Order of Mods was when playing Oblivion.

Link to comment
  • 3 weeks later...
  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...