Jump to content

What needs to be changed in a nif file to go from static to wearable?

Recommended Posts

Lets see...First off I'm a complete noob to nifscope so I'm unsure of what I'll have to change to get the following to work in game.


On to the issue I've run into:

I'm trying to take the key mesh (found in the skyrim - meshes.esm/clutter/key01.nif and key02.nif) and add them to a set of nipple piercings.


Now I've done enough of the work so they show up and look good in Outfit Studio.

But they do not show up in game, nor do they show up in nifscope (the chain part will show up in game as well as in nifscope but the keys do not).


NSFW image




In the above image I used key02.nif for the right_key and key01.nif for the left_key (sub mesh names in the top right panel of OS).


To get them into the same nif file I had to open them separately in OS and then save each one as an *.obj object file.

Once I imported the object files back into OS I had to redo the texture mappings (which was strange).

The texture mappings currently point to: textures\devious\devices\key01.nif (and key01_n.nif) for the left_key and key02.nif (and key02_n.nif) for the right_key.


I read a while back on a thread somewhere about changing a 1 handed weapon to a 2 handed you would need to edit some string data in nifscope as well as set the basic stuff up in the CK for an esp.

I'm wondering if that is something I'll have to do to the keys as well as they list clutter in some of the string data in nif scope...


If anyone wants to play with it (and maybe fix it)... I'll attach the nif as well.

Devious Nipple Keys.nif


If someone fix's it, please tell me what was done so I can learn to do this next time...

Thanks in advance

Link to comment

You need to skin them.


I highly suggest you don't use Outfit Studio for that.


Get a proper 3d software creation program and start doing these sorts of things.


Outfit Studio is just not meant to do things that were outside of it's skope

Link to comment

It has NOT been a good day for me...


The day started out looking good....

I was able to put the parts together in nifscope first (copy branch from one nifscope instance to another).

Adjusted the size of the keys, moved them to the correct locations, properly rotated...

Then tested in Outfit Studio and was so damn close (I thought I was so there) and it was close...

Then I was pointed to the skin dismemberment data and worked that out (or so I thought).


Hell I even put together a rough alpha that I thought might work ingame (thankfully I pulled it before to many downloaded it, there are 2 people that got it and are probabaly asking WTF)... No not even close.

Somehow the dismemberment data for the chain got copied to each of the keys... but the keys didn't have dismemberment data to begin with (which is strange as the keys are rendered in the game)... so I thought no big deal.... seems it a very big deal... and now onto what I've spent this afternoon try'n to figure out...


Lets see... tried blender and I can't read it. The letters are so damn small (f'n hate how microsoft set the text resize to not work properly with the 3d api known at Aero, it worked fine from NT 4.0 to XP and even in the older 3.11 for work groups and 9x platforms... but Hay it's Microsoft shit never works right after a new version is released).


Oh and did I mention I had the 64bit version of blender (v2.70a x86-64) but the blender plugins are for the older 2.56 32bit version or some such shit... and the installs want to install to my OS drive, and I have blender on a larger separate drive and the plugs shit themselves when I tell them to install somewhere other then the c:\f'n program files folder... yeah f'n asshat bullshit.


And don't even get me started on Autodesk...

I just spent the entire afternoon pulling the 64bit 2015 version... then come to find out it's not backwards compatible with the Autodesk's Max 64bit 2012 or 2013 nif plugin (Does no one underfuckingstand BACKWARDS COMPATIBILITY)... so I'm currently unistalling that (and going to hard delete the damn install files when I'm done)....


Tomorrow I might try to pull the 3D Max 2012 or 2013 version... I'm just so Pissed at why these programs are such a pain in the f'n ass that I'm about ready to give up on try'n this shit. I've been a system builder and IT support for over 15 years and worked for Fortune 500 companies, I wouldn't recommend any program that is not backwards compatible with it's previous version...



Makes we want to drink, but I don't drink or smoke... hell I play video games to relieve stress and I'm stressed out just try'n to make something work in a video game... Shit's more fun the trouble shoot VOIP when it came out (oooh ip conflicts due to subnet over use, cause someone didn't figure on add'n 50 phones lines using individual ip's to that subnet... yeah dem dare were da good old days... now you get a different subnet and hub for the phones -vs- the pc's and they all get firewall'd so the geek in the mailroom can surf porn on his phone's ip connection....lol)


End Rant... gonna go shoot some shit in Defiance's cause that's a stress relief!!!

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. For more information, see our Privacy Policy & Terms of Use