Jump to content
IGNORED

Playing Oblivion with a controller, or trying to, at least.


AwfulArchdemon

Recommended Posts

Okay. I just bought a Microsoft Windows/X-Box 360 controller to use to play Oblivion, because I saw someone on YouTube playing Obl with it, and it showed him doing specific things to prove it worked. Well, turns out he was failing miserably to mention that he was using a Pinnacle Gamer Profile to do that. So, I may have wasted $60, but at least this controller is wireless, which will make Skyrim far easier to play.

 

Does anyone know a sure-fire way to play using a controller?

I've read a few forums, and googled the crap out of "how to play Oblivion with a controller", and other similar searches, but all I keep getting are oblivion.ini changes that don't do shit. No matter how many changes I make, the game doesn't recognize the right or left triggers, or the right joystick. In fact, it tries so hard to ignore the damn right joystick, that if I "switch sticks" (make right stick do what left one did, and make the left one do what the right one did), they will BOTH do nothing.

 

JoyToKey doesn't recognize the right joystick either, and Pinnacle Gamer Profile (PGP) has an installer .exe that gives me a virus, and they haven't answered my post there.

 

Here is my post to PGP's staff:

 

Trojan: Win32 Generic

 I've seen one post on the forum saying that his comp detected a mal packer, which I assume is a virus. The response says that certain low-budget Anti-viruses can read it wrong, and give you a virus warning, and that higher-end AVs would read it correctly, and move on, and that PGP isn't a virus.

I need more convincing than that. I have a pretty nice AV (Kaspersky Internet Security '13). I've heard the same thing about tons of other things I've downloaded, but never once did I get a "false error" like that.

However, when I run the installer.exe from this page http://pinnaclegameprofiler.com/pc-c...lder-scrolls-4, I got a "yellow" warning from Kaspersky saying that there's suspicious activity coming from the file "similar to malware". It said Trojan: Generic32, so I clicked on [Terminate]. It was then that my error turned "red" icon4.png(critical virus activity), and my Kaspersky IS began deleting the files that were being downloaded from the program/installer. During the deletion process it told me that many of the .dll files (and some others I think) would not work correctly with my system (Windows 7). They were located in my sysWoW folder. My AV had quite a time getting rid of the files, but it managed.icon2.png



attachment.php?attachmentid=5082&d=13818

icon13.png
 
So, my question is obvious: Is there another place to download this installer, or maybe just a download that has the files I need zipped in .rar/.7z file, so I can just put the files in myself? I've never trusted installer. exe's, and I'm sure you see why. Almost every time I've ever run one, I've gotten a virus, and I don't mean a "warning".

Can I just have the files, instead of the installer? At this point, I doubt my AV will even let me run the installer, and I'm basically desperate to play Oblivion with a controller, since I get crushed when I try to use a keyboard and mouse to play it. smilie_sad.gif

 

 

Any help would be super appreciated. I won't even play the game if I can't use one of my controllers. I've tried with a Logitech Gamepad F310 too, but no gravy.

 

Thanks in advance. I'm sure I'm not the only one who desperately wants (needs) to play Oblivion with their controller. I'm also sure that one of our members has managed to do it.  :sleepy:

Link to comment

Daaaaam you're fast Truth!  :o Anyway, that's just not gonna happen. I don't use a computer desk. I have my comp hooked up to my big-ass TV, and my keyboard sitting on my ever-so-low coffee table. I cannot reach down and keep pressing all those keys, and it would take a lot of ghetto box stacking to create a "comfortable" way of using it without reaching down to the ground.

 

Let's not forget, I just bought a $60 wireless Windows controller to do this. I must get it working. I didn't go out and buy this thing for no reason. Like I said, I won't play Oblivion if I can't use a controller. I wouldn't play Skyrim that way either. I'd prefer 10 buttons in my hand over a hundred fecking keys on my table.

Link to comment

SOLVED

 

Finally! Took me all...damn...day to get this bitch working right, but after 15 hours, I finally fuck*ng got it working decently. There's only one drawback...your running is no longer analogue sensitive. It's really not so bad though. There are times when I only want to run, and times when I only want to walk, but rarely a time that I need to switch back and forth, so it isn't hurting me any. Every site I saw about this had one thing in common...they were all using JoytoKey. They were also using another program, but it seemed to be a different one in each vid. Turns out, you only need JoytoKey! Why the fffffuck evryone kept using 2 different programs is well beyond me, but here is the setup I ended up with. The only one that let's me function with a controller comfortably. The buttons are all pretty much what you think they'd be. Attack = right-trigger, pause = start button, sneak = L3 (left analogue button), and so on.

 

So, without further ado... here's the result of 15 hours of research made pitifully and embarrassingly easy:

 

post-111270-0-58314300-1381906502_thumb.jpg

 

post-111270-0-53338100-1381891567_thumb.jpg

 

JoytoKey

 

To download, click the [Direct Download Link] just below the big green stupid [Download Now] crap that only wants to sucker you into downloading a useless installer. What kind of world do we live in when the big "DOWNLOAD HERE" link is the thing you don't want to click!?

 

Just remember to go to your oblivion.ini in either Documents\My Games\Oblivion, or if you use Mod Organizer (and you SHOULD), go to C:\Program Files (x86)\Steam\SteamApps\common\Oblivion\profiles\[your profile name]. You'll see the oblivion.ini in there that you want to use to make all ini adjustments when using MO.

 

Also remember, if you leave your JoytoKey running when you aren't playing, your controller will still function the same way! You can move your cursor around with it, and do everything it's programmed to do. So 'A' will be your 'space bar', 'Y' is 'E', 'Start' is 'escape', and so on.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...