Jump to content
IGNORED

Skyrim Campfire Not Unequiping Armor


Recommended Posts

1 hour ago, MrLegendary said:

Hey, I'm using campfire along with frostfall and when I sit or lie down in my tent only my weapon and backback are unequiped. I have it set to unequip all in the MCM menu so I'm not sure what the issue is. Can I please have some help?

 

https://modwat.ch/u/Mr Legendary/plugins

This is a fairly shit "bug report".

 

What is the character wearing?  What body slots do those items occupy? What other mods do you have set to control clothing/outfits/equip management?  What have you tried already to isolate the problem?

Link to comment
6 minutes ago, Seijin8 said:

This is a fairly shit "bug report".

 

What is the character wearing?  What body slots do those items occupy? What other mods do you have set to control clothing/outfits/equip management?  What have you tried already to isolate the problem?

Wearing any armor seems to be what prevents it from being unequipped, regardless of what type of armor it is.

 

Steel helmet: Slot 31, Iron Armor: Slot 32, Iron Gauntlets: Slot 33, Iron Boots: Slot 37, Iron Shield: Slot 39, Black Wolf Skin Cloak: Slot 40. And then the items duplicate and show the same item on a different slot. Steel Helmet: Slot 42, Black Wolf Skin Cloak: Slot 46, Backpack, Brown Fur: Slot 47, Water Skin, Right: Slot 49, Iron Armor, Slot 52.

 

The only mod I believe I have that effects outfit management is Dual Sheath Redux, but I could be wrong. I've tried disabling it and it's patch in Mod Organiser and reloading but it didn't solve the issue. 

Link to comment
1 hour ago, MrLegendary said:

And then the items duplicate and show the same item on a different slot

How are you determining this?  Unless you have a mod that changes SkyUI, the slot numbers are normally hidden from view.

 

Regardless, most of the slots you listed are normal use cases.  For instance, slot 52 being added to Iron Armor is normal when using SOS, cloak on 40 and 46 is normal (it is blocking a tail from showing up and clipping through), Steel Helmets normally block circlets (slot 42) from being used at the same time, etc.

 

For the most part, that is normal mod and vanilla game activity.  The items aren't "duplicated", they are just occupying more than one slot, and that is normal.  This wouldn't be the source of the issue.

 

In general, for tracking down the source of a bug like this, I'd need to know what mod manager you are using.  If it is MO/MO2, then tracking the problem can be fairly easy.  For other mod managers, it can be a bit more problematic.

Link to comment
7 minutes ago, Seijin8 said:

How are you determining this?  Unless you have a mod that changes SkyUI, the slot numbers are normally hidden from view.

 

Regardless, most of the slots you listed are normal use cases.  For instance, slot 52 being added to Iron Armor is normal when using SOS, cloak on 40 and 46 is normal (it is blocking a tail from showing up and clipping through), Steel Helmets normally block circlets (slot 42) from being used at the same time, etc.

 

For the most part, that is normal mod and vanilla game activity.  The items aren't "duplicated", they are just occupying more than one slot, and that is normal.  This wouldn't be the source of the issue.

 

In general, for tracking down the source of a bug like this, I'd need to know what mod manager you are using.  If it is MO/MO2, then tracking the problem can be fairly easy.  For other mod managers, it can be a bit more problematic.

I was determining them using this mod here. https://www.nexusmods.com/skyrim/mods/64976 And I am using MO2.

Link to comment
1 hour ago, MrLegendary said:

I was determining them using this mod here. https://www.nexusmods.com/skyrim/mods/64976 And I am using MO2.

Good. 

 

1) Start a new game with your existing load order, then set up campfires to your liking and test.  This will tell you if the issue is save-game related (something went wonky in your save), or load order related (the expected bug shows up right away in a new game).

 

2) Assuming it is load-order related (or a mod conflict of some type), then the best option when you run into something like this is to make a copy of your current profile, and start turning off half the mods in the load order, load the savegame and test to see what happens, repeat until you find what is causing the incompatibility.

 

3) If the above method fails, then strip the load order down to the absolute minimum needed to get the basic state setup (Base game and DLCs, Racemenu, Campfire, any of their requirements like SkyUI) and start a new game, set up like in #1 (set up campfires and test) and make sure it is working as expected, then add mods in chunks until it starts misbehaving.  Once it does that, roll it back by a few mods and re-test, and do this until the misbehavior shows up and you can isolate the one mod doing it.

 

(In the event that the issue shows up even in this state, check on campfires in the left panel of MO2 and make sure nothing is overwriting it or and script files in it.)

 

4) Upon finding the problem mod, read the mod description to see if it mentions something about load order (maybe LOOT or whatever sorting method put it in the wrong place), and if not, change the load order yourself (right after the master files, or all the way at the end) to see if this changes the behavior.

 

5) As the issue is likely related to scripting, further troubleshooting/conflict resolution gets tricky as it would then be another mod fighting with campfire's stripping mechanism.

Link to comment
15 minutes ago, Seijin8 said:

Good. 

 

1) Start a new game with your existing load order, then set up campfires to your liking and test.  This will tell you if the issue is save-game related (something went wonky in your save), or load order related (the expected bug shows up right away in a new game).

 

2) Assuming it is load-order related (or a mod conflict of some type), then the best option when you run into something like this is to make a copy of your current profile, and start turning off half the mods in the load order, load the savegame and test to see what happens, repeat until you find what is causing the incompatibility.

 

3) If the above method fails, then strip the load order down to the absolute minimum needed to get the basic state setup (Base game and DLCs, Racemenu, Campfire, any of their requirements like SkyUI) and start a new game, set up like in #1 (set up campfires and test) and make sure it is working as expected, then add mods in chunks until it starts misbehaving.  Once it does that, roll it back by a few mods and re-test, and do this until the misbehavior shows up and you can isolate the one mod doing it.

 

(In the event that the issue shows up even in this state, check on campfires in the left panel of MO2 and make sure nothing is overwriting it or and script files in it.)

 

4) Upon finding the problem mod, read the mod description to see if it mentions something about load order (maybe LOOT or whatever sorting method put it in the wrong place), and if not, change the load order yourself (right after the master files, or all the way at the end) to see if this changes the behavior.

 

5) As the issue is likely related to scripting, further troubleshooting/conflict resolution gets tricky as it would then be another mod fighting with campfire's stripping mechanism.

Huh... starting a new save fixed it. I can only assume that my removing a mod earlier in my current save broke something. Well, thanks for you help. I'll be sure to use your advice when something else inevitably breaks and I need to find the cause.

Link to comment
1 hour ago, MrLegendary said:

Huh... starting a new save fixed it. I can only assume that my removing a mod earlier in my current save broke something. Well, thanks for you help. I'll be sure to use your advice when something else inevitably breaks and I need to find the cause.

No problem.

 

If it is a save issue, that isn't the end of the world.  You can use Fallrim Tools to see if clearing out unattached script instances fixes it.  Sometimes waiting 24+ hrs can fix things, too.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...