Jump to content

Help - Skyrim SexLabMatchMaker.Rev7 Problems


Recommended Posts



I am having some trouble with SexLabMatchMaker.Rev7 not working on certain creatures in Skyrim. MatchMaker will work on horses and dogs (and humans), but no other creatures. My initial thought was to install Untamed to make the creatures friendly (after adding them to the pack) however this did not work. I also tried the setrelationshiprankplayer command (after adding to pack) to improve relationship and this did not work.


My load order is as follows:







SexLab.esm (Version 1.62)

SexLabAroused.esm (Redux Version 2.8)

CreatureFramework.esm (1.0.0)

Schlongs of Skyrim - Core.esm (2.05.021)

BadDogSchlongCore.esm (7.0.1)




FNIS.esp (7_0)

SkyUI.esp (5.1)

UIExtensions.esp (1-2-0)

RaceMenu.esp (3-4-5)

RaceMenuPlugin.esp (3-4-5)

SexLabTools.esp (3.0)

MoreNastyCritters.esp (10_4D)

SexLabNudeCreatures.esp (MNC 10_4D)

SexLabNudeCreaturesDG.esp (MNC 10_4D)

SexLabNudeCreaturesDB.esp (MNC 10_4D)

Dovabear.esp (MNC 10_4D Compatibility Kit)

HornyDragons.esp (0_99A)

SLAnimLoader.esp (1.5)

SexLabMatchMaker.esp (Rev7)

Schlongs of Skyrim.esp (3.00.004)

SOS - Smurf Average Addon.esp (3.00.004)

SOS - Shop.esp (3.00.004)

BDHoodieFemale.esp (7.0.1)

BDHoodieSchlong.esp (7.0.1)

BDLoincloth.esp (7.0.1)

RaceMenuMorphsUUNP (Bad Dog Hoodie Schlongs 7.0.1)

Alternate Start - Live Another Life.esp (3.1.7)

BDKhajitDigi.esp (Compleat Khajit 2.0)

argonianraptor.esp (Argonian Raptor Feet)

dc-untamed-000.esp (124)

SexLab Aroused Creatures.esp (03.1)


I have re-run FNIS and am running it with administrator privileges. I am also using Nexus Mod Manager. I do not have the Legendary Edition Patch because it was causing issues with game stability after I had installed Bad Dog Hoodie Schlongs.


Any and all help is appreciated. Thank you.

Link to comment


5. make sure you have "Allow Creature Animation" checked in SexLab's MCM settings.


6. turn off "Match Creature Gender" in sexlab's MCM settings, if this setting is enabled some animations won't play.


8. you may need to reload the animations, go to the Animation Loader's MCM and then:
8.1. click on the "Disable All" button.
8.2. click on "Rebuild Animation Registry", then Wait for the message to pop up*.
8.3. click on "Reload JSON".
8.4. click on "Enable All".
8.5. click on "Register Animations", then Wait for the message to pop up*.
*if you like you can press "~" on your keyboard to open the console so you can watch it Register everything, just make sure you close it before you try to click on anything.



Link to comment

This has fixed most of the problems, however there is still an issue with dragons specifically. When a dragon is encountered and the irresistibly attractive spell is cast upon them, the message displays "Your spell fizzles and fails to affect dragon." However, when sneaking up on a dragon and casting the spell undetected, the proper message of "Dragon has an irresistible aura about them" before the dragon notices and begins attacking. When the dragon begins attacking, no animation plays and the spell will fail if cast again. I cannot figure out why, as the spell now works on other hostile creatures such as wolves and bears.


I have a theory that the dragon animations are not working because I have not completed Dragon Rising (the quest that populates Skyrim with dragons). There also may be the issue that I used Alternate Start to start the game in Whiterun (I like to test mods in the fields to the east) so I have not yet encountered Alduin or any other dragon naturally. I tested the mod with dragons that I spawned using console commands.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...