Jump to content
Sign in to follow this  
BrimstoneOmega

Mod Organizer 2 Help

Recommended Posts

Alright, so I finally picked up Fallout 4 a few days ago, and played it a bit vanilla, and while I don't really have any specific problems with the game, I do love my  mods, I mean, who doesn't, aside from maybe Bethesda....

 

Anyways, I downloaded MO 2, did the ini files line adds stuff, at first I had some problems just getting MO2 to even load the game/launcher/FO4SE. Figured that one out, I can now get the game to load through MO, the Bethesda mods tab sees and recognizes the mods I have in MO, but the thing is, none of them actually run in the game. I tried to find the profiles file in MO to put the * in front of plugins, but could see no profile folder. I tried to run the script fix thing from Nexus (I know, super descriptive there) but that also needs to go in the profile file.

 

I was wondering if anyone knew some more, or could point me in the right direction of where to find the way to get this to work.

 

If I need to give some more info or take screenshots I will be happy to do so, and I'm sorry for making this thread, I tend to try to find out how to get things to work myself, but this has me stumped, seams like all the fixes are for the older versions of MO 2, I have the newest one that's supposed to did the * thing itself, but I'm not so sure it is, or maybe I messed things up. More likely it was me...

 

Thanks in advance.

Share this post


Link to post

Depending on what you chose after the installation when you first started MO2:

  • Portable: How it works for MO1, one instance for one game. All mods and settings are stored in the folder of MO2.
  • Regular: One MO2 instance/folder for all games you want to manage with it. This is probably what you chose.

In case of regular, settings are now in a folder in "%localappdata%\ModOrganizer". (I reinstalled MO2 after I chose this new option)

 

The newest, Beta1 worked fine some days ago for me. Newest LOOT worked as well.

There are some other issues like INI's not reading from the profile folder. Better keep the normal INI's and the ones inside MO2 exactly the same.

 

Move files from "%localappdata%\ModOrganizer". elsewhere if you want to keep settings and mods.

For now you need to reinstall MO2 to get the dialog to select the mode.

_________________________________________________________________________

EDIT:

 

Better method to set it to portable:

No re-installation, no download of files.

  1. Remove all files from "%localappdata%\ModOrganizer". Delete or backup somewhere (Downloads, Mods, Profiles)
  2. Remove "ModOrganizer.ini" (Backup optional, contains setup of executables)
  3. Delete the everything in the registry for "HKEY_CURRENT_USER\SOFTWARE\Tannin"
  4. Start MO2 and choose portable.
  5. If you backed up mods and profiles in Step 1, put them into the normal folder.

This resets all settings to the state before installing. Now you should get the option to choose portable.

Damn, till I found out how this worked. Just a teeny bit of source code reading and other debugging.

 

Share this post


Link to post

Depending on what you chose after the installation when you first started MO2:

  • Portable: How it works for MO1, one instance for one game. All mods and settings are stored in the folder of MO2.
  • Regular: One MO2 instance/folder for all games you want to manage with it. This is probably what you chose.

In case of regular, settings are now in a folder in "%localappdata%\ModOrganizer". (I reinstalled MO2 after I chose this new option)

 

The newest, Beta1 worked fine some days ago for me. Newest LOOT worked as well.

There are some other issues like INI's not reading from the profile folder. Better keep the normal INI's and the ones inside MO2 exactly the same.

 

Move files from "%localappdata%\ModOrganizer". elsewhere if you want to keep settings and mods.

For now you need to reinstall MO2 to get the dialog to select the mode.

_________________________________________________________________________

EDIT:

 

Better method to set it to portable:

No re-installation, no download of files.

  1. Remove all files from "%localappdata%\ModOrganizer". Delete or backup somewhere (Downloads, Mods, Profiles)
  2. Remove "ModOrganizer.ini" (Backup optional, contains setup of executables)
  3. Delete the everything in the registry for "HKEY_CURRENT_USER\SOFTWARE\Tannin"
  4. Start MO2 and choose portable.
  5. If you backed up mods and profiles in Step 1, put them into the normal folder.

This resets all settings to the state before installing. Now you should get the option to choose portable.

Damn, till I found out how this worked. Just a teeny bit of source code reading and other debugging.

 

Thank you so much! You're right, I did choose the regular one. I haven't seen this before, I will have to try it and get back to you on the results, for now I'm gonna get off to bed, it's getting late by me.

Thanks again for the reply and help.

 

Share this post


Link to post

Please excuse my foolishness, but where do I find %localappdata%\ModOrganizer? I did a search in my flies and I get nothing. Reinstalling doesn't give me the option to select the Portable or regular. I used run to delete the registry, but that alone still has no effect. At this point I'm a bit stumped.

Share this post


Link to post

What *.ini file changes are needed?

 

OK, found it. Had to add:

 

[Archive]

bInvalidateOlderFiles=1

sResourceDataDirsFinal=STRINGS\, TEXTURES\, SOUND\, MUSIC\, VIDEO\, MESHES\, PROGRAMS\, MATERIALS\, LODSETTINGS\, VIS\, MISC\, SCRIPTS\, SHADERSFX\

 

to Fallout4Custom.ini

located in C:\Users\UserName\Documents\My Games\Fallout4

Share this post


Link to post

Please excuse my foolishness, but where do I find %localappdata%\ModOrganizer? I did a search in my flies and I get nothing. Reinstalling doesn't give me the option to select the Portable or regular. I used run to delete the registry, but that alone still has no effect. At this point I'm a bit stumped.

 

Open start menu, and type "Show Hidden Files" and select the option that appears at the top of the menu. This should take you to the setting in the control panel. Enable viewing of hidden files, and apply.

 

AppData is hidden under C:\Users\Username

 

Under which you will find Local, LocalLow, and Roaming.

Share this post


Link to post

 

Please excuse my foolishness, but where do I find %localappdata%\ModOrganizer? I did a search in my flies and I get nothing. Reinstalling doesn't give me the option to select the Portable or regular. I used run to delete the registry, but that alone still has no effect. At this point I'm a bit stumped.

 

Open start menu, and type "Show Hidden Files" and select the option that appears at the top of the menu. This should take you to the setting in the control panel. Enable viewing of hidden files, and apply.

 

AppData is hidden under C:\Users\Username

 

Under which you will find Local, LocalLow, and Roaming.

 

 

Awesome! Thank you I found it now, was able to clear everything out and get Mod Organizer set to Portable.

 

Thanks so much Advint and Akzyra

 

Share this post


Link to post

if some one posts a path with %appdata%, %localappdata%, %temp% you can just put that in the adress bar of the file explorer.

These are variables that are easier than posting "C:\Users\USERNAME\Appdata\Local\..." every time.

 

If this problem persists I will write a small tool to atomate the switch between these two modes, but I hope tannin considers doing it himself (even if he will do it, probably not at the top of his TODO list which is very long)

Share this post


Link to post

Depending on what you chose after the installation when you first started MO2:

  • Portable: How it works for MO1, one instance for one game. All mods and settings are stored in the folder of MO2.
  • Regular: One MO2 instance/folder for all games you want to manage with it. This is probably what you chose.

In case of regular, settings are now in a folder in "%localappdata%\ModOrganizer". (I reinstalled MO2 after I chose this new option)

 

The newest, Beta1 worked fine some days ago for me. Newest LOOT worked as well.

There are some other issues like INI's not reading from the profile folder. Better keep the normal INI's and the ones inside MO2 exactly the same.

 

Move files from "%localappdata%\ModOrganizer". elsewhere if you want to keep settings and mods.

For now you need to reinstall MO2 to get the dialog to select the mode.

_________________________________________________________________________

EDIT:

 

Better method to set it to portable:

No re-installation, no download of files.

  1. Remove all files from "%localappdata%\ModOrganizer". Delete or backup somewhere (Downloads, Mods, Profiles)
  2. Remove "ModOrganizer.ini" (Backup optional, contains setup of executables)
  3. Delete the everything in the registry for "HKEY_CURRENT_USER\SOFTWARE\Tannin"
  4. Start MO2 and choose portable.
  5. If you backed up mods and profiles in Step 1, put them into the normal folder.

This resets all settings to the state before installing. Now you should get the option to choose portable.

Damn, till I found out how this worked. Just a teeny bit of source code reading and other debugging.

 

I've been having so many issues with MO2 trying to load up Bodyslide. This worked like a charm, thanks a lot mate. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×