Jump to content

FNIS - Unhandled exception

Recommended Posts

I'm using Skyrim Mod Organizer, and I'm trying to get SexLab working with it. When I run FNIS through MO, I end up getting an error. The normal output ends up looking like this:



>>Warning: Generator not run from a legal (Steam) Skyrim installation directory. If you use SKSE, this can be fixed by starting Skyrim once through Steam.<<
FNIS Behavior V5.5   7/5/2015 9:43:37 PM
Skyrim: -
Generator: C:\Games\Steam\steamapps\common\Skyrim\data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

Skeleton(hkx) female: Default (99 bones)   male: Default (99 bones)

Reading FNISBase V5.5 ...
Reading FNISCreatureVersion V5.3 ...
Reading FNISSpells V5.0.1  ( 0 furniture, 0 offset, 9 paired, 0 kill, 0 chair, 0 alternate animations) ...
Reading SexLab V1.59c ...
Reading SexLabCreature V1.59c ...

All Anim Lists scanned. Generating Behavior Files....
Generating animationsetdatasinglefile.txt ...

Create Creature Behaviors ...
Reading SexLabCreature V1.59c ...


and then I get a popup with the following error:



See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Exception: Application-defined or object-defined error.
   at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
   at GenerateFNISforUsers.GenerateFNISUsers.Execute_BehavioredObjects()
   at GenerateFNISforUsers.GenerateFNISUsers.Main()
   at GenerateFNISforUsers.GenerateFNISUsers.Button1_Click(Object sender, EventArgs e)
   at System.Windows.Forms.Control.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnClick(EventArgs e)
   at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
   at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at System.Windows.Forms.ButtonBase.WndProc(Message& m)
   at System.Windows.Forms.Button.WndProc(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
   at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
    Assembly Version:
    Win32 Version: 4.0.30319.18444 built by: FX451RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
    Assembly Version:
    Win32 Version:
    CodeBase: file:///C:/Games/Steam/steamapps/common/Skyrim/data/tools/GenerateFNIS_for_Users/GenerateFNISforUsers.exe
    Assembly Version:
    Win32 Version: 11.0.50938.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Microsoft.VisualBasic/v4.0_10.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    Assembly Version:
    Win32 Version: 4.0.30319.34238 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    Assembly Version:
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    Assembly Version:
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    Assembly Version:
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    Assembly Version:
    Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    Assembly Version:
    Win32 Version: 4.0.30319.34234 built by: FX452RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    Assembly Version:
    Win32 Version: 4.0.30319.34108 built by: FX45W81RTMGDR
    CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging

For example:

    <system.windows.forms jitDebugging="true" />

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


This only happens if I run FNIS with the SexLab Framework enabled. If I disable the Framework, it works just fine. Can anyone help me?


e: quick update - it works if I disable the FNIS Creature Pack.

Link to comment

Go here to post that question.. Many users and much experienced there on that thread.



However you likely have your setup for FNIS wrong.. You have to start it from MO.. from the STEPs page just in case it is an easy fix.


Fore's New Idles for Skyrim (FNIS)Fore's New Idles for Skyrim (FNIS)

Fore's New Idles for Skyrim (FNIS) maybe added in this manner:

  1. Click the gears Gear_MO.png button. This opens the Modify Executables window.
  2. In the Title field, type FNIS.
  3. For the Binary field, browse to your FNIS installation (should be located in <ModOrganizer>/mods/Fores New Idles in Skyrim - FNIS/tools/GenerateFNIS_for_Users) and select the GenerateFNISforUsers.exe application.
  4. Click the Add button. This will add FNIS to your executables list.
  5. Click Close to close the dialog.

Please note:

  • After closing FNIS, there will be files in Overwrite (essentially a fake mod located at the bottom of the Left Pane if sorted by priority ascending) created by FNIS. Right-click Overwrite and select Create Mod, name it FNIS Output and click OK. This will create a new mod listing in the Left Pane for the FNIS generated files. You will then need to check it to enable it. Each subsequent time you update FNIS behavior, you must open Overwrite and drag the new files back to this mod.
  • If you receive a This application cannot be started message, most likely you forgot to enable the mod in the Left Pane.

You have to activate Skyrim at least once outside of MO .. normally activate it and your path isn't the advised pathway for FNIS activation/ operation. Two things to try to resolve and / or fix..

Link to comment

You have to activate Skyrim at least once outside of MO .. normally activate it and your path isn't the advised pathway for FNIS activation/ operation. Two things to try to resolve and / or fix..


Thanks for the help, doing this managed to fix it.

Link to comment

Thought so.. :D. Sometimes the most simple fix is the hardest to find.


If you have other problems with MO installations etc post it at the unofficial MO thread. I don't always see new post and like other here I see response to post I am following or have posted into.. You can get very fast and accurate instruction and aid there.

Link to comment
  • 4 weeks later...

Were there any other options to take?


I'm getting the same error in the first post.


I tried running just the base game. I have the exact same problem, down to the exact error message. For some reason, the FNIS tool does NOT like the Creature Pack in Mod Organizer.


I can run FNIS successfully without the FNIS creature functionality.



Link to comment

Okay, here's my workaround that I found that worked for me.


First, I downloaded both FNIS and the FNIS for Creatures manually. I unzipped both files, then I merged the files completely together (meshes with the meshes, scripts with the scripts, etc.).


I then had one folder holding everything together. I then used 7zip to turn that file in to a zipped file and gave it its own custom name (Mine was FNIS creature Test). I then used Mod Organizer to pull that file into my list of mods.


From there, I created a new FNIS executable. I named it FNIS Creature 2 (I'm so creative x.x) and pointed it towards the FNIS for Users in the new mod in the Mod Organizer folder that I made from combining the two FNIS sections together. I also made sure to uncheck the FNIS boxes that I had previously for my other runs.


I ran that executable and FNIS worked! No weird error message and the creatures worked for the sexlab functions.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...