Jump to content

FNIS problem

Recommended Posts

Hello, I got a problem running FNIS...

Firstly I am using Mod Organizer, and FNIS is installed correctly through MO I believe.


When I run Vanilla Skyrim all animations work correctly, the actual problem is when I run only FNIS-base with female animations, it runs correctly & the female animations work in game but all creatures are static (not moving)

If I run FNIS with creature addon, female animations work correctly, still all creatures are static.


Here is the thing, if I run FNIS+creature addon with Sexlab & morenastycritters, all animations work fine in game.


I don't know why running only the FNIS base is affecting the creatures animations.


I also cleared out the generated files between testing, so no left over files are affecting each test.


All my animations work fine with Sexlab/morenasty critters installed, though I wanted to do a standard play through without Sexlab, with only the female animations.


Any Idea anyone?

Link to comment

Have you tried installing every mod you want to use in your non Sexlab playthrough on a clean Skyrim installation?
Did you clear out the generated files manually or did you use FNIS again after deinstalling Sexlab et cetera?

Link to comment


Firstly FNIS always runs perfectly without errors

On profiles I use Sexlab/MNC I have a mod created from the FNIS generated files activated, all those profile animations work fine.


On a new profile, I deactivate the Sexlab/MNC FNIS mod, then activate newly generated files as another mod, same problems.

I even tried deactivating all custom animations, generating a blank FNIS-base mod and still creatures are static.

If I deactivate FNIS in the MO left plain all vanilla animations start to work.


I tried validating files from steam, still I get the same problem.


Also, this may be worth mentioning the files relating to tails were missing and Khjati tails were static, which I fixed by manually adding an auxbone folder in data/meshes. Maybe I got some files missing that validating isn't replacing for some reason.

A thought, In data/meshes I currently have only 2 folders, actors & auxbones should there be more?

I've done everything bar a fresh install :/

Link to comment

I do not know about the auxbone folder since i do not have one, but if you have not done this already deinstalling FNIS-creatures via the GenerateFNISforUser.exe while having FNIS installed may help.

Edit: It seems i just overlooked the auxbone folder, i do have it in my heavily modded skyrim folder but maybe it is causing your problem, since it normally also contains mcn animations deleting/moving it could be worth a try.


Link to comment

First are you running just one install of MO or do you use different installs of MO for different profiles? When you run FNIS generator are you launching it from MO and are you sure you have it pointed at the correct install of FNIS? Have you always used MO or did you at one time overwrite your game files with mods? Are you using the current version of MO? Some older versions had problems with FNIS but that was some time ago. 

Link to comment

So glad I'm not alone in this!


This problem started a few days ago when I updated my mods, all animations work fine, FNIS runs without problems. But Argonians, Khajit and beasts rare static.


I updated the skeletons, but no avail. Any ideas you guys have would help alot.

Link to comment


This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...