Jump to content

Animations not working, despite using FNIS


Recommended Posts

I used FNIS 4 times, and yet it's still saying that I have not run it yet.  Anyone know why this might be occuring, or how to fix it?  I tested an animation from Defeat, and I just stand there making sex sounds, so its obviously not working.  Like I said, ive run FNIS, and it's just not working... and I dont know why.

Link to comment

I used FNIS 4 times, and yet it's still saying that I have not run it yet.  Anyone know why this might be occuring, or how to fix it?  I tested an animation from Defeat, and I just stand there making sex sounds, so its obviously not working.  Like I said, ive run FNIS, and it's just not working... and I dont know why.

 

Post you FNIS report it will normally show errors and why if thats the issue.

Link to comment
FNIS Behavior V5.1.1   12/14/2014 10:17:01 AM>>Warning: Bad installation. Generator not run from a Skyrim installation directory.<<
Skyrim: ??.?? - C:\Program Files (x86)\Steam\steamapps\common\Skyrim (Steam)
Generator: C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\FNIS Behavior 5.1.1\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe
>>Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users.<<
 
Skeleton female: Default (99 bones)   male: Default (99 bones)
Patch: "SKELETON Arm Fix" 
 
Reading FNIS V5.1.1 ...
Reading FNISBase V5.1.1 ...
 
All Anim Lists scanned. Generating Behavior Files ...
 
Creature Pack not installed
 
 129 animations for 2 mods successfully included (character)
 2 Warning(s).
 
If Im reading this correctly, its saying it needs to be installed into the Skyrim folder, but it is.  In fact, its also run correctly for me in the past from my Downloads folder, yet now it won't.  Im not sure what I did differently back then.  The actual directory is:
 

 

C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\FNIS Behavior 5.1.1\Data\tools\GenerateFNIS_for_Users

PS No idea why its quoting like this.  I tried to fix it twice, but it wont work for me either D:

Link to comment

Yea it's in the correct place although most wlll say not to run steam in programfiles(x86) I don't have any issues with that but you should run as administrator for pretty much everything including FNIS.

 

It's not reading Sexlab animations or defeat or anything as far as I can tell.

 

What are you using to install your mods? NMM, MO, or manual installaion?

Link to comment

I pretty much have the same thing to say here as the other poster having the same problem in the thread above this one. I have never used NMM and I have no advice on the correct way to do so. it's obviously and installation issue since SexLab and defeat are not showing up in FNIS. There are a lot of helpful people here I'm sure someone will see this later in the day and help you with the problem.

Link to comment

Alright, thank you for the help that you could give, Shane.  Even though you dont know how to fix it, the next person will see the information already posted between us talking and have more to go on.

 

there used to be an option in NMM that was off by default that would not install text files for mods which is needed for FNIS to read. I don't know if NMM was ever updated to have that on by default but that used to be a common problem and will cause this issue. If you can find that option in NMM or search on how to turn it on that could be your issue. You would have to reinstall SexLab and probably FNIS with that option turned on.

Link to comment

I think the error is shown in this lines :

 

Generator: C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\FNIS Behavior 5.1.1\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

>>Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users.<<

 

 

FNIS is not installed in the right directory, it should look like this:

C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe .

 

Can you copy the content of the "FNIS Behavior 5.1.1" folder into the "Skyrim" folder and run the generator from the new directory?

 
Link to comment

ARE YOU USING MOD ORGANIZER?

because if you are just create mod from the overwrite and activate it.

IF YOUR NOT USING MO

the...uhm..tick the box above the current ticked box.....

and uhm well maybe...check the required files for each mod and we cant see your load order so you may be missing ZaZ Animation pack and such

if you have all required files and FNIS is being awkward  then i got no idea.

Link to comment

I think the error is shown in this lines :

 

Generator: C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\FNIS Behavior 5.1.1\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

>>Warning: Bad installation. Generator not run from <Skyrim_Data>\Tools\GenerateFNIS_for_Users.<<

 

 

FNIS is not installed in the right directory, it should look like this:

C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe .

 

Can you copy the content of the "FNIS Behavior 5.1.1" folder into the "Skyrim" folder and run the generator from the new directory?

 

Wow I didn't even catch that good eye:

 

C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\FNIS Behavior 5.1.1\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe

 

looks similar but should be

 

C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\tools\GenerateFNIS_for_Users\GenerateFNISforUsers.exe .

 

as SaSD3 pointed out.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...