Jump to content

[SOLVED] Can't access ATI Catalyst Control Center


HentaiGnome

Recommended Posts

All of a sudden, my Catalyst Control Center (CCC) fails to open up (and I believe it was version 12.1). I'm not sure what happened because I don't recall doing anything major to my computer. And if anything, CCC was working fine for a whole year up until recently. I don't think it's a hardware problem because games still run fine with max settings, and I can still see the AMD Crossfire watermark label at the top-right corner, so I know my video cards are working. This is purely a software issue, but I need help figuring out how to fix it. I can still see the CCC icon on my taskbar, and I can even right-click on it to see the options, but nothing happens when I click on "AMD VISION Engine Control Center", "Help", or "About".

 

Things I've done:

 

- Uninstall and reinstall CCC.

- Ran "repair" option for CCC.

- Ensure I had .NET Frameworks (3 and 4) installed.

- Ran CCleaner to make sure there were no remnants of old CCC files.

 

I've already contacted AMD/ATI about this and I'm waiting for their response. I was hoping someone can help me fix this asap. Thanks!

 

My PC:

Windows 7 64-bit

8 GB Memory RAM

HIS HD Radeon 6950 (Crossfire mode)

AMD Phenom II x6 1100T 3.31 GHz CPU

 

RESOLVED: Reformatted my computer. Reinstalled the CCC and drivers. Everything seems to be working fine again. Thanks for trying to help. :blush:

Link to comment

I'll check that out. (result around 18.00 ,when I'm back again;)

Btw. did you notice that? :

Important ! Caution !

 

The AMD display driver and the AMD Catalyst Control Center / AMD Vision Engine Control Center can be downloaded independently of each other. However, for stability and performance AMD recommends that both components be updated from the same AMD Catalyst release.

The AMD Catalyst Control Center / AMD Vision Engine Control Center requires that the Microsoft .NET Framework SP1 be installed for Windows XP and Windows Vista. Without .NET SP1 installed, the AMD Catalyst Control Center / AMD Vision Engine Control Center will not launch properly and the user will see an error message.

 

Notes.

 

When installing the AMD Catalyst driver for Windows operating system, the user must be logged on as Administrator or have Administrator rights to complete the installation of the AMD Catalyst driver.

Link to comment

Yeah, I'm the admin of this computer. I even have UAC off. Like I said before, CCC has been working fine for a whole year up until earlier today, so it isn't anything due to installation issues. It's more like something (either another software or some update) just "popped up" out of nowhere and messed up my CCC.

 

Frankly, at this point, it's no use for me to figure out what the cause of the problem is. Instead, I should be focusing on just how to get the CCC window to open up again. It's weird because the icon is still in the taskbar and I can easily tweak my settings by right-clicking and choosing the options there, but if I click on the actual program to open up its own window, nothing appears, as if I never clicked on it.

 

I've also tried the so-called "fix" by looking for acertain Public Key Token under C:\Windows|assembly, but that key doesn't even appear on my computer. Looks to be like an outdated fix, I think the latest Catalyst drivers are installed differently.

Link to comment

Yep, I've disabled my antivirus (and I even ran antivirus just incase there was an infection). I've also disabled my firewall, but no luck either.

 

It could have been a windows update, but I have doubts on that. Throughout all these years of having CCC work, none of the windows updates have ever messed it up. If it did, I'd see this issue spread all over the Internet by now.

 

I'm like THIS close to reformatting my computer, but I'd rather find a simple solution first. Still waiting for ATI to respond, their customer service is slow as hell.

 

UPDATE: Nevermind guys. I decided to just reformat my computer. Besides, it's been a long time since I've done it and I realized with all the crap that I had on there I needed a reformat anyway. And yes, I did do my backups beforehand so don't worry lol. And at any rate, AMD/ATI is still taking a long time to respond so I can't wait for them.

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...