Jump to content
IGNORED

SOS causes everyone to be "trolled"


Recommended Posts

I have been using SOS for some time now, and I seem to have developed a problem out of the blue.  Nearly everyone (NPCs) I come in contact with is "trolled. "   I am not sure what being trolled means, except that the NPC being trolled has disappeared.  In some cases I am still able to converse with them and if they were someone I was supposed to meet with, the arrow is still present, but they are not.  It has also happened to bad guys when I am fighting with them.  It is very frustrating to have to fight someone who is beating up on you and is also invisible.  I would appreciate any help anyone can offer to me.  Thanks.

TonyB

 

PS  If I have already posted this I apologize.  It was recommended that I go to this site and try to find some help.

Link to comment

If you uninstall SoS does the issue go away? If you have not tried that, try that so we can be sure it is SoS causing the problem.

 

My next question is are you using the latest version of SoS? I ask because you indicate you was directed to this site and this site has the latest versions of SoS, the one on Nexus is very out of date.

Link to comment

I'm sorry, I thought that I had mentioned that.  Yes, the problem does go away when I turn SOS off.    When I turn SOS back on, the problem comes back after a little while.  I have tried several versions of SOS including SOS light that I have downloaded from this site, including 2.03.010b, 2.04.006, and 2.04.011 and have gotten similar results from each of these.   This is about the third request for help that I have done at different places, and I apologize for leaving out such important information. 

 

One thing I am curious about with these later versions is the open slots in mod management.  Are these open slots for different types of schlongs?  Or what?  BTW, I am using JoshNZ's AP version 5.12 since I did not like the fact that the partner puts her clothes back on while my player is still humping her in the 5.21 version.  That and no sparkles at orgasm.   I always thought those sparkles special for Dragonborn's sex since they are lacking when Lydia or one of my other followers has sex. 

 

I really enjoyed SOS especially since it got rid of those ugly "drawers" the men wear.  My player is a high elf female named Danar, and she really gets a kick out of seeing the penises of the guys she just killed in combat flop over when the SOS underwear disappears.  But then we all know that young elf females are promiscuous (ref:  The Real Barinziah series). 

Link to comment

Yes the one here has 3 different schlong styles you can pick during installation.

 

No worries about the info, just wanted to be sure.

 

My next question is have you tried a new game? I would try making a new character and going far enough along till you can test it. That will tell us something if it happens on new games or if it is just with your saved game. So if you don't mind make a new character and play till you can get to a point to try it and out and see if the same things happens.

Link to comment

OK, I don't mind doing that just for a test, but this will make like the fourth new game I have started in the past couple of weeks, so I will test this out and then probably go back to my current game.  Even if I have to look at ugly drawers on those guys.

TonyB

 

Thanks for your help.  I really do appreciate it.  Oh, and I know about those 3 different schlongs they are also in the version I got from Nexus.  The average, regular and muscular.  There were some slots, I think they were called "default" something that were in the mod manager.  Oh well, I'll try the new game this evening.

Link to comment

I just want to know if on a new game you get the error there as well. If you get it on a new game then we know it is the mod, if you don't get it on the game then we know it is in the save. Either can possible be fixed but knowing which helps.

Link to comment

OK, here's what happened.  I started a new game and activated SOS version 2.04.009.  I am at level 16 and have had no problems with it.  So I went back to where I had left off my other game and did not have any  problems with trolling, but everyone kept on their underwear.  Go figure.  So what I am doing is playing the new game I started yesterday and will continue to play it.  I am going to try really really hard to not add anymore mods to it and play it to the end.  If I have any problems with SOS, I will let you know if you want me to. 

 

How does that sound to you?

 

TonyB

Link to comment

Ok then if the new game worked fine then it sounds like something happened with the save of your old game. There are a few things you can try and do to fix your old game if you want.

 

1) Log onto you old game, find a place like in a house or a cleared dungeon where your PC is the ONLY character.

2) next tell SoS to clean/rebuild button. Wait for awhile till it is for sure done.

3) I forget if SoS has a disable button or not, if it does click that and disable the mod. Wait a good 5-10 mins. (or if there is no disable button just wait 10 mins after step 2)

4) Make a new save and then exit the game.

5) Go into NMM and deactivate and then remove SoS.

6) Log back into your last save you just made. Wait a good 5-10 mins for the MCM menu to remove SoS.

7) Make a new save at this point and exit SoS.

8 Reupload the latest SoS to NMM and activate the mod.

9) Use BOSS to sort your load order and run FNIS.

10) Log back into the newest save you made. Wait 10 mins till SoS has fully installed. Then try and leave the area you was in with no other people or creatures and go test to see if you have the same problem.

 

Hopefully doing a clean uninstall and clean reinstall will fix your old save. It might not but there is a pretty good chance it will, since you new game works.

 

If you are just happy playing your new game no worries, but the above might fix your old game if you are interested in it.

Link to comment

Thank you, that seems to have fixed the trolling problem, but I still have  the underwear issue.  These guys just do not take off their underwear I don't care if they are dead or having sex.  I installed version 2.04.011 and when I open up SOS in mod configuration I get three headings instead of the two I am used to seeing.  There are the usual two of "general settings" and VectorPlexus Regular."  Then there is another which is "missing schlong."  When I choose that I get a blank page.  I know that I did not mess up installing the mod in NMM; nothing could be simpler: three pages make a choice on each one regular or bodybuilder, hairy or hairless and choose one of three schlong types--I chose regular.  What is this missing schlong stuff and could that be the reason why the males keep on their underwear all the time?

 

Oh yeah, what is BOSS and do I need it?  Thanks again.

 

TonyB

Link to comment

For what it's worth, being "trolled" is what happens if someone drinks an "Essence of the Troll" potion, the ones you find on the bodies of slain trolls. If you drink those your penis goes bye-bye. Why it would be happening to NPCs in your game is beyond me.

Link to comment

BOSS is a load order sorting program and yes I strongly recommend you to use it, Since mods out of the correct load order can cause problems.

 

As for the underwear issue that sounds like it is related to the 3rd menu you have, It sounds like SoS is looking for another set of schlongs and can't find them so defaults to the underwear. Why it is doing that I am not sure. Nor at this moment am I sure how to fix that. Might want to search the SoS forum thread for the perma underwear bug I know it has come up before and there might be a fix buried somewhere in that forum thread.

 

You can find BOSS here

 

http://boss-developers.github.io/

 

Eventually it is going to be replaced by LOOT made by the same people but for now you can use BOSS just fine and it does help.

Link to comment

Well, I got to thinking (which is not always an easy task for me) and I tried several things including removing the underwear nifs I read about in b2lisario's forum and I suddenly remembered that SOS worked well in the new game I had tried out.  So, I removed SOS and then reinstalled version 009 which is the one I had used in the new game.  Guess what?! SOS works just like it is supposed to.  Imagine that.  So, I thank you for all your help and patience.  You have been a big help.   BTW I got both BOSS and LOOT.  I haven't tried LOOT yet, but BOSS seems to be OK.

 

Thanks again.

TonyB

Link to comment

Archived

This topic is now archived and is closed to further replies.

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...